Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse won't start anymore. Exit code = 4
Eclipse won't start anymore. Exit code = 4 [message #1749083] Thu, 01 December 2016 16:31 Go to next message
K. Simpson is currently offline K. SimpsonFriend
Messages: 1
Registered: December 2016
Junior Member
I was able to run Eclipse yesterday. My system ran a Windows update and, since the update, my IDE will no longer run. I am receiving two error prompts listed below. Please assist.

Prompt #1
---------------------------
Java Virtual Machine Launcher
---------------------------
Error: missing `server' JVM at `C:\Program Files (x86)\Java\jre1.8.0_111\bin\server\jvm.dll'.
Please install or use the JRE or JDK that contains these missing components.
---------------------------

Prompt #2
---------------------------
Eclipse
---------------------------
Java was started but returned exit code=4
C:\ProgramData\Oracle\Java\javapath\javaw.exe
-Dosgi.requiredJavaVersion=1.7
-Xms4096m
-Xmx12288m
-Xss1m
-server
-XX:-UseParallelGC
-XX:-UseParallelOldGC
-Dfile.encoding=UTF-8
-Dsvnkit.http.sslProtocols=SSLv3
-XX:MaxPermSize=256m
-jar C:\Documents\oca\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
-os win32
-ws win32
-arch x86_64
-showsplash C:\Documents\oca\\plugins\org.eclipse.platform_4.3.2.v20140221-1700\splash.bmp
-launcher C:\Documents\oca\eclipse.exe
-name Eclipse
--launcher.library C:\Documents\oca\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20140116-2212\eclipse_1503.dll
-startup C:\Documents\oca\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
--launcher.appendVmargs
-exitdata 2e08_60
-pluginCustomization plugin_customization.ini
-product org.eclipse.epp.package.jee.product
-vm C:\ProgramData\Oracle\Java\javapath\javaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.7
-Xms4096m
-Xmx12288m
-Xss1m
-server
-XX:-UseParallelGC
-XX:-UseParallelOldGC
-Dfile.encoding=UTF-8
-Dsvnkit.http.sslProtocols=SSLv3
-XX:MaxPermSize=256m
-jar C:\Documents\oca\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
---------------------------

[Updated on: Thu, 01 December 2016 20:25]

Report message to a moderator

Re: Eclipse won't start anymore. Exit code = 4 [message #1749116 is a reply to message #1749083] Fri, 02 December 2016 00:16 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3909
Registered: July 2009
Senior Member

It's strange that this would have worked before; you have a 32-bit JRE referenced in "C:\Program Files (x86)\Java\jre1.8.0_111" but a 64-bit Eclipse referenced with the launch arguments "-arch x86_64". You can't mix and match 32-bit code and 64-bit code within the same process., and it would also be worth using a version of Eclipse that's contemporary with your JRE version: Neon.1.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:How to recover from Project Refactor Trashed Directory Structure
Next Topic:frustrated about Web App start
Goto Forum:
  


Current Time: Wed Dec 02 10:32:50 GMT 2020

Powered by FUDForum. Page generated in 0.02952 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top