Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Build not working(Save is not doing a build (create class))
icon5.gif  Build not working [message #1745965] Wed, 19 October 2016 23:42 Go to next message
Paul Cathro is currently offline Paul CathroFriend
Messages: 2
Registered: October 2016
Location: Mechanicsburg, Pennsylvan...
Junior Member
Installed Eclipse Neon on my MAC and when I create a Java app and save it the Auto Build is not creating the Class file so I get the No Class found error when I run it.
Re: Build not working [message #1746048 is a reply to message #1745965] Thu, 20 October 2016 19:26 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3513
Registered: July 2009
Senior Member

Can you elaborate on what "create a Java app" means here, because this tends to work perfectly fine.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Build not working [message #1746053 is a reply to message #1746048] Thu, 20 October 2016 21:29 Go to previous message
Paul Cathro is currently offline Paul CathroFriend
Messages: 2
Registered: October 2016
Location: Mechanicsburg, Pennsylvan...
Junior Member
I downloaded the "eclipse-inst-mac64.tar.gz" from the Eclipse.org website on my MAC. Extracted the installer and ran it. It installed successfully. I installed the "Eclipse IDE for Java Developers" version. I then opened Eclipse in the Java perspective and clicked on the C icon to create a java class. I wrote a simple Hello World program and saved it. I checked the Project dropdown and Build Automatically is checked. But when I run it I get: "Error: Could not find or load main class misc.aaaaTest". If I look in the bin directory there are no folders for my packages and no class files. Doing the exact same thing on a Windows machine works fine.
Previous Topic:Trouble installing Neon version on Mac OSX
Next Topic:Java Virtual Memory Usage at Eclipse startup
Goto Forum:
  


Current Time: Mon Oct 21 04:37:22 GMT 2019

Powered by FUDForum. Page generated in 0.03076 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top