Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » http preview starts the wrong jdk (and then aborts)(Configuring the jdk for http preview)
http preview starts the wrong jdk (and then aborts) [message #1740660] Tue, 16 August 2016 19:46 Go to next message
Sean Rhody is currently offline Sean RhodyFriend
Messages: 1
Registered: August 2016
Junior Member
I'm running the latest Eclipse-Neon on a Mac running El Capitan. I have installed the latest JDK (1.8.x) and have relinked the /Library/Java/Home link to point to the 1.8 jdk rather than the 1.6 that is installed by default.

When I try to run an html file with HTTP Preview, it uses 1.6 to run, and since this version of eclipse wants a higher version, it aborts.

How do I configure Eclipse to launch preview with 1.8?
Re: http preview starts the wrong jdk (and then aborts) [message #1740668 is a reply to message #1740660] Wed, 17 August 2016 04:23 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30304
Registered: July 2009
Senior Member
Sean,

I'm not sure what HTTP Preview is, but if there are launchers involved,
Window -> Preferences -> Java -> Installed JREs lets you configure which
JREs are available for compiling and launching. Does that help?


On 16.08.2016 22:14, Sean Rhody wrote:
> I'm running the latest Eclipse-Neon on a Mac running El Capitan. I
> have installed the latest JDK (1.8.x) and have relinked the
> /Library/Java/Home link to point to the 1.8 jdk rather than the 1.6
> that is installed by default.
> When I try to run an html file with HTTP Preview, it uses 1.6 to run,
> and since this version of eclipse wants a higher version, it aborts.
> How do I configure Eclipse to launch preview with 1.8?
Previous Topic:Tomcat can not be started via Eclipse and XAMPP
Next Topic:PyDev debugging: do not open "_pydev_execfile" at the end
Goto Forum:
  


Current Time: Wed Jul 17 10:26:18 GMT 2019

Powered by FUDForum. Page generated in 0.03283 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top