Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't install Eclipse(problem install Eclipse)
icon5.gif  Can't install Eclipse [message #1737345] Thu, 07 July 2016 12:25 Go to next message
Olga Fokina is currently offline Olga FokinaFriend
Messages: 1
Registered: July 2016
Junior Member
I can not install Eclipse Neon. I'm downloading the .exe file, then open it and ... the browser throws me to a page warning that it can not find Java. But, java already installed.
java path: C:\Program Files (x86)\Java\jdk1.8.0_91

Help pls.
Re: Can't install Eclipse [message #1741944 is a reply to message #1737345] Tue, 30 August 2016 17:30 Go to previous messageGo to next message
Mason Schulze is currently offline Mason SchulzeFriend
Messages: 2
Registered: August 2016
Junior Member
I have the same problem. I did a clean install with the latest version of Java both the jdk and jre. I also tried adding both of them to my path and that didn't help either. I'm on Windows 10 the Java version is Java 8 102.
Re: Can't install Eclipse [message #1742057 is a reply to message #1741944] Tue, 30 August 2016 20:46 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30452
Registered: July 2009
Senior Member
Does the bitness of the Java you have installed match the bitness of what you've downloaded? So specifically, at which file system location is your Java installed, and specifically which download link did you download?
Re: Can't install Eclipse [message #1742061 is a reply to message #1742057] Tue, 30 August 2016 22:55 Go to previous messageGo to next message
Mason Schulze is currently offline Mason SchulzeFriend
Messages: 2
Registered: August 2016
Junior Member
Both of mine are 64 bit versions. My java is at path:C:\Program Files (x86)\Java\jre1.8.0_102\bin
I used the download link on this page https://www.eclipse.org/downloads/download.php?file=/oomph/epp/neon/R/eclipse-inst-win64.exe
Running the installer sends me here http://download.eclipse.org/oomph/jre/?vm=1_1_7_0_64_0&pn=Eclipse%20Installer&pu=http://wiki.eclipse.org/Eclipse_Installer&pi=http://download.eclipse.org/oomph/jre/128x128.png
I also have the jdk at this address path:C:\Program Files (x86)\Java\jdk1.8.0_102\bin
Re: Can't install Eclipse [message #1742063 is a reply to message #1742061] Wed, 31 August 2016 01:04 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
You claim that your JDK and JRE are 64-bit, but 64-bit programs are NOT stored under C:/Program Files (x86) - that where Windows puts 32-bit programs.
Have you looked at the Announcement post at the top of this forum group, the one titled "Eclipse Won't Start? Read this first"
Re: Can't install Eclipse [message #1743073 is a reply to message #1742063] Sat, 10 September 2016 10:22 Go to previous message
Abelardo Mising name is currently offline Abelardo Mising nameFriend
Messages: 6
Registered: April 2010
Junior Member
Hello world!

I downloaded the Eclipse NEON for MAC OS X version.

In the middle of the installation, this message was showed:

Previous messages:
[2016-09-10 11:07:49] Executing bootstrap tasks
[2016-09-10 11:07:49] Java(TM) SE Runtime Environment 1.8.0_91-b14
[2016-09-10 11:07:49] Product org.eclipse.products.epp.package.php.neon
[2016-09-10 11:07:49] Bundle org.eclipse.oomph.setup 1.4.0.v20160530-1355, build=2444, branch=d2a285619d608146f2b29fa5d42db7d6201863c2
[2016-09-10 11:07:49] Bundle org.eclipse.oomph.setup.core 1.4.0.v20160530-1200, build=2444, branch=d2a285619d608146f2b29fa5d42db7d6201863c2
[2016-09-10 11:07:49] Bundle org.eclipse.oomph.setup.p2 1.4.0.v20160530-1200, build=2444, branch=d2a285619d608146f2b29fa5d42db7d6201863c2
[2016-09-10 11:07:49] Performing P2 Director (Eclipse IDE for PHP Developers (Neon))
[2016-09-10 11:07:49] Offline = false
[2016-09-10 11:07:49] Mirrors = true
[2016-09-10 11:07:49] Resolving 4 requirements from 3 repositories to .../ECLIPSE/php-neon/Eclipse.app/Contents/Eclipse
[2016-09-10 11:07:49] Requirement epp.package.php [4.6.0,4.7.0)
[2016-09-10 11:07:49] Requirement org.eclipse.platform.feature.group [4.6.0,4.7.0)
[2016-09-10 11:07:49] Requirement org.eclipse.rcp.feature.group [4.6.0,4.7.0)
[2016-09-10 11:07:49] Requirement org.eclipse.oomph.setup.feature.group
[2016-09-10 11:07:49] Repository http://download.eclipse.org/technology/epp/packages/neon/M5
[2016-09-10 11:07:49] Repository http://download.eclipse.org/releases/neon/201602051000
[2016-09-10 11:07:49] Repository http://download.eclipse.org/oomph/updates/milestone/latest

Error:
[2016-09-10 11:04:41] ERROR: org.eclipse.equinox.p2.metadata.repository code=1000 No repository found at http://download.eclipse.org/releases/neon/201602051000.
at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.fail(AbstractRepositoryManager.java:395)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:116)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.fail(CachingRepositoryManager.java:314)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:217)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(CachingRepositoryManager.java:437)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:96)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:92)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$RepositoryLoader$Worker.perform(ProfileTransactionImpl.java:1625)
at org.eclipse.oomph.util.WorkerPool$Worker.run(WorkerPool.java:416)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

My system is:
- OS X 10.11.5 (15F34)
- java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode)


What's wrong?


***** EDITED (1) ***********
The installer was updated; then, it could start!

I upload a screenshot where a signal located on right top can be seen to update it.

WARNING: if you have a slow Internet connection, several warnings can appear during the installation process:

Artifact download is progressing very slowly from the following hosts: http://ftp.fau.de, http://mirrors.nic.cz, http://ftp-stud.fht-esslingen.de, http://mirror.netcologne.de

This installation can take long time. Be patient.

MODERATORS: I encourage to you to update the post "ECLIPSE CAN'T INSTALL?" in order to add this information. Smile

[Updated on: Sat, 10 September 2016 10:50]

Report message to a moderator

Previous Topic:Reports for SVN repositories
Next Topic:Eclipse git project with git externals
Goto Forum:
  


Current Time: Fri Sep 20 07:30:47 GMT 2019

Powered by FUDForum. Page generated in 0.02268 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top