Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Error using JGIT CLONE(Cloning JGIT SSL connections not throttled)
Error using JGIT CLONE [message #1737282] Wed, 06 July 2016 21:21 Go to next message
Frank Myers is currently offline Frank MyersFriend
Messages: 1
Registered: July 2016
Junior Member

I'm using jgit version
I ran a "hgit clone" at the command line which resulted in :
Cloning into '/u/FOMYERS/usspfs2'...
org.eclipse.jgit.api.errors.TransportException: connection is closed by foreign host
at org.eclipse.jgit.api.CloneCommand.fetch(
at org.eclipse.jgit.pgm.TextBuiltin.execute(
at org.eclipse.jgit.pgm.Main.execute(
at org.eclipse.jgit.pgm.Main.main(
Caused by: org.eclipse.jgit.errors.TransportException: connection is closed by foreign host
at org.eclipse.jgit.transport.JschConfigSessionFactory.getSession(
at org.eclipse.jgit.transport.SshTransport.getSession(
at org.eclipse.jgit.transport.TransportGitSsh$SshFetchConnection.<init>(
at org.eclipse.jgit.transport.TransportGitSsh.openFetch(
at org.eclipse.jgit.transport.FetchProcess.executeImp(
at org.eclipse.jgit.transport.FetchProcess.execute(
at org.eclipse.jgit.transport.Transport.fetch(
... 7 more
Caused by: com.jcraft.jsch.JSchException: connection is closed by foreign host
at com.jcraft.jsch.Session.connect(
at org.eclipse.jgit.transport.JschConfigSessionFactory.getSession(
... 14 more

I suspect that the "connection is closed by foreign host" could be that I'm overloading the git server (too many SSL connections).
I tried the same using "git" rather than jgit, and it worked fine.
Has anyone seen this before? Any suggestions on how to get past this?

Re: Error using JGIT CLONE [message #1737409 is a reply to message #1737282] Thu, 07 July 2016 20:54 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1154
Registered: July 2009
Senior Member
Ask an admin if your git server has an error log for your failed requests.
Previous Topic:eGit with old Eclipse version
Next Topic:Could not initialize class org.eclipse.jgit.util.FS
Goto Forum:

Current Time: Sun Sep 20 08:49:43 GMT 2020

Powered by FUDForum. Page generated in 0.01499 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top