Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Newbie requests help with Eclipse installation (PHP & JavaScript)(Eclipse PHP & Eclipse JavaScript)
Newbie requests help with Eclipse installation (PHP & JavaScript) [message #1737185] Wed, 06 July 2016 09:25 Go to next message
Laxman ObalapuramFriend
Messages: 4
Registered: July 2016
Junior Member
Hi all,

Recently, I have started learning HTML5, JavaScript, XML, and PHP. When I looked up Google for a good IDE for JavaScript & PHP, I was recommended Eclipse.

I see that Eclipse Neon 4.6 is out; for JavaScript support & PHP, I need to install packages/plug-ins. So, I need to install three files.

Eclipse 4.6 (64 bit): https://www.eclipse.org/downloads/download.php?file=/oomph/epp/neon/R/eclipse-inst-win64.exe
Eclipse PHP (64 bit): https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/neon/R/eclipse-php-neon-R-win32-x86_64.zip
Eclipse JavaScript (64 bit): https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/neon/R/eclipse-javascript-neon-R-win32-x86_64.zip

Am I correct?

Thanks in advance for your replies!


---
Laxman Obalapuram
My setup: Win 10 (64 bit), Java v8 update 91 (64 bit), Eclipse Neon 4.6, WAMPServer 3.0.0 (64 bit), PHP: 5.6.16, Apache: 2.4.17, Firefox 47.0.1
Re: Newbie requests help with Eclipse installation (PHP & JavaScript) [message #1737271 is a reply to message #1737185] Wed, 06 July 2016 18:31 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 502
Registered: August 2014
Senior Member
The installer is OK to load. To use it, you need a reasonably recent 64-bit Java in your computer. The installer complains, if it is not there.

Use the installer to install 'Eclipse IDE for JavaScript and Web Developers'.

Start up the installed Eclipse, use its Help -> Install New Software menu to install from Neon repository the PHP Development Tools from the Web XML Java EE and OSGI Development subtree.


--

Tauno Voipio
Re: Newbie requests help with Eclipse installation (PHP & JavaScript) [message #1737288 is a reply to message #1737271] Wed, 06 July 2016 23:55 Go to previous messageGo to next message
Laxman ObalapuramFriend
Messages: 4
Registered: July 2016
Junior Member
Hello Tauno,

Thanks for your reply!

I have recently installed Java v8 update 91; I hope it is 64 bit (I have Win 10 64 bit and it must have automatically installed Java 64 bit).

I will start off with Eclipse Neon 4.6 (64 bit), then install Eclipse IDE for JavaScript and Web Developers. Using Eclipse 4.6, I install PHP Dev Tools.

Will post here if I have any difficulty.


---
Laxman Obalapuram
My setup: Win 10 (64 bit), Java v8 update 91 (64 bit), Eclipse Neon 4.6, WAMPServer 3.0.0 (64 bit), PHP: 5.6.16, Apache: 2.4.17, Firefox 47.0.1
Re: Newbie requests help with Eclipse installation (PHP & JavaScript) [message #1737341 is a reply to message #1737288] Thu, 07 July 2016 11:37 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 502
Registered: August 2014
Senior Member
You can check the Java version by opening the command prompt and writing

java -version

and read the details from the response.

The bitness is no great problem. The installer is smart enough to complain if there is a mismatch.



--

Tauno Voipio
icon14.gif  Re: Newbie requests help with Eclipse installation (PHP & JavaScript) [message #1737416 is a reply to message #1737341] Fri, 08 July 2016 00:26 Go to previous messageGo to next message
Laxman ObalapuramFriend
Messages: 4
Registered: July 2016
Junior Member
Hi Tauno,

When I ran the command 'java -version' at command prompt, the output is:
java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.91-b15, mixed mode)


Also, I could successfully install Eclipse Neon 4.6 (64 bit) for Javascript and web development, and install PHP plugin/package too. So, I am good for now; thanks for your help Smile

Any good books/web sites that walk through newbies like me to learn/understand features of Eclipse (PHP wise)? I see websites that talk about using Eclipse for Java coding, Java classes, Java packages etc. Any pointers will be deeply appreciated!


---
Laxman Obalapuram
My setup: Win 10 (64 bit), Java v8 update 91 (64 bit), Eclipse Neon 4.6, WAMPServer 3.0.0 (64 bit), PHP: 5.6.16, Apache: 2.4.17, Firefox 47.0.1
Re: Newbie requests help with Eclipse installation (PHP & JavaScript) [message #1737495 is a reply to message #1737416] Fri, 08 July 2016 16:35 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 502
Registered: August 2014
Senior Member
The Eclipse documentation is at <http://help.eclipse.org/neon/index.jsp>.

You should have the applicable pieces installed on your system and accessible via the Help menu. There is a part on PHP.

If you are not familiar with the Eclipse workbench, start with Workbench User Guide.



--

Tauno Voipio
Previous Topic:Cannot run Eclipse (new install)
Next Topic:workspace mechanic plugin download is broken
Goto Forum:
  


Current Time: Tue Oct 22 09:00:58 GMT 2019

Powered by FUDForum. Page generated in 0.03868 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top