Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » How to get eclipse base plugins jar
How to get eclipse base plugins jar [message #1736029] Fri, 24 June 2016 13:26 Go to next message
Umesh Thakare is currently offline Umesh ThakareFriend
Messages: 12
Registered: February 2016
Junior Member
Hi

I am trying to build my own plugins using maven. which are using the below dependency
org.eclipse.core.runtime;bundle-version="3.11.0"

I am able to compiled successfully these set of plugin in my local eclipse 4.5.
However when I try to build the same set of plugin from maven with the help of nexus url which actually points to eclipse release url "http://download.eclipse.org/releases/mars/" repository created as below in my pom.xml

<repository>
<id>eclipse-mars</id>
<url>https://dsnexus-xxx:8083/nexus/content/repositories/eclipse-mars-release</url>
<layout>p2</layout>
</repository>

so this nexus url is unable to find the above bundle(org.eclipse.core.runtime 3.11.0) and giving below error.

" Missing requirement: com.modelling.emf.castormapping1_0 1.0.0.qualifier requires 'bundle org.eclipse.core.runtime 3.11.1' but it could not be found "

When I checked in nexus and found that org.eclipse.core.runtime 3.11.0 plugin is not there it means its not present at "http://download.eclipse.org/releases/mars/" also.
and the above bundle/jars resides under installed eclipse plugin folder and that was the reason it gets compiled in local eclipse.

Till now I was assuming that all the basic jars will be available in eclipse release repository but that is not the case.
So my question is, is there any eclipse repository url which will have all the basic plugins are resides. Please let me know if there is any update sites where all the eclipse base plugins are available.

[Updated on: Mon, 27 June 2016 04:47]

Report message to a moderator

Re: How to get eclipse base plugins jar [message #1736137 is a reply to message #1736029] Mon, 27 June 2016 04:48 Go to previous messageGo to next message
Umesh Thakare is currently offline Umesh ThakareFriend
Messages: 12
Registered: February 2016
Junior Member
Hey is any one have the solution?
Re: How to get eclipse base plugins jar [message #1736192 is a reply to message #1736029] Mon, 27 June 2016 12:10 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30641
Registered: July 2009
Senior Member
Mars is a composite and definitely contains version 3.11.1 from
org.eclipse.core.runtime. I can't say which versions are available in
Nexus. At Eclipse we generally use Tycho in conjunction with Maven
builds so that plugins can be downloaded directly from their update
sites rather than being resolved to whatever might be in Nexus.


On 24.06.2016 09:26, Umesh Thakare wrote:
> Hi
> I am trying to build my own plugins using maven. which are using the
> below dependency org.eclipse.core.runtime;bundle-version="3.11.0"
>
> I am able to compiled successfully these set of plugin in my local
> eclipse 4.5.
> However when I try to build the same set of plugin from maven with the
> help of nexus url which actually points to eclipse release url
> "http://download.eclipse.org/releases/mars/" repository created as
> below in my pom.xml
>
> <repository>
> <id>eclipse-mars</id>
> <url>https://dsnexus-xxx:8083/nexus/content/repositories/eclipse-mars-release</url>
> <layout>p2</layout>
> </repository>
>
> so this nexus url is unable to find the above
> bundle(org.eclipse.core.runtime 3.11.0) and giving below error.
>
> " Missing requirement: com.modelling.emf.castormapping1_0
> 1.0.0.qualifier requires 'bundle org.eclipse.core.runtime 3.11.1' but
> it could not be found "
>
> When I checked in nexus and found that org.eclipse.core.runtime 3.11.0
> plugin is not there it means its not present at
> "http://download.eclipse.org/releases/mars/" also. and the above
> bundle/jars resides under installed eclipse plugin folder and that was
> the reason it gets compiled in local eclipse.
>
> Till now I was assuming that all the basic jars will be available in
> eclipse release repository but that is not the case.
> So my question is, is there any eclipse repository url which will have
> all the basic plugins are resides. Please let me know if there is any
> update sites where all the eclipse base plugins are available.
Re: How to get eclipse base plugins jar [message #1736414 is a reply to message #1736192] Wed, 29 June 2016 10:44 Go to previous messageGo to next message
Umesh Thakare is currently offline Umesh ThakareFriend
Messages: 12
Registered: February 2016
Junior Member
Thanks Merks

I am using release mar(http://download.eclipse.org/releases/mars/) url, but i did not get below dependency.
" org.eclipse.core.runtime.3.11.1 "
It is not in release url.
Please help me how will i find it ?

[Updated on: Wed, 29 June 2016 10:45]

Report message to a moderator

Re: How to get eclipse base plugins jar [message #1736438 is a reply to message #1736414] Wed, 29 June 2016 12:16 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30641
Registered: July 2009
Senior Member
It is in the repository. More specifically it's in
http://download.eclipse.org/releases/mars/201602261000 and also in
http://download.eclipse.org/eclipse/updates/4.5/R-4.5.2-201602121500.
You can use this approach to find Eclipse repositories:

https://wiki.eclipse.org/Eclipse_Oomph_Authoring#How_to_find_a_P2_repository_at_Eclipse_using_the_Repository_Explorer


On 29.06.2016 06:44, Umesh Thakare wrote:
> Thanks Merks
>
> I am using mars release url but i did not get below dependency.
> " org.eclipse.core.runtime.3.11.1 "
> It is not in release url.
> Please help me how will i find it ?
>
Re: How to get eclipse base plugins jar [message #1737748 is a reply to message #1736438] Tue, 12 July 2016 13:07 Go to previous messageGo to next message
Umesh Thakare is currently offline Umesh ThakareFriend
Messages: 12
Registered: February 2016
Junior Member
Hi
I have tried the mars release url which you mention in your post but still i am facing the same issue.
So now i have created one sample application to check whether given url is working or not
I have created one hello world plugin in eclipse 4.5(mars). In which i have added two below dependency on the manifest file(MANIFEST.MF).
org.eclipse.core.runtime;bundle-version="3.11.1",
org.eclipse.emf.ecore;bundle-version="2.11.1"

And MANIFEST.MF file looks like below

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Maven_building
Bundle-SymbolicName: com.qvto.maven_building;singleton:=true
Bundle-Version: 1.0.0.qualifier
Bundle-Activator: com.qvto.maven_building.Activator
Bundle-Vendor: NAME
Require-Bundle: org.eclipse.ui;bundle-version="3.107.0",
org.eclipse.core.runtime;bundle-version="3.11.1",
org.eclipse.emf.ecore;bundle-version="2.11.1"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy

please find the snipped code of pom.xml which i have used to build my plugin using maven.
Please find the snipped code below:-

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>com.qvto.maven_building</groupId>
<artifactId>com.qvto.maven_building</artifactId>
<version>0.0.1-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<name>Engineering Tool Parent</name>

<properties>
<tycho-version>0.17.0</tycho-version>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
</properties>

<repositories>
<repository>
<id>mars-eclipse</id>
<layout>p2</layout>
<url>http://download.eclipse.org/releases/mars/201602261000/</url>
</repository>
</repositories>

<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-maven-plugin</artifactId>
<version>${tycho-version}</version>
<extensions>true</extensions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-compiler-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<source>1.6</source>
<target>1.6</target>
</configuration>
</plugin>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>target-platform-configuration</artifactId>
<version>${tycho-version}</version>
<configuration>
<resolver>p2</resolver>
<environments>
<environment>
<os>win32</os>
<ws>win32</ws>
<arch>x86</arch>
</environment>
<environment>
<os>linux</os>
<ws>gtk</ws>
<arch>x86</arch>
</environment>
</environments>
<filters>
<filter>
<type>eclipse-plugin</type>
<id>org.antlr.runtime</id>
<restrictTo>
<versionRange>[3.0.0,3.0.2)</versionRange>
</restrictTo>
</filter>
<filter>
<type>eclipse-plugin</type>
<id>com.google.inject</id>
<restrictTo>
<versionRange>[2.0.0,2.0.1)</versionRange>
</restrictTo>
</filter>
</filters>
</configuration>
</plugin>
</plugins>
</build>
</project>

So after adding dependency and creating pom when i try to build using maven, i face the below problem

Missing requirement: com.qvto.maven_building 1.0.0.qualifier requires 'bundle org.eclipse.core.runtime 3.11.1' but it could not be found

So still i am facing the same type of issue even i have change the repository which you share with us.
Please help me on this problem

[Updated on: Tue, 12 July 2016 13:11]

Report message to a moderator

Re: How to get eclipse base plugins jar [message #1737794 is a reply to message #1737748] Wed, 13 July 2016 05:18 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30641
Registered: July 2009
Senior Member
Umesh,

I'm not sure you're using Tycho correctly. Perhaps better to ask via
https://eclipse.org/tycho/support.php

We use Tycho Maven for Oomph, and we don't use those repos the way you
do. Our parent POM refers to our releng plugin for the target:

http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/tree/releng/org.eclipse.oomph.parent/pom.xml#n111

That project has a *.target file:

http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/tree/releng/org.eclipse.oomph.releng

And the dependencies in that file are used by Tycho to resolve the
target platform.

But I'm no expert and Eike Stepper implemented this build
infrastructure. So I won't be able to answer anything in detail. Better
to Google, look at Oomph as a working example, and ask Tycho-specific
questions on their support channel.

On 12.07.2016 15:07, Umesh Thakare wrote:
> Hi
> I have tried the mars release url which you mention in your post but
> still i am facing the same issue.
> So now i have created one sample application to check whether given
> url is working or not
> I have created one hellow world plugin in eclipse 4.5(mars). In which
> i have added two below dependency on the manifest file(MANIFEST.MF).
> org.eclipse.core.runtime;bundle-version="3.11.1",
> org.eclipse.emf.ecore;bundle-version="2.11.1"
>
> And MANIFEST.MF file looks like below
>
> Manifest-Version: 1.0
> Bundle-ManifestVersion: 2
> Bundle-Name: Maven_building
> Bundle-SymbolicName: com.qvto.maven_building;singleton:=true
> Bundle-Version: 1.0.0.qualifier
> Bundle-Activator: com.qvto.maven_building.Activator
> Bundle-Vendor: NAME
> Require-Bundle: org.eclipse.ui;bundle-version="3.107.0",
> org.eclipse.core.runtime;bundle-version="3.11.1",
> org.eclipse.emf.ecore;bundle-version="2.11.1"
> Bundle-RequiredExecutionEnvironment: JavaSE-1.6
> Bundle-ActivationPolicy: lazy
>
> please find the snipped code of pom.xml which i have used to build my
> plugin using maven.
> Please find the snipped code below:-
>
> <project xmlns="http://maven.apache.org/POM/4.0.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
> <modelVersion>4.0.0</modelVersion>
> <groupId>com.qvto.maven_building</groupId>
> <artifactId>com.qvto.maven_building</artifactId>
> <version>0.0.1-SNAPSHOT</version>
> <packaging>eclipse-plugin</packaging>
> <name>Engineering Tool Parent</name>
>
> <properties>
> <tycho-version>0.17.0</tycho-version>
> <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
> </properties>
>
> <repositories>
> <repository>
> <id>mars-eclipse</id>
> <layout>p2</layout>
> <url>http://download.eclipse.org/releases/mars/201602261000/</url>
> </repository>
> </repositories>
>
> <build>
> <plugins>
> <plugin>
> <groupId>org.eclipse.tycho</groupId>
> <artifactId>tycho-maven-plugin</artifactId>
> <version>${tycho-version}</version>
> <extensions>true</extensions>
> </plugin>
> <plugin>
> <groupId>org.eclipse.tycho</groupId>
> <artifactId>tycho-compiler-plugin</artifactId>
> <version>${tycho-version}</version>
> <configuration>
> <source>1.6</source>
> <target>1.6</target>
> </configuration>
> </plugin>
> <plugin>
> <groupId>org.eclipse.tycho</groupId>
> <artifactId>target-platform-configuration</artifactId>
> <version>${tycho-version}</version>
> <configuration>
> <resolver>p2</resolver>
> <environments>
> <environment>
> <os>win32</os>
> <ws>win32</ws>
> <arch>x86</arch>
> </environment>
> <environment>
> <os>linux</os>
> <ws>gtk</ws>
> <arch>x86</arch>
> </environment>
> </environments>
> <filters>
> <filter>
> <type>eclipse-plugin</type>
> <id>org.antlr.runtime</id>
> <restrictTo>
> <versionRange>[3.0.0,3.0.2)</versionRange>
> </restrictTo>
> </filter>
> <filter>
> <type>eclipse-plugin</type>
> <id>com.google.inject</id>
> <restrictTo>
> <versionRange>[2.0.0,2.0.1)</versionRange>
> </restrictTo>
> </filter>
> </filters>
> </configuration>
> </plugin>
> </plugins>
> </build>
> </project>
>
> So after adding dependency and creating pom when i try to build using
> maven, i face the below problem
> Missing requirement: com.qvto.maven_building 1.0.0.qualifier requires
> 'bundle org.eclipse.core.runtime 3.11.1' but it could not be found
>
> So still i am facing the same type of issue even i have change the
> repository which you share with us.
> Please help me on this problem
>
Previous Topic:Permanently exclude a directory from Search Results
Next Topic:Set debug working directory relative path
Goto Forum:
  


Current Time: Sat Nov 16 21:10:26 GMT 2019

Powered by FUDForum. Page generated in 0.04459 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top