Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Query during debug ends prematurely(Query during debug ends prematurely)
Query during debug ends prematurely [message #1732718] Thu, 19 May 2016 06:37 Go to next message
Michael Warner is currently offline Michael WarnerFriend
Messages: 1
Registered: May 2016
Junior Member
I have a java program that starts with an initial query that collects a number of objects. Then it pulls related data based on those objects and writes records out to a file, then goes to the next object in the original collection.

However, out of the original collection (let's say 2349 objects), it will iterate through 2250 and exit gracefully. No errors, no messages and the file closes properly.

I am a fair java programmer but still learning and have tried to trap this. I've forced the query to start further down in the list of objects and it will complete the list. However, it will not go thru the whole list on its own. (And it always stops around the same point but not exactly...)
Re: Query during debug ends prematurely [message #1732724 is a reply to message #1732718] Thu, 19 May 2016 15:35 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 05/19/2016 02:18 AM, Michael Warner wrote:
> I have a java program that starts with an initial query that collects a
> number of objects. Then it pulls related data based on those objects
> and writes records out to a file, then goes to the next object in the
> original collection.
>
> However, out of the original collection (let's say 2349 objects), it
> will iterate through 2250 and exit gracefully. No errors, no messages
> and the file closes properly.
>
> I am a fair java programmer but still learning and have tried to trap
> this. I've forced the query to start further down in the list of
> objects and it will complete the list. However, it will not go thru the
> whole list on its own. (And it always stops around the same point but
> not exactly...)

This sounds like a Java question. You'll likely not get help with this
in this forum where only Eclipse and Eclipse set-up questions are
answered. Try stackoverflow.com.
Previous Topic:Plug in Development
Next Topic:Unable to install sonarlint plugin from marketplace
Goto Forum:
  


Current Time: Tue Nov 12 18:24:25 GMT 2019

Powered by FUDForum. Page generated in 0.03373 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top