Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Add user projects file from git repo
Add user projects file from git repo [message #1726540] Mon, 14 March 2016 14:20 Go to next message
kon f is currently offline kon fFriend
Messages: 152
Registered: March 2012
Senior Member
Hey,

i'm trying to reference a custom project file with following URI

https://stash.abc.de/projects/APPS/repos/def.ghi/browse/de.abc.def.ghi.feature/oomph/ghi.setup?at=feature/ghi-464-create-oomph-script-for-ide-setup&raw


but I do get an error dialog telling that ".....ghi.setup?at=feature/ghi-464-create-oomph-script-for-ide-setupraw" does not contain a valid project. We'are using Attlasian Stash and we need to provide two parameters: branch and raw. Somehow the "&" that concatenates both parameter is swallowed.

Is there a way to make this work? It works for github raw URIs ..right? But they indicate raw within the uri and not in a parameter.

Thank you! Smile

Kon
Re: Add user projects file from git repo [message #1726544 is a reply to message #1726540] Mon, 14 March 2016 14:39 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31151
Registered: July 2009
Senior Member
Kon,

The query string is already a bit of a problem when one tries to
redirect URIs, but at a glance I don't see that it's invalid. I
assume this works in a browser though, right?

Unless I can reproduce the problem and look at where/what is going wrong
in the HTTP handshaking (which uses ECF under the covers), I can't
really say much that would be informative. Sorry.

I have gotten private raw github URIs (that use a query string to work),
but they are annoying in that the query token expires if a change is
committed, i.e., it's not a stable URI. So I figured out how to use
api.github.com, which supports basic authentication, to work...


On 14.03.2016 15:20, kon f wrote:
> Hey,
>
> i'm trying to reference a custom project file with following URI
>
> https://stash.abc.de/projects/APPS/repos/def.ghi/browse/de.abc.def.ghi.feature/oomph/ghi.setup?at=feature/ghi-464-create-oomph-script-for-ide-setup&raw
>
>
> but I do get an error dialog telling that
> ".....ghi.setup?at=feature/ghi-464-create-oomph-script-for-ide-setupraw"
> does not contain a valid project. We'are using Attlasian Stash and we
> need to provide two parameters: branch and raw. Somehow the "&" that
> concatenates both parameter is swallowed.
>
> Is there a way to make this work? It works for github raw URIs
> ..right? But they indicate raw within the uri and not in a parameter.
>
> Thank you! :)
>
> Kon
Re: Add user projects file from git repo [message #1726567 is a reply to message #1726544] Mon, 14 March 2016 17:18 Go to previous messageGo to next message
kon f is currently offline kon fFriend
Messages: 152
Registered: March 2012
Senior Member
I've change the default branch to develop, so I just need the raw parameter.

https://USER:PW@stash.abc.de/projects/APPS/repos/def.ghi/browse/de.abc.def.ghi.feature/oomph/ghi.setup?&raw

If I use this link, including user + pw for basic auth, the installer keeps prompting for the user and the pw Sad Is this a bug?
Re: Add user projects file from git repo [message #1726717 is a reply to message #1726567] Tue, 15 March 2016 21:30 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31151
Registered: July 2009
Senior Member
Kon,

I've traveling and won't be able to help until April. And even then, I
need a way to reproduce the problem myself locally.

On 15.03.2016 01:19, kon f wrote:
> I've change the default branch to develop, so I just need the raw
> parameter.
>
> https://USER:PW@xxxxxxxx.de/projects/APPS/repos/def.ghi/browse/de.abc.def.ghi.feature/oomph/ghi.setup?&raw
>
>
> If I use this link, including user + pw for basic auth, the installer
> keeps prompting for the user and the pw :( Is this a bug?
>
Re: Add user projects file from git repo [message #1726759 is a reply to message #1726717] Wed, 16 March 2016 09:17 Go to previous message
kon f is currently offline kon fFriend
Messages: 152
Registered: March 2012
Senior Member
Hey Ed,

thank you for your effort Smile I just installed Chrome and Opera just to make that my basic auth works for sure. And I was wrong, it does not work. I guess, I messed up with my firefox session Sad

But the same link (incl. the credentials) works perfect with "curl" on the command line ..

> curl -v https://USER:PW@stash.abc.de/projects/APPS/repos/def/browse/de.abc.feature/oomph/project.setup?raw
* timeout on name lookup is not supported
*   Trying 37.61.202.43...
* Connected to stash.abc.de (37.61.202.43) port 443 (#0)
* ALPN, offering http/1.1
* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
* successfully set certificate verify locations:
*   CAfile: C:/Program Files/Git/mingw64/ssl/certs/ca-bundle.crt
  CApath: none
* TLSv1.2 (OUT), TLS header, Certificate Status (22):
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* TLSv1.2 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Client hello (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS change cipher, Client hello (1):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* ALPN, server did not agree to a protocol
* Server certificate:
*        subject: OU=Domain Control Validated; OU=Hosted by Alfahosting GmbH; OU=PositiveSSL Wildcard; CN=*.abc.de
*        start date: Jun  5 00:00:00 2015 GMT
*        expire date: Jun  4 23:59:59 2017 GMT
*        subjectAltName: stash.abc.de matched
*        issuer: C=GB; ST=Greater Manchester; L=Salford; O=COMODO CA Limited; CN=COMODO RSA Domain Validation Secure Server CA
*        SSL certificate verify ok.
* Server auth using Basic with user 'USER'
> GET /projects/APPS/repos/def/browse/de.abc.feature/oomph/project.setup?raw HTTP/1.1
> Host: stash.abc.de
> Authorization: Basic XXX
> User-Agent: curl/7.46.0
> Accept: */*
>
< HTTP/1.1 200 OK
< Date: Wed, 16 Mar 2016 09:04:54 GMT
< Server: Apache-Coyote/1.1
< X-AREQUESTID: @9KSMXXx604x369370x0
< X-ASEN: SEN-5079493
< X-AUSERNAME: USER
< X-AUSERID: 303
< X-ASESSIONID: 1qy31f8
< X-XSS-Protection: 1; mode=block
< X-Frame-Options: SAMEORIGIN
< X-Content-Type-Options: nosniff
< Pragma: no-cache
< Expires: Thu, 01 Jan 1970 00:00:00 GMT
< Cache-Control: no-cache
< Cache-Control: no-store
< X-Download-Options: noopen
< Content-Disposition: attachment
< Content-Type: application/xml
< Set-Cookie: JSESSIONID=D5EBF07DA2F28EA9289B8C3DA2BC7331; Path=/; HttpOnly
< Set-Cookie: crowd.token_key=RnSmW0reDl9j6GtbaSma9Q00; Domain=.abc.de; Path=/; HttpOnly
< Connection: close
< Transfer-Encoding: chunked
<
<?xml version="1.0" encoding="UTF-8"?>

Omitted the rest o the setup file ...


I'm not sure if curl only uses pure basic auth ... it might somehow interfere with my firefox session, but it should right? Smile I need to investigate this.

Best regards and save travel Smile

Kon
Previous Topic:How can I remove a project from my oomph-managed eclipse install?
Next Topic:E=mc Eclipse Mission Control
Goto Forum:
  


Current Time: Tue May 26 20:45:22 GMT 2020

Powered by FUDForum. Page generated in 0.01890 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top