Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » [SOLVED - GTK3 issue] Weird Eclipse Mars behaviour after installation(Running from the installer = ok, running any other way = huge fonts)
[SOLVED - GTK3 issue] Weird Eclipse Mars behaviour after installation [message #1721831] Sun, 31 January 2016 20:14 Go to next message
PETR POLEZHAEV is currently offline PETR POLEZHAEVFriend
Messages: 2
Registered: March 2012
Junior Member

I've got some really weird issue here: I've just installed a fresh new copy of Eclipse Mars using a new glorified installer. It went mostly fine, once I've updated the installer (site download link points to a somewhat broken version, for some reason) in let me launch a newly installed Mars (in C/C++ configuration)...

Once it's launched I've installed a few plugins - LLVM support (restart), Qt support (restart), themes (restart), configured a few colors, switched the main theme to dark, tweaked a couple of code style options, etc... Each time Eclipse asked me to restart itself, I agreed and everything went fine. But then I've added a new file association to open "*.ipp" files with the C++ editor.

It didn't worked from the first time and there was no prompt to restart, but I've guessed it somehow cached the preferred editor for a file and decided to restart Eclipse manually. It was the first time I've attempted that on the new copy. And once it's started again everything gone BAD. All fonts became huge, menu and toolbar became a color mess with white on white and stuff, preferences not working (clicking on sections on the left do nothing), etc... Text editor worked fine, though. And it also got the new association right. I've tried to revert all style settings, uninstall themes, removed workspace. Nothing helped.

After lots of testing I figured out that affected things are system widgets. And this happens when eclipse is NOT launched by the installer. And they are probably catching some weird system theme? Java version (I've got icedtea for both java-1.7 and 1.8 for messing with Che) is irrelevant, plugins are irrelevant, Eclipse configuration is irrelevant.

I've copied a full java command the installer is launching Eclipse with (the one with like 10? osgi.requiredJavaVersion switches in it. "Just to make it absolutely clear!") and tried launching with that - no luck either. Environment is the same.

The only difference is that the installed saying something along the lines of
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

(java:20315): Gtk-WARNING **: Загружаемый модуль тем не найден в module_path: «aurora»,
The last message says that "aurora loadable theme module wasn't found in the module_path". And there a more of similar messages for various themes.

So I guess that's the problem, but I just don't understand how to make the same problem happen with the main Eclipse! For the first time in my live I want a problem to be a solution! I don't care about GTK themes, I didn't install any, nor configured anything, I'm using KDE!

The main eclipse is dead-silent though when it's launched. So maybe it's just blocking it's output somehow.

So, does anyone know how such thing may happen and what to do with it?

P.S. I've installed Neon (on java-1.Cool - same thing.

[Updated on: Thu, 04 February 2016 20:14]

Report message to a moderator

Re: Weird Eclipse Mars behaviour after installation [message #1722440 is a reply to message #1721831] Thu, 04 February 2016 20:13 Go to previous message
PETR POLEZHAEV is currently offline PETR POLEZHAEVFriend
Messages: 2
Registered: March 2012
Junior Member
Figured that out by running strace. It seems that, for some reason, installer is using GTK2 while "normal" eclipse is using GTK3. And GTK3 is not compatible with GTK2 themes, so it's behaving rather strangely when it's running GTK3. I found an another topic here with an advice to add

to the eclipse.ini (I've added it after a --launcher.library pair). And it worked nicely.
Previous Topic:Upgrading more than one version?
Next Topic:Errors - Proceed with Launch?
Goto Forum:

Current Time: Sun Jan 26 23:22:00 GMT 2020

Powered by FUDForum. Page generated in 0.03187 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top