Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problems and Questions While Installing Java(Java Development, JDK, Java_Home, Java Disappears)
Problems and Questions While Installing Java [message #1719244] Wed, 06 January 2016 14:18 Go to next message
Kurt Sanger is currently offline Kurt SangerFriend
Messages: 6
Registered: January 2016
Junior Member
Hi;

We've had some weird issues when trying to get Eclipse IDE up and running to develop code for USFirst Robotics where we program in Java and download to a roboRIO target. Instructions for installing Eclipse for C++, then Java development tools, then Java JDK, then FRC WPILib are located at wpilib.screenstepslive.com/s/4485/m/13503/l/145002-installing-eclipse-c-java.

My first mistake was that I selected and installed Java JRE instead of the Java JDK. This resulted in a compile error stating that Java_Home was undefined. I figured out that I wasn't pointing to the JDK, then installed it too. Then Select Windows from the menu bar, then Preferences. Choose Java preferences in the list on the left of the Preferences window, then Installed JREs, and selected the JDK. But that did not fix the issue. I still obtained an error that the environment variable JAVA_Home was not defined.

So I deleted all references to eclipse in my home directory, reinstalled Java JDK, settup eclipse again, and then reinstalled the sample program and everything compiled. Plus I was able to Select the Project, then right click and select "Run As" then select "WPILib Java Deployment". However I didn't have a roboRio to download too.

Then two weeks later, at our robotics meeting, we open eclipse, select our workspace, and obtained errors stating that no editor defined. Further our project will not build, nor clean. Java development tools was missing or deleted. We needed to reinstall Java development tools, JDK setup, FRC WPILib, and it still would not work, until we deleted the sample project and reloaded it. We have since exited eclipse and restarted eclipse and it worked again. But why did everything stop working once we had the Eclipse IDE setup the way we needed?

The only thing we had done on the computer was move the eclipse shortcut from my desktop to the start page. I'm running Win 8.1; eclipse Mars.1; java_1.8.0_65

Re: Problems and Questions While Installing Java [message #1719267 is a reply to message #1719244] Wed, 06 January 2016 16:51 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 01/06/2016 08:17 AM, Kurt Sanger wrote:
> Hi;
> We've had some weird issues when trying to get Eclipse IDE up and
> running to develop code for USFirst Robotics where we program in Java
> and download to a roboRIO target. Instructions for installing Eclipse
> for C++, then Java development tools, then Java JDK, then FRC WPILib are
> located at
> wpilib.screenstepslive.com/s/4485/m/13503/l/145002-installing-eclipse-c-java.
>
>
> My first mistake was that I selected and installed Java JRE instead of
> the Java JDK. This resulted in a compile error stating that Java_Home
> was undefined. I figured out that I wasn't pointing to the JDK, then
> installed it too. Then Select Windows from the menu bar, then
> Preferences. Choose Java preferences in the list on the left of the
> Preferences window, then Installed JREs, and selected the JDK. But that
> did not fix the issue. I still obtained an error that the environment
> variable JAVA_Home was not defined.
>
> So I deleted all references to eclipse in my home directory, reinstalled
> Java JDK, settup eclipse again, and then reinstalled the sample program
> and everything compiled. Plus I was able to Select the Project, then
> right click and select "Run As" then select "WPILib Java Deployment".
> However I didn't have a roboRio to download too.
> Then two weeks later, at our robotics meeting, we open eclipse, select
> our workspace, and obtained errors stating that no editor defined.
> Further our project will not build, nor clean. Java development tools
> was missing or deleted. We needed to reinstall Java development tools,
> JDK setup, FRC WPILib, and it still would not work, until we deleted the
> sample project and reloaded it. We have since exited eclipse and
> restarted eclipse and it worked again. But why did everything stop
> working once we had the Eclipse IDE setup the way we needed?
>
> The only thing we had done on the computer was move the eclipse shortcut
> from my desktop to the start page. I'm running Win 8.1; eclipse
> Mars.1; java_1.8.0_65

Did you check the sticky posts at forum's top? In particular, these two
might help:

https://www.eclipse.org/forums/index.php/t/198527/
https://www.eclipse.org/forums/index.php/t/1065514/
Re: Problems and Questions While Installing Java [message #1719313 is a reply to message #1719267] Thu, 07 January 2016 01:58 Go to previous messageGo to next message
Kurt Sanger is currently offline Kurt SangerFriend
Messages: 6
Registered: January 2016
Junior Member
Thanks;

I'll check which version of Java I'm currently pointing to using that first post. I assume this didn't change when I installed the JDK after the JRE failed. Plus by the time I did that the JDK was a different version. Though changing the setting in the IDE to use the JDK as the default didn't work, or update the Environment variable needed. I see if that's in the ini file too.

I'll also back up the initialization file so if it doesn't work again. I can compare the initialization file with a backup of one that does to see what changed.
Re: Problems and Questions While Installing Java [message #1719400 is a reply to message #1719267] Thu, 07 January 2016 16:14 Go to previous messageGo to next message
Kurt Sanger is currently offline Kurt SangerFriend
Messages: 6
Registered: January 2016
Junior Member
I've checked that the eclipse icon on the start page starts up in C:\Program Files\eclipse. If I go to c:\Program Files\eclipse and right click on eclipse.exe it too starts up in C:\Program Files\eclipse. If I create a shortcut and place it on the desktop it starts in the same place. If I right click on the eclipse.exe and pin it to the taskbar it starts in the same place. So I do not see how deleting the shortcut on the desktop or the taskbar icon and using the icon on the start page deleted Java developer settings.

Searching for eclipse.ini doesn't show up any files in my user directory. Actually it shows no files as I have to change Win 8.1 search setting to search my hard drive...

Have to figure out how to get Win 8.1 to search my entire hard drive. Currently it ignores Data, App Data, and isn't showing eclipse.ini at all. Argh. Search should find everything. Shouldn't take a rocket scientist. So I don't know if I have multiple ini files for eclipse yet.

Re: Problems and Questions While Installing Java [message #1719403 is a reply to message #1719400] Thu, 07 January 2016 16:25 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 01/07/2016 09:14 AM, Kurt Sanger wrote:
> I've checked that the eclipse icon on the start page starts up in
> C:\Program Files\eclipse. If I go to c:\Program Files\eclipse and right
> click on eclipse.exe it too starts up in C:\Program Files\eclipse. If I
> create a shortcut and place it on the desktop it starts in the same
> place. If I right click on the eclipse.exe and pin it to the taskbar it
> starts in the same place. So I do not see how deleting the shortcut on
> the desktop or the taskbar icon and using the icon on the start page
> deleted Java developer settings.
>
> Searching for eclipse.ini doesn't show up any files in my user
> directory. Actually it shows no files as I have to change Win 8.1
> search setting to search my hard drive...
>
> Have to figure out how to get Win 8.1 to search my entire hard drive.
> Currently it ignores Data, App Data, and isn't showing eclipse.ini at
> all. Argh. Search should find everything. Shouldn't take a rocket
> scientist. So I don't know if I have multiple ini files for eclipse yet.

I advise against putting Eclipse in C:\Program Files. It's
personal-productivity software and it creates some access troubles on
versions past Windows XP. Put it instead on a path like C:\Users\kurt.

Cheers.
Re: Problems and Questions While Installing Java [message #1719555 is a reply to message #1719400] Fri, 08 January 2016 19:26 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Kurt Sanger wrote on Thu, 07 January 2016 16:14
Searching for eclipse.ini doesn't show up any files in my user directory. Actually it shows no files as I have to change Win 8.1 search setting to search my hard drive...

Have to figure out how to get Win 8.1 to search my entire hard drive. Currently it ignores Data, App Data, and isn't showing eclipse.ini at all. Argh. Search should find everything. Shouldn't take a rocket scientist. So I don't know if I have multiple ini files for eclipse yet.


The eclipse.ini file is always located right next to the executable. I'm 99% sure Eclipse won't look for it in any other location.
Re: Problems and Questions While Installing Java [message #1719560 is a reply to message #1719244] Fri, 08 January 2016 20:19 Go to previous message
Kurt Sanger is currently offline Kurt SangerFriend
Messages: 6
Registered: January 2016
Junior Member
Thank you guys for your help;

So far I've only found the one eclipse.ini file in the C:\Program Folders\eclipse directory. Which is also the directory with eclipse.exe. So I have no idea why my Java settings were lost.

I have an opportunity to load software for robotics on another computer so I will check if the instructions result in eclipse being placed under "C:\Program Folders" or if I did that on my own. I'm familiar with having multiple eclipse versions for coding for android, and Linux. I had thought that specifying the workspace is when the IDE would set up the options being used.

Previous Topic:Unable to launch Scrapbook VM
Next Topic:How to uninstall Eclipse Mars from Windows 7
Goto Forum:
  


Current Time: Mon Sep 16 20:07:10 GMT 2019

Powered by FUDForum. Page generated in 0.03259 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top