Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Texo] NoSuchMethodError
[Texo] NoSuchMethodError [message #1715437] Mon, 23 November 2015 15:01 Go to next message
Bastian Wagenfeld is currently offline Bastian WagenfeldFriend
Messages: 183
Registered: January 2013
Senior Member
Hi Martin,

for a new project I'm evaluating the usage of Texo within a Spring Boot Application. Unfortunately I'm getting a NoSuchMethodError with this Stacktrace:
java.lang.NoSuchMethodError: org.eclipse.emf.texo.json.BaseModelJSONConverter.doBaseActions(Ljava/util/List;)V
	at org.eclipse.emf.texo.json.BaseModelJSONConverter.convert(BaseModelJSONConverter.java:79)
	at org.eclipse.emf.texo.server.service.json.JSONServiceContext.convertToResultFormat(JSONServiceContext.java:73)
	at org.eclipse.emf.texo.server.service.ServiceContext.setResultInResponse(ServiceContext.java:247)
	at org.eclipse.emf.texo.server.service.RetrieveModelOperation.internalExecute(RetrieveModelOperation.java:114)
	at org.eclipse.emf.texo.server.service.UpdateInsertModelOperation.internalExecute(UpdateInsertModelOperation.java:69)
	at org.eclipse.emf.texo.server.service.ModelOperation.execute(ModelOperation.java:59)
	at org.eclipse.emf.texo.server.web.WebServiceHandler.doPost(WebServiceHandler.java:111)
	at de.kisters.fastq.controller.texo.TexoController.doPost(TexoController.java:96)


The query I sent to the server is: select e from fastq_Feature e where e.type like :base and e.parent.db_Id is null with base = base.

The Eclipse RCP is running with Texo version 0.9.0.v201510072120. The server side is using 0.9.0-v201501182340. Might this cause a NoSuchMethodError in your opinion? Did you experience something like this?

Best regards
Bastian
Re: [Texo] NoSuchMethodError [message #1715594 is a reply to message #1715437] Tue, 24 November 2015 14:46 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Bastian,
Yes the method signature of this method changed in March 2015. But this works fine if all the classes are from the same
Texo build/version. So to me I think the plugins/classes are loaded from different versions into one classpath.
Guessing a bit, but that's what it seems to be to me.

gr. Martin

On 23-11-15 16:01, Bastian Wagenfeld wrote:
> Hi Martin,
>
> for a new project I'm evaluating the usage of Texo within a Spring Boot Application. Unfortunately I'm getting a
> NoSuchMethodError with this Stacktrace: java.lang.NoSuchMethodError:
> org.eclipse.emf.texo.json.BaseModelJSONConverter.doBaseActions(Ljava/util/List;)V
> at org.eclipse.emf.texo.json.BaseModelJSONConverter.convert(BaseModelJSONConverter.java:79)
> at org.eclipse.emf.texo.server.service.json.JSONServiceContext.convertToResultFormat(JSONServiceContext.java:73)
> at org.eclipse.emf.texo.server.service.ServiceContext.setResultInResponse(ServiceContext.java:247)
> at org.eclipse.emf.texo.server.service.RetrieveModelOperation.internalExecute(RetrieveModelOperation.java:114)
> at org.eclipse.emf.texo.server.service.UpdateInsertModelOperation.internalExecute(UpdateInsertModelOperation.java:69)
> at org.eclipse.emf.texo.server.service.ModelOperation.execute(ModelOperation.java:59)
> at org.eclipse.emf.texo.server.web.WebServiceHandler.doPost(WebServiceHandler.java:111)
> at de.kisters.fastq.controller.texo.TexoController.doPost(TexoController.java:96)
>
> The query I sent to the server is: select e from fastq_Feature e where e.type like :base and e.parent.db_Id is null with
> base = base.
>
> The Eclipse RCP is running with Texo version 0.9.0.v201510072120. The server side is using 0.9.0-v201501182340. Might
> this cause a NoSuchMethodError in your opinion? Did you experience something like this?
> Best regards
> Bastian


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@xxxxxxxx - mtaal@xxxxxxxx
Web: www.springsite.com - www.elver.org
Re: [Texo] NoSuchMethodError [message #1715773 is a reply to message #1715594] Thu, 26 November 2015 06:26 Go to previous messageGo to next message
Bastian Wagenfeld is currently offline Bastian WagenfeldFriend
Messages: 183
Registered: January 2013
Senior Member
Hi,

indeed there were two versions of Texo in the classpath. I've got a project which includes Texo. This component is included in the server which also uses Texo. From within Eclipse both Texo versions are loaded into the classpath. If I export the server application everything works fine.

Best regards
Bastian
Re: [Texo] NoSuchMethodError [message #1715796 is a reply to message #1715773] Thu, 26 November 2015 10:35 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hey Bastian,
That's indeed strange, not sure how your server is setup. If it is a osgi run configuration you can maybe limit the
version to load. Or if it is a standard servlet webapp put the texo jars directly in WEB-INF/lib to be sure that those
are loaded.

gr. Martin

On 26-11-15 07:26, Bastian Wagenfeld wrote:
> Hi,
>
> indeed there were two versions of Texo in the classpath. I've got a project which includes Texo. This component is
> included in the server which also uses Texo. From within Eclipse both Texo versions are loaded into the classpath. If I
> export the server application everything works fine.
>
> Best regards
> Bastian


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@xxxxxxxx - mtaal@xxxxxxxx
Web: www.springsite.com - www.elver.org
Re: [Texo] NoSuchMethodError [message #1715814 is a reply to message #1715796] Thu, 26 November 2015 12:17 Go to previous message
Bastian Wagenfeld is currently offline Bastian WagenfeldFriend
Messages: 183
Registered: January 2013
Senior Member
Hi Martin,

the model containing project is an Eclipse plugin. And is included by the spring boot application as a normal dependency. So the model project references the Texo libraries of version 0.9.0.v201510072120 from the P2 repo. The server itself uses Texo from Maven in version 0.9.0-v201501182340. When exporting the server. The Texo version from the P2 repo can be excluded. So when the server is started is exported and packed as a jar there is no problem, but started from Eclipse as a Java Application the classpath contains both Texo version. I don't have a idea, how it can be started in Eclipse, yet.

Best regards
Bastian
Previous Topic:[CompleteOCL] Programmatically register ocl file with EMF model
Next Topic:[EMF Forms] multi-row controls
Goto Forum:
  


Current Time: Tue Mar 31 13:12:00 GMT 2020

Powered by FUDForum. Page generated in 0.02570 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top