Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Plug-in Dependency Difficulty of Java Service usage
Plug-in Dependency Difficulty of Java Service usage [message #1713407] Tue, 03 November 2015 19:59 Go to next message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Hello,

I'm trying to use Java Service. I read an article that for the Java Service, odesign project has the plug-in which contains its ecore file.
To do it, I made the plug-in for my bpmn ecore file.
By the way, when I click an add button for the dependency plug-in, there is no plug-in which I added in the ~/eclipse/plugin/.
The following is the picture.

index.php/fa/23823/0/

Does any body know why this happen?
I tried to execute -clean when execute the eclipse.

Thanks in advance.

Best Regards,
Eunjung Grace

[Updated on: Wed, 04 November 2015 09:47]

Report message to a moderator

Re: Plug-in Dependency Problem for Java Service [message #1713454 is a reply to message #1713407] Wed, 04 November 2015 09:23 Go to previous messageGo to next message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Hi,
I could solve the problem. I just imported the ecore file in runtime environment. ^^
Thanks.
Re: Plug-in Dependency Problem for Java Service [message #1713458 is a reply to message #1713407] Wed, 04 November 2015 09:26 Go to previous messageGo to next message
Esteban Dugueperoux is currently offline Esteban DugueperouxFriend
Messages: 472
Registered: July 2009
Senior Member
Hi,

This seems a deployement issue, to have your metamodel plugin deployed
you can :

- in development mode, launch a second runtime from your workspace
containing your metamodel plugin.
- in production mode, have your metamodel plugin deployed through a
feature or exported directly in the dropins folder of your Eclipse target.

Note your question is not Sirius related but only a deployment issue.

Best Regards.

Le 03/11/2015 20:59, eunjung park a écrit :
> Hello,
>
> I'm trying to use Java Service. I read an article that for the Java Service, odesign project has the plug-in which contains its ecore file.
> To do it, I made the plug-in for my bpmn ecore file.
> By the way, when I click an add button for the dependency plug-in, there is no plug-in which I added in the ~/eclipse/plugin/.
> The following is the picture.
>
>
>
> Does any body know why this happen?
> I tried to execute -clean when execute the eclipse.
>
> Thanks in advance.
>
> Best Regards,
> Eunjung Grace
>



--
Esteban Dugueperoux - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Plug-in Dependency Problem for Java Service [message #1713462 is a reply to message #1713458] Wed, 04 November 2015 09:44 Go to previous message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Hi Esteban,

Thank you so much.
I'm not accustomed to Eclipse environment, so I didn't know where to ask.
Please excuse me.
Have a wonderful day.

Best Regards,
Grace Eunjung
Previous Topic:AQL expression for setname() in Sirius
Next Topic:Adding images to table
Goto Forum:
  


Current Time: Tue Mar 02 21:22:55 GMT 2021

Powered by FUDForum. Page generated in 0.01873 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top