Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Paste into Papyrus table not working for UML? Or I'm doing something wrong?
Paste into Papyrus table not working for UML? Or I'm doing something wrong? [message #1710138] Mon, 05 October 2015 04:53 Go to next message
Ri Fr is currently offline Ri FrFriend
Messages: 114
Registered: July 2015
Senior Member
Hi there

following these instructions, Papyrus 1.2.0 (I just updated)

I want to import a list of Packages into and existing package

Select the Package - new table - generic Table
Select the Table - Properties - Paste: "Not available for this Table" (contrary to what the user guide says)
Then I get a bunch of error messages from papyrus (I clicked 'Yes' on 'Submit bug report') such as 'An error has occurred. See error log for more details.
java.lang.NullPointerException'
Tried to paste anyway, nothing happens

Try again!!!

Select the Package - new table - generic Tree Table
Select the Table - Properties - now Paste view is showing
Delect 'Detach mode'
Paste element ID select 'org.eclipse.papyrus.uml.Package'
Containment feature: 'PackageableElement'
Select the table, Create/Destroy Columns', select UML 'Package', 'Name'
Go back to the table, copy the Package names from Excel table (a few cells in a column), click on Table, Edit - Paste , nothing happens. Click on the 'name' column, Edit-paste, nothing happens. Is this a bug or am I doing it wrong? Thanks!!!


p.s. "Import from file" context menu is available on Generic tables, and it only generates error messages for me - nothing else...


[Updated on: Mon, 05 October 2015 05:29]

Report message to a moderator

Re: Paste into Papyrus table not working for UML? Or I'm doing something wrong? [message #1710175 is a reply to message #1710138] Mon, 05 October 2015 08:03 Go to previous messageGo to next message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 129
Registered: March 2013
Location: Bordeaux, France
Senior Member
Hi Ri,

What instruction did you followed ?

1.2.0 is the version number used in the Neon release which is currently only in M2. You should probably use the mars version 1.1.x

Regards,
Benoit MAGGI
Re: Paste into Papyrus table not working for UML? Or I'm doing something wrong? [message #1710202 is a reply to message #1710175] Mon, 05 October 2015 10:56 Go to previous messageGo to next message
Ri Fr is currently offline Ri FrFriend
Messages: 114
Registered: July 2015
Senior Member
Than you for your reply Benoit. I followed instructions in papyrus help (F1) "Paste From Spreadsheet in a Table ". I just did a fresh install of everything (Eclipse and Papyrus 1.1.2) and got same behavior. I let Eclipse log all my exception messages so they should be on record. Either I misunderstand the instructions or there's a bug. Would be good to know if anyone else can paste Excel into a Table (for example to add several packages to a UML Model).
Re: Paste into Papyrus table not working for UML? Or I'm doing something wrong? [message #1710211 is a reply to message #1710202] Mon, 05 October 2015 11:47 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 922
Registered: February 2011
Senior Member
Hi,

The paste only works if the table is configured to create a specific element for each line. Papyrus only provides (by default) 2 such configurations, for SysML Requirements (A requirement is created for each line) and SysML Allocations. For a generic table, there is no way for the tool to know that you want to create a uml::Package for each pasted line, so it won't work.

A custom table configuration is required for your use case (If I understand it correctly)

Edit: It seems that the help also covers the step for customizing the Paste in a generic table, so I may indeed have misunderstood the issue. I'll see if it works for me and post again once I can confirm whether it works or not on the current version(s).

HTH,
Camille


Camille Letavernier

[Updated on: Mon, 05 October 2015 11:49]

Report message to a moderator

Re: Paste into Papyrus table not working for UML? Or I'm doing something wrong? [message #1710222 is a reply to message #1710138] Mon, 05 October 2015 12:22 Go to previous messageGo to next message
vincent lorenzo is currently offline vincent lorenzoFriend
Messages: 127
Registered: June 2010
Location: Paris Saclay, France
Senior Member
Hi Ri,
the paste is not configured for Generic Tree Table and the tool to allow to configure it has not yeen been created. The paste view displayed for Tree Table must be developed.

Sorry for that.
--
Vincent Lorenzo
Re: Paste into Papyrus table not working for UML? Or I'm doing something wrong? [message #1710234 is a reply to message #1710222] Mon, 05 October 2015 13:07 Go to previous message
Ri Fr is currently offline Ri FrFriend
Messages: 114
Registered: July 2015
Senior Member
Thank you Camille and Vincent
Yes I tried to configure the Generic Table to receive the right Element; when I do this, I cannot access the 'Paste' property for Generic table, and nothing happens when I try to paste; I *can* access the 'paste' property for *Generic Tree* Table, however nothing happens when I paste. I think as Vincent says the tool to do this has not yet been created. p.s. Import from Excel also not working, so it would be great if we could kill 2 birds with 1 stone!

Previous Topic:Link
Next Topic:How to remove the 'Imported' decoration in diagrams?
Goto Forum:
  


Current Time: Thu Apr 09 21:29:29 GMT 2020

Powered by FUDForum. Page generated in 0.05765 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top