Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » SWT browser on linux
SWT browser on linux [message #1706891] Mon, 31 August 2015 15:52
Christian Pontesegger is currently offline Christian PonteseggerFriend
Messages: 220
Registered: July 2009
Location: Graz, Austria
Senior Member
I am struggling to get the browser widget (eg for tooltips) running.

I am working on gentoo linux using KDE 4.14 with the oxygen theme.
First of all I had to step back to GTK 2 using
--launcher.GTK_version 2
in the ini file. Otherwise the UI is completely broken.
Now when I try to load a browser window I run into
Caused by: java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
/[...]/ Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
no swt-mozilla-gtk in java.library.path
Can't load library: /home/christian/.swt/lib/linux/x86_64/

On my system there is no swt-mozilla-gtk library, so no wonder it cannot be found.
After installing webkit-gtk I tried to set
as mentioned in the SWT FAQ, but it seems this setting is ignored. I still get the same exception from above.

Any idea how to get a working browser on linux?


Previous Topic:Is there a way to make a no_focused shell not gain focused when the user click on a control on the s
Next Topic:Webkit will not work on CentOS 6--Following SWT FAQ Instructions
Goto Forum:

Current Time: Sat Feb 27 19:14:24 GMT 2021

Powered by FUDForum. Page generated in 0.02448 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top