Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Jubula » ios(Automating ios AUT using Jubula in a mac )
ios [message #1703783] Wed, 05 August 2015 01:52 Go to next message
tang rong is currently offline tang rongFriend
Messages: 3
Registered: June 2015
Junior Member
Hi,

I'm trying to automate an ios application using Jubula in mac. While creating the AUT configuration, I gave the ios Device Port as 11022 which is the default number specified in the Jubula documentation.

I connected to the "Embedded AUT Agent", Then clicked on "Start AUT" button. But I always get the error code "5009: AUT Start failed. Please check AUT Configuration."

I tried Googling it and didn't get any valid solution for the ios AUT. Since I am new to Jubula, please help me in moving forward Confused

Thanks in advance.

Tang.
  • Attachment: rc_ios.log
    (Size: 94.21KB, Downloaded 99 times)
Re: ios [message #1703806 is a reply to message #1703783] Wed, 05 August 2015 06:35 Go to previous messageGo to next message
Oliver Goetz is currently offline Oliver GoetzFriend
Messages: 219
Registered: May 2011
Senior Member
Hi Tang,

have you followed all the steps described here?
Regards
Oliver
Re: ios [message #1703816 is a reply to message #1703806] Wed, 05 August 2015 08:06 Go to previous messageGo to next message
tang rong is currently offline tang rongFriend
Messages: 3
Registered: June 2015
Junior Member
Hi Oliver,
I have followed the steps as described in the Jubula User manual for setting up the ios AUT for testing.
Re: ios [message #1703958 is a reply to message #1703816] Thu, 06 August 2015 07:47 Go to previous messageGo to next message
tang rong is currently offline tang rongFriend
Messages: 3
Registered: June 2015
Junior Member
Is anyone available to help me out in this issue?
Re: ios [message #1708386 is a reply to message #1703958] Wed, 16 September 2015 07:29 Go to previous message
Balaram Sundaram is currently offline Balaram SundaramFriend
Messages: 8
Registered: March 2015
Junior Member
Hello Tang!

If you had successfully set up the iOS AUT as described here, the do the following:

In the "didFinishLaunchingWithOptions" method your "AppDelegate.m", add the following code at the end of the method:

#if RUN_FUNCTIONAL_TESTS
[UIRemoteControl attach:11022]; //11022 is the "iOS Device Port" that you have specified in the AUT configuration in Jubula
#endif


Before connecting to the AUT, you should ensure that both your iOS device and your Mac are connected to the same WiFi network. The "iOS Device Host" in the AUT configuration should be the IP Address of the iOS device in the selected WiFi network (you can access the IP address by going to Settings->WiFi->Tap the selected WiFi network).

Best regards,
Balaram.
Previous Topic:Connection to Database Failed
Next Topic:Iterate list items in iOS TableView
Goto Forum:
  


Current Time: Wed Apr 24 20:10:07 GMT 2024

Powered by FUDForum. Page generated in 0.03460 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top