Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Mars Install New Features/Update fails with HTTP Code 416
Eclipse Mars Install New Features/Update fails with HTTP Code 416 [message #1702881] Mon, 27 July 2015 07:46
Oliver Becker is currently offline Oliver BeckerFriend
Messages: 1
Registered: July 2015
Junior Member
I'm currently trying to update my working Eclipse Luna (for Java and DSL
Developers) to the new Mars version (seperate fresh installation), but I keep getting an error, which I was unable to resolve.

The workstation has to use a corporate proxy and it was always a little bit tricky to get the Eclipse Marketplace and Install New Feature/Update working. My Luna Eclipse is configured (network settings) to use "Manual" as Active Provider, with the correct host + port + user + password combination. I also got the known bugs and , so I added the infamous "-Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient4"
option in the eclipse.ini. While this is working in Luna, I cannot use the Marketplace or Update features in Mars.

I can open the Marketplace and it actually shows all the plugins, I can select one for install and the plugin-dependency-tree is show, but the next step fails with the following message:


java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Framework arguments:  -product org.eclipse.epp.package.dsl.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.dsl.product

Mon Jul 27 09:41:12 CEST 2015
Unable to read repository at Server returned HTTP response code: 416 for URL:
	at Source)
	at Source)
	at org.eclipse.ecf.provider.filetransfer.retrieve.UrlConnectionRetrieveFileTransfer.getDecompressedStream(
	at org.eclipse.ecf.provider.filetransfer.retrieve.UrlConnectionRetrieveFileTransfer.openStreams(
	at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer.sendRetrieveRequest(
	at org.eclipse.ecf.provider.filetransfer.retrieve.MultiProtocolRetrieveAdapter.sendRetrieveRequest(
	at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.sendRetrieveRequest(
	at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.readInto(
	at org.eclipse.equinox.internal.p2.repository.CacheManager.updateCache(
	at org.eclipse.equinox.internal.p2.repository.CacheManager.createCache(
	at org.eclipse.equinox.internal.p2.metadata.repository.SimpleMetadataRepositoryFactory.getLocalFile(
	at org.eclipse.equinox.internal.p2.metadata.repository.SimpleMetadataRepositoryFactory.load(
	at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(
	at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.oomph.util.ReflectUtil.invokeMethod(
	at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(
	at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(
	at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(
	at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(
	at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(
	at org.eclipse.epp.internal.mpc.ui.operations.AbstractProvisioningOperation.addRepositories(
	at org.eclipse.epp.internal.mpc.ui.operations.ProfileChangeOperationComputer.computeInstallableUnits(
	at org.eclipse.jface.operation.ModalContext$

Check for Update shows the same result.

I tried googling for this kind of error, but it seems no one has reported this problem so far. I'm a little bit lost what to do now (apart from using Luna again), since exactly the same configuration is working in Luna, but is unusable for me in Mars. The network access seems to work because Mars can load the dependency tree of a Marketplace plugin. Every other combination in the network settings fails because of the corporate proxy.

So, any suggetions how to find the root cause? It's quite possible the corporate proxy is misconfigured, but I hope you can help me finding the difference between the working Luna and the (for me) broken Mars, so I know what has to be configured differently. Something seems to be changed in the way the packages are downloaded.

Thank you very much!
Previous Topic:Install new Software is not working in RCP application- Eclipse Indigo
Next Topic:CFEclipse plugin install confusion
Goto Forum:

Current Time: Wed Apr 21 02:27:14 GMT 2021

Powered by FUDForum. Page generated in 0.02938 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top