Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Phortran outline links don't work(Phortran outline)
Phortran outline links don't work [message #1701929] Thu, 16 July 2015 18:43 Go to next message
Francois LA is currently offline Francois LAFriend
Messages: 1
Registered: July 2015
Junior Member
I'm working on a Fortran projet. When I open a source file (.f95); module, type and subroutine are shown in Outline.

When I click on a subroutine in the Outline, it's bring me to the wrong line in the editor.

I did a lot of research, and I can't find any solution.



I'm using :

Eclipse for Parallel Application Developers
Version: Mars Release (4.5.0)
Build id: 20150621-1200
On Mac OS 10.9.5

Thanks

Fran├žois

EDIT : The problem occurs when I add more than one include like this :

module test
    ! include for interventions
    include 'intervention.f95'
    !include test
    include "test.f95'

contains
subroutine getmaplabels()
    write(*,*)intervention(i)%label
end subroutine getmaplabels

end module test

[Updated on: Fri, 17 July 2015 14:24]

Report message to a moderator

Re: Phortran outline links don't work [message #1702046 is a reply to message #1701929] Fri, 17 July 2015 20:38 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
The Photran project uses a mailing list to support its community, see https://www.eclipse.org/photran/mailinglists.php
Previous Topic:Eclipse JEE 4.5.0 (MARS)
Next Topic:Error while opening the eclipse
Goto Forum:
  


Current Time: Sat Oct 19 23:20:24 GMT 2019

Powered by FUDForum. Page generated in 0.03259 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top