Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Mars has broken existing JDBC Oracle connections
Mars has broken existing JDBC Oracle connections [message #1701398] Mon, 13 July 2015 08:30 Go to next message
Jim Seconde is currently offline Jim SecondeFriend
Messages: 19
Registered: February 2015
Junior Member
Hi all,

I've upgraded to Eclipse Mars - but loading the current workspace (I told it to upgrade from Luna for compatibility) has broken the JDBC Oracle connection.

The only settings that may have changed are my machine's Java version. Windows 8.1 has caused me no end of bother recently by having multiple Java installations and being fussy interacting with both 64 and 32 bit versions. I got round this with Luna by forcing a path to v7 in eclipse.ini, but v6 is installed "as default" according to the control panel info. However, both 7 and 8 are supposedly installed.

Using the new Eclipse installer, it was happy to function using the newest version of Java, but I don't think the binary app is reading it.

Error fairly standard from Java - when testing connection
"Cannot load JDBC Driver class: oracle.jdbc.OracleDrvier."

Nothing has changed with the native Oracle instant client.

Posted in both Eclipse and BIRT forums as it's BIRT I'm using.

Any thoughts or more info needed?

Thanks
Re: Mars has broken existing JDBC Oracle connections [message #1701411 is a reply to message #1701398] Mon, 13 July 2015 10:15 Go to previous message
Jim Seconde is currently offline Jim SecondeFriend
Messages: 19
Registered: February 2015
Junior Member
Fixed already: Mars needed to restore the previously used OJDBC.jar driver which didn't automatically get read for some reason.
Previous Topic:Workspace Layout's messed up (Can't reset it)
Next Topic:Eclipse have issues under OSX 10.11 Beta3
Goto Forum:
  


Current Time: Wed Aug 21 11:29:34 GMT 2019

Powered by FUDForum. Page generated in 0.02584 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top