Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » E4 RCP and org.apache.batik dependency
E4 RCP and org.apache.batik dependency [message #1699316] Tue, 23 June 2015 10:45 Go to next message
Frank Benoit is currently offline Frank BenoitFriend
Messages: 17
Registered: December 2012
Junior Member
Hi

when updating the target platform from Ecipse 4.3 to 4.4.2, my eclipse application has unresolved plugins.

Somehow it need org.apache.batik 1.6 and 1.7

org.eclipse.ui depends on batik 1.7
org.eclipse.birt.chart.device.pdf depends on batik.css 1.6

So is this birt problem not working with E4, or a general problem that i can work around?
Is there a way batik 1.6+1.7 can be loaded at the same time?
Seems like whatever i use in the launch config, it sees only one of the versions.

Frank
Re: E4 RCP and org.apache.batik dependency [message #1699323 is a reply to message #1699316] Tue, 23 June 2015 11:49 Go to previous messageGo to next message
Dumont Jonathan is currently offline Dumont JonathanFriend
Messages: 33
Registered: January 2013
Location: Laval
Member
Hi,

We had the same problem with batik, as our product includes Birt and other projects, using 1.6 and 1.7 versions.
To solve this problem, we had to include manually in our launch configuration (based on plugins) the both versions of batik.
Otherwise, in our industrialisation chain, we use Tycho to build the product, and it doesn't have any problem, it correctly resolves the dependencies.

Regards,

Jonathan


Re: E4 RCP and org.apache.batik dependency [message #1704893 is a reply to message #1699323] Mon, 10 August 2015 13:11 Go to previous messageGo to next message
Frank Benoit is currently offline Frank BenoitFriend
Messages: 17
Registered: December 2012
Junior Member
Hi,
I have this issue. But even adding both batik version does not help.

org.osgi.framework.BundleException: Could not resolve module: org.eclipse.birt.report.engine [7]
  Unresolved requirement: Require-Bundle: org.apache.batik.transcoder
    -> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.7.0.v201011041433"
       org.apache.batik.transcoder [161]
         Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="[1.7.0,1.8.0)"


Either it loads 1.6 or 1.7.

Is there a solution?
Re: E4 RCP and org.apache.batik dependency [message #1736046 is a reply to message #1704893] Fri, 24 June 2016 15:03 Go to previous messageGo to next message
Frank Benoit is currently offline Frank BenoitFriend
Messages: 17
Registered: December 2012
Junior Member
Event with NEON, this is not sovled Sad
Re: E4 RCP and org.apache.batik dependency [message #1736050 is a reply to message #1736046] Fri, 24 June 2016 15:08 Go to previous messageGo to next message
Frank Benoit is currently offline Frank BenoitFriend
Messages: 17
Registered: December 2012
Junior Member
And i don't understand how the platform is doing it. I can install BIRT, in the About dialog it shows batik plugins v1.6 and 1.7.
But in my RCP application I cannot do it.
If i add both, either the platform or birt cannot resolve its batik.
Re: E4 RCP and org.apache.batik dependency [message #1736879 is a reply to message #1736050] Mon, 04 July 2016 07:21 Go to previous messageGo to next message
Michael Janssen is currently offline Michael JanssenFriend
Messages: 3
Registered: June 2016
Junior Member
In Neon the Bug is partially fixed. We had had the some Problem for Batik 1.6 and Batik 1.7 in our Product. But by using a Feature-Based Product instead of a Plugin-Based Product this problem is solved.
Re: E4 RCP and org.apache.batik dependency [message #1743559 is a reply to message #1736879] Fri, 16 September 2016 11:32 Go to previous message
Kundan Upadhyaya is currently offline Kundan UpadhyayaFriend
Messages: 1
Registered: September 2016
Junior Member
Hi,

I am facing similar issue while using BIRT report in latest Neon version, the error says

Unresolved requirement: Require-Bundle: org.eclipse.birt.report.engine.script.javascript; bundle-version="2.5.2"
-> Bundle-SymbolicName: org.eclipse.birt.report.engine.script.javascript; bundle-version="4.4.2.v201410272105"; singleton:="true"
org.eclipse.birt.report.engine.script.javascript [502]
Unresolved requirement: Require-Bundle: org.eclipse.birt.report.engine; bundle-version="[2.5.1,5.0.0)"
-> Bundle-SymbolicName: org.eclipse.birt.report.engine; bundle-version="4.4.2.v201411040904"; singleton:="true"
org.eclipse.birt.report.engine [458]

Is this an issue on eclipse's neon version because it is working perfectly fine on eclipse 3. Kindly suggest a solution if available.
Previous Topic:Running e4 RCP application on GTK2
Next Topic:Proxy Service
Goto Forum:
  


Current Time: Sat Aug 13 13:31:42 GMT 2022

Powered by FUDForum. Page generated in 0.02084 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top