Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Having to manually add project include path everytime?(Arduino Include Path)
Having to manually add project include path everytime? [message #1697961] Tue, 09 June 2015 22:08 Go to next message
Michael Chwang is currently offline Michael ChwangFriend
Messages: 1
Registered: June 2015
Junior Member
Hi Everyone,

I have downloaded eclipse and installed the Arduino plug-in. Everything works fine except that I find myself needing to go configure 3 include paths every single time I start a new project.

Basically, with every project I need to go right click on the project>properties>"C/C++ General">"Path and Symbols" and under include paths add:

C:\arduino-1.5.6-r2\hardware\tools\avr\avr\include
C:\arduino-1.5.6-r2\hardware\tools\avr\lib\gcc\avr\4.3.2\include
C:\arduino-1.5.6-r2\hardware\tools\avr\lib\gcc\avr\4.3.2\include-fixed

If i don't, I get a lot of unresolved errors and warning.
Is there anyway to get the IDE setup so it has these 3 paths as part of the default?

Regards,
Mike
Re: Having to manually add project include path everytime? [message #1698187 is a reply to message #1697961] Fri, 12 June 2015 00:51 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/09/2015 04:59 PM, Michael Chwang wrote:
> Hi Everyone,
>
> I have downloaded eclipse and installed the Arduino plug-in. Everything
> works fine except that I find myself needing to go configure 3 include
> paths every single time I start a new project.
>
> Basically, with every project I need to go right click on the
> project>properties>"C/C++ General">"Path and Symbols" and under include
> paths add:
>
> C:\arduino-1.5.6-r2\hardware\tools\avr\avr\include
> C:\arduino-1.5.6-r2\hardware\tools\avr\lib\gcc\avr\4.3.2\include
> C:\arduino-1.5.6-r2\hardware\tools\avr\lib\gcc\avr\4.3.2\include-fixed
>
> If i don't, I get a lot of unresolved errors and warning.
> Is there anyway to get the IDE setup so it has these 3 paths as part of
> the default?
>
> Regards,
> Mike

Arduino is a third-party plub-in. You'll want to get support from them.
Previous Topic:Eclipse doesn't start since I updated my Mac
Next Topic:IP Backtrace on website
Goto Forum:
  


Current Time: Sat Aug 24 00:05:05 GMT 2019

Powered by FUDForum. Page generated in 0.02574 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top