Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Sashdi(Sashdi - package not found)
Sashdi [message #1697953] Tue, 09 June 2015 20:02 Go to next message
Jorelia Mising name is currently offline Jorelia Mising nameFriend
Messages: 3
Registered: June 2015
Junior Member
Hi Team,

I got an exception when I try to create a new schema (deployment) after a fresh installation of Papyrus and CDO.

I got with exception: Package not found: http://www.eclipse.org/papyrus/0.7.0/sashdi

Moreover I'm still looking for the palette, to fill my diagram...but not palette.

Please HELP !


!ENTRY org.eclipse.emf.cdo.server.security 1 0 2015-06-09 15:40:56.634
!MESSAGE Security extension started
[INFO] CDO server started

!ENTRY org.eclipse.emf.cdo.server 1 0 2015-06-09 15:40:56.635
!MESSAGE CDO server started
[ERROR] Package not found: http://www.eclipse.org/papyrus/0.7.0/sashdi

!ENTRY org.eclipse.net4j 4 0 2015-06-09 15:43:01.341
!MESSAGE Package not found: http://www.eclipse.org/papyrus/0.7.0/sashdi
java.lang.IllegalStateException: Package not found: http://www.eclipse.org/papyrus/0.7.0/sashdi
at org.eclipse.emf.cdo.common.model.CDOClassifierRef.resolve(CDOClassifierRef.java:116)
at org.eclipse.emf.cdo.spi.common.protocol.CDODataInputImpl.readCDOClassifierRefAndResolve(CDODataInputImpl.java:170)
at org.eclipse.emf.cdo.spi.common.protocol.CDODataInputImpl.readCDORevisionOrPrimitiveOrClassifier(CDODataInputImpl.java:618)
at org.eclipse.emf.cdo.internal.common.CDOQueryInfoImpl.<init>(CDOQueryInfoImpl.java:53)
at org.eclipse.emf.cdo.server.internal.net4j.protocol.QueryIndication.indicating(QueryIndication.java:53)
at org.eclipse.emf.cdo.server.internal.net4j.protocol.CDOServerIndication.indicating(CDOServerIndication.java:86)
at org.eclipse.net4j.signal.IndicationWithResponse.doExtendedInput(IndicationWithResponse.java:92)
at org.eclipse.net4j.signal.Signal.doInput(Signal.java:331)
at org.eclipse.net4j.signal.IndicationWithResponse.execute(IndicationWithResponse.java:65)
at org.eclipse.emf.cdo.server.internal.net4j.protocol.CDOServerReadIndication.execute(CDOServerReadIndication.java:36)
at org.eclipse.net4j.signal.Signal.runSync(Signal.java:256)
at org.eclipse.net4j.signal.Signal.run(Signal.java:149)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
!STACK 0
Re: Sashdi [message #1698216 is a reply to message #1697953] Fri, 12 June 2015 08:43 Go to previous messageGo to next message
Gabriel Pascual is currently offline Gabriel PascualFriend
Messages: 31
Registered: April 2013
Location: Laval, France
Member
Hi,

It seems it misses several plugins in your installation.


  • What version of Papyrus did you install ?
  • What Update Site did you use to install Papyrus and CDO ?


Regards

Gabriel


Software Development Engineer
Re: Sashdi [message #1698341 is a reply to message #1698216] Sun, 14 June 2015 14:27 Go to previous messageGo to next message
Jorelia Mising name is currently offline Jorelia Mising nameFriend
Messages: 3
Registered: June 2015
Junior Member
Hi Gabriel,

Thank you for your answer. It was my very first contact with EMF, CDO and Papyrus as I use to use standalone versions of Enterprise Architect or MagicDraw.

From here :
- https://www.eclipse.org/papyrus/
- http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna

CDO server from eclipse market place, via the install button
http://marketplace.eclipse.org/marketplace-client-intro?mpc_install=573

I remembered that, that I've installed CDO after installing Papyrus because the first time I did not know how to start papyrus (Making a new project...), I thought that Papyrus required a CDO repository to save a model... But I know now that it is not necessary.... it is not obvious to configure a CDO server for the first time. I used H2 for now.

I remembered too, that the first time I've installed Papyrus, It won't install all artifacts like stuff related to hibernate and Teneo and other. It was correct for me because I did not need to work with hibernate and etc...

However, I've also try to install Teneo to complete Papyrus from here:
- https://wiki.eclipse.org/Teneo
- https://wiki.eclipse.org/Teneo/Hibernate/Download_and_Install

Despite of that, when I tried again to install Papyrus, some artifact still missing then I've left the installation like this as it does not seem to hurt the software.

My first usage of Papyrus was a little bit difficult. After inserting a new diagram, I did not see any way to create components, actors and so on. I got some difficulty to see from where to take the tools. Then I found the palette.... after reading a couple of Started Guides... Wink)

There are many small bugs in Papyrus and many small features missing that will improve the ergonomic of the software. However the product is good enough and stable for working with. THANK YOU.

Ok, let me know how to install Papyrus from here : https://www.eclipse.org/downloads/download.php?file=/modeling/mdt/papyrus/downloads/drops/1.0.2/R201502180839/Papyrus-Update-1.0.2.zip

Once I've got the zip, what are the next steps ?? Why this page does not explain the next steps ? The file structure is like an update site ? Let me know.

Is is true that it exist a standalone version of Papyrus ? Where to download it if we want to test it ?

Thank you.

J.
Re: Sashdi [message #1698380 is a reply to message #1698341] Mon, 15 June 2015 08:30 Go to previous messageGo to next message
Gabriel Pascual is currently offline Gabriel PascualFriend
Messages: 31
Registered: April 2013
Location: Laval, France
Member
Hi Jorelia,

That's true, Papyrus can be used without CDO or other external tools like Teneo. More, to use Papyrus with CDO, you should install "Extra" plugins so that it works well:
Papyrus CDO (Luna):https://hudson.eclipse.org/papyrus/job/Papyrus-Luna-Extra/lastSuccessfulBuild/artifact/releng/extras/target/repository/
For Papyrus Luna, you can not choose to install only CDO for Papyrus but this was fixed in Papyrus Mars(24th June).

Else, once you have got Papyrus 1.0.2 Update site zip file, you have to go in Eclipse application menu "Help > Install New Software ..." and to select "Add..." button. Then, you have to indicate where the zip file is located with "Archive..." button.

Otherwise, there is not yet a standalone version of Papyrus but there are some works about it.

HIH

Regards

Gabriel


Software Development Engineer
Re: Sashdi [message #1698476 is a reply to message #1698380] Mon, 15 June 2015 21:25 Go to previous messageGo to next message
Jorelia Mising name is currently offline Jorelia Mising nameFriend
Messages: 3
Registered: June 2015
Junior Member
Hi Gabriel,

Thank you so much for your answer. Then I will try to update the plugin to see if the error disappears.

Well, it works well with CDO server. I've no problem with that. It is just a matter of configuration, but once you got the good link to read about CDO server configuration, it is easy. The sole drawback is about starting the CDO server manually (run Configuration...) from Eclipse. Otherwise, CDO server works pretty well.

Thank you for the link but what is the added value of this Extras ? in using it ?

Thx.

J.
Re: Sashdi [message #1698505 is a reply to message #1698476] Tue, 16 June 2015 07:03 Go to previous message
Gabriel Pascual is currently offline Gabriel PascualFriend
Messages: 31
Registered: April 2013
Location: Laval, France
Member
Hi Jorelia,

With "Papyrus CDO" Extra, all features are compliant with CDO tool because Papyrus does not use it by default. Christian Damus worked on integration and he made some videos[1] about it.
If you have to use CDO with Papyrus, I advice you to install Papyrus CDO(it's made for that Smile ) .

Regards

Gabriel

1: https://www.youtube.com/watch?v=n40Dad5-ZYY


Software Development Engineer
Previous Topic:How to embed a table into a property view
Next Topic:Change size of decorations for associations
Goto Forum:
  


Current Time: Mon Sep 21 16:45:11 GMT 2020

Powered by FUDForum. Page generated in 0.08255 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top