Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EMF Forms]( ECP SDK e4)
[EMF Forms] [message #1695072] Mon, 11 May 2015 19:35 Go to next message
Mr Cur is currently offline Mr CurFriend
Messages: 31
Registered: September 2014
Member
Hi,

I am working through the tutorial on http://eclipsesource.com/blogs/tutorials/getting-started-with-the-emf-client-platform/#custommodel

It is suggested to use ECP SDK e4.
Where can I find it?
I used http://download.eclipse.org/ecp/releases/releases_15/ and there is only e3.

Thanks in advance.

Cur
Re: [EMF Forms] [message #1695112 is a reply to message #1695072] Tue, 12 May 2015 06:55 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

it depends on whether you want an e3 or an e4 application.
The e4 SDK should be on the target platform update site
(https://www.eclipse.org/ecp/emfforms/download.html)

Please let us know, if not.

Best regards

Jonas


Am 11.05.2015 um 21:35 schrieb Mr Cur:
> Hi,
>
> I am working through the tutorial on
> http://eclipsesource.com/blogs/tutorials/getting-started-with-the-emf-client-platform/#custommodel
>
>
> It is suggested to use ECP SDK e4.
> Where can I find it?
> I used http://download.eclipse.org/ecp/releases/releases_15/ and there
> is only e3.
>
> Thanks in advance.
>
> Cur


--
Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: [EMF Forms] [message #1695222 is a reply to message #1695072] Tue, 12 May 2015 19:12 Go to previous messageGo to next message
Mr Cur is currently offline Mr CurFriend
Messages: 31
Registered: September 2014
Member
Thanks for the answer.
I thought I needed SDK 4 because I run Luna but appearantly, this is not the case. I get however the following error while running the demo:

!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.pde.build [1192]
Unresolved requirement: Import-Package: org.eclipse.equinox.frameworkadmin; version="[2.0.0,3.0.0)"

The demo runs by the way.

Any ideas?

Thanks.
Cur
Re: [EMF Forms] [message #1695267 is a reply to message #1695222] Wed, 13 May 2015 07:09 Go to previous message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
The issue looks unrelated to ECP or EMF Forms. The question is, why
*pde.build is part of you run config. How did you create it?

Best regards

Jonas

Am 12.05.2015 um 21:12 schrieb Mr Cur:
> Thanks for the answer.
> I thought I needed SDK 4 because I run Luna but appearantly, this is not
> the case. I get however the following error while running the demo:
>
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module:
> org.eclipse.pde.build [1192]
> Unresolved requirement: Import-Package:
> org.eclipse.equinox.frameworkadmin; version="[2.0.0,3.0.0)"
>
> The demo runs by the way.
>
> Any ideas?
>
> Thanks.
> Cur


--
Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Previous Topic:[solved] [EMF Forms] Error using View Model Editor: "Bad type on operand stack"
Next Topic:Unable to locate installable unit
Goto Forum:
  


Current Time: Sat Sep 26 22:45:22 GMT 2020

Powered by FUDForum. Page generated in 0.02600 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top