Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Error inserting certain UTF-8 characters into MySql database
Error inserting certain UTF-8 characters into MySql database [message #1690238] Thu, 26 March 2015 00:19 Go to next message
Ralf Heydenreich is currently offline Ralf HeydenreichFriend
Messages: 235
Registered: July 2009
Senior Member
Hi all,
I have some Lithuanian strings that can't be inserted in a MySQL
database via EclipseLink JPA. I have the following string: "Ukmergės
kel. Užubalių k.". The database gets "Ukmerg?s kel. Užubali? k.". Since
I can insert this string into the database via an INSERT command (with a
database tool) correctly, I assume that the connection isn't set up
right. The JDBC string looks like follows:

javax.persistence.jdbc.url=jdbc\:mysql\://localhost/mystrangedb?useUnicode=yes&characterEncoding=UTF-8

I've checked the string with debug view (in Eclipse). There it was also
correct. Is there any extra setting for Unicode encoding in EclipseLink?

Any help would be appreciated.

Regards,
Ralf.
Re: Error inserting certain UTF-8 characters into MySql database [message #1690239 is a reply to message #1690238] Thu, 26 March 2015 00:23 Go to previous messageGo to next message
Rick Curtis is currently offline Rick CurtisFriend
Messages: 24
Registered: September 2014
Location: Rochester, MN
Junior Member
What is the version of your MySQL JDBC driver?
Re: Error inserting certain UTF-8 characters into MySql database [message #1690358 is a reply to message #1690239] Thu, 26 March 2015 20:24 Go to previous message
Ralf Heydenreich is currently offline Ralf HeydenreichFriend
Messages: 235
Registered: July 2009
Senior Member
Am 26.03.2015 um 01:23 schrieb Rick Curtis:
> What is the version of your MySQL JDBC driver?


I'm using version 5.1.30 of the MySQL driver.

Ralf.
Previous Topic:Getting Configuration error. Class [drive-class] not found intermittently
Next Topic:Is it possible to weave a .class file programmatically
Goto Forum:
  


Current Time: Fri Apr 12 10:44:00 GMT 2024

Powered by FUDForum. Page generated in 0.05120 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top