Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » ERROR, PLEASE HELP ME.(ERROR)
icon4.gif  ERROR, PLEASE HELP ME. [message #1689734] Tue, 24 March 2015 07:53 Go to next message
azar azlan is currently offline azar azlanFriend
Messages: 5
Registered: March 2015
Junior Member
Hi guys, i'm currently working on Running and Debugging MPJ Express with Eclipse for my final project and i'm facing many errores like this one.

Exception in thread "main" java.lang.UnsupportedClassVersionError: runtime/starter/MPJRun : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: runtime.starter.MPJRun. Program will exit.


I am using java version 1.6.0_34

I've searched for a while but can't find anything to help me, found some answers but just can't do it so i came here to ask for your help. Thank you.
Re: ERROR, PLEASE HELP ME. [message #1689888 is a reply to message #1689734] Tue, 24 March 2015 15:18 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4035
Registered: July 2009
Senior Member

The class was compiled for a newer version of Java: 7. Use that to run it.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: ERROR, PLEASE HELP ME. [message #1690078 is a reply to message #1689888] Wed, 25 March 2015 06:13 Go to previous messageGo to next message
azar azlan is currently offline azar azlanFriend
Messages: 5
Registered: March 2015
Junior Member
i already run use java 7, but still the same problem occur. is it another solution? *crying*
Re: ERROR, PLEASE HELP ME. [message #1690082 is a reply to message #1690078] Wed, 25 March 2015 07:36 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31837
Registered: July 2009
Senior Member
Are you sure? What makes you sure? The error makes it clear that's not
the case and your terminal trace makes it clear that your default JRE is
1.6 and that's even what you said: "I am using java version 1.6.0_34".
Now you're claiming you already use Java 7, but certainly you weren't
doing so when you first posted. Did you do something to install 1.7
since then?


On 25/03/2015 7:13 AM, azar azlan wrote:
> i already run use java 7, but still the same problem occur. is it
> another solution? *crying*


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: ERROR, PLEASE HELP ME. [message #1690083 is a reply to message #1690078] Wed, 25 March 2015 07:50 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4035
Registered: July 2009
Senior Member

It's not a question of running Eclipse with Java 7, you need to have it set up to run your application with it as well. If you were using Java 7 to run your application, you would not see this specific error and message.

From the Installed JREs preference page, make sure a version 7 is present. Then, use the Run->Run Configurations... menu action to open the Launch Configuration Dialog. From there, make sure that that JRE is the one being used for your application, either directly, or with the JavaSE-7 Execution Environment (which will only work if you actually have 7 [or 8]) installed and set up in the preferences.


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Wed, 25 March 2015 07:53]

Report message to a moderator

Re: ERROR, PLEASE HELP ME. [message #1690128 is a reply to message #1690083] Wed, 25 March 2015 12:44 Go to previous messageGo to next message
Alastair Brian is currently offline Alastair BrianFriend
Messages: 7
Registered: March 2015
Junior Member
Looking to adapt eclipse, this type of bugs are quite discouraging.
Re: ERROR, PLEASE HELP ME. [message #1690149 is a reply to message #1690128] Wed, 25 March 2015 13:32 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31837
Registered: July 2009
Senior Member
You mean adopt? Note that there is work in progress with Oomph to
address some of the more annoying aspects of installing Eclipse, at
least one Window. I.e., a self-extracting exe or using the Oomph
installer itself.

https://wiki.eclipse.org/Eclipse_Oomph_Installer

Oomph's installer itself is packaged as a self extracting exe which
firstly, ensures that you don't need to unzip anything and run into the
fact that Windows doesn't have a good unzip tool, and secondly detects
the bitness of your download and ensure that a JVM of the right bitness
and of a sufficiently high version is actually available and is actually
used (and prompts you to install and download one if one is not
available) This installer can then be used to create Eclipse
installation and the wizard will also ensure that this installation uses
an appropriate bitness and version JVM. In principle all the Eclipse
package zip downloads for Windows could be replaced by self-extracting
zips in the future, but we expect the Oomph installer will provide a
better long term experience that will allow you to install many
different IDEs for different focused purposes.

On 25/03/2015 2:23 PM, Alastair Brian wrote:
> Looking to adapt eclipse, this type of bugs are quite discouraging.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: ERROR, PLEASE HELP ME. [message #1690192 is a reply to message #1690082] Wed, 25 March 2015 15:34 Go to previous messageGo to next message
azar azlan is currently offline azar azlanFriend
Messages: 5
Registered: March 2015
Junior Member
ohh i'm sorry for that misunderstood. what i meant to say is, after Nitin said i should use java 7, i quickly change my java 6 to java 7. then i run my program. the same error occurs. my eclipse is in ubuntu 12.04.

can you explain to me what my errors meant? what does it want?
p/s: sorry for my broken english. huhu.
Re: ERROR, PLEASE HELP ME. [message #1690202 is a reply to message #1690083] Wed, 25 March 2015 16:32 Go to previous messageGo to next message
azar azlan is currently offline azar azlanFriend
Messages: 5
Registered: March 2015
Junior Member
thanks nitin and everyone. problem solved. Very Happy
Re: ERROR, PLEASE HELP ME. [message #1690387 is a reply to message #1690149] Fri, 27 March 2015 05:30 Go to previous message
Alastair Brian is currently offline Alastair BrianFriend
Messages: 7
Registered: March 2015
Junior Member
Ed Merks wrote on Wed, 25 March 2015 13:32
You mean adopt? Note that there is work in progress with Oomph to
address some of the more annoying aspects of installing Eclipse, at
least one Window. I.e., a self-extracting exe or using the Oomph
installer itself.



Oomph's installer itself is packaged as a self extracting exe which
firstly, ensures that you don't need to unzip anything and run into the
fact that Windows doesn't have a good unzip tool, and secondly detects
the bitness of your download and ensure that a JVM of the right bitness
and of a sufficiently high version is actually available and is actually
used (and prompts you to install and download one if one is not
available) This installer can then be used to create Eclipse
installation and the wizard will also ensure that this installation uses
an appropriate bitness and version JVM. In principle all the Eclipse
package zip downloads for Windows could be replaced by self-extracting
zips in the future, but we expect the Oomph installer will provide a
better long term experience that will allow you to install many
different IDEs for different focused purposes.

On 25/03/2015 2:23 PM, Alastair Brian wrote:
> Looking to adapt eclipse, this type of bugs are quite discouraging.


Sorry I misunderstood the actual context, thanks for clearing it.
Previous Topic:Re: Eclipse is unable to debug
Next Topic:a .jar in pom.xml cannot be imported automatically
Goto Forum:
  


Current Time: Mon Apr 19 00:53:47 GMT 2021

Powered by FUDForum. Page generated in 0.03363 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top