Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Unable to update Eclipse to Luna SR2
Unable to update Eclipse to Luna SR2 [message #1649379] Wed, 04 March 2015 09:42 Go to next message
Philippe Couton is currently offline Philippe CoutonFriend
Messages: 15
Registered: July 2009
Junior Member
Hi all,

I am using Eclipse Luna SR1. Since monday, I am trying to update it to SR2 by using the menu Help / Check for Updates. Eclipse shows me the available update to SR2 : Eclipse IDE for Java Developers 4.4.2.20150219-0708

Once the update is started, it aborts a few minutes after with this error message:

Quote:
An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.egit,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.egit.core,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.egit.doc,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.egit.mylyn.ui,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.egit.ui,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.jgit,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.jgit.archive,3.7.0.201502260915-r
No repository found containing: org.eclipse.update.feature,org.eclipse.egit,3.7.0.201502260915-r
No repository found containing: org.eclipse.update.feature,org.eclipse.egit.mylyn,3.7.0.201502260915-r
No repository found containing: org.eclipse.update.feature,org.eclipse.jgit,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.jgit.java7,3.7.0.201502260915-r
No repository found containing: org.eclipse.update.feature,org.eclipse.jgit.java7,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.slf4j.impl.log4j12,1.7.2.v20131105-2200


Is there a problem with the update site?
Do you have any hint to resolve this problem?

Thank you for your help.
Re: Unable to update Eclipse to Luna SR2 [message #1649491 is a reply to message #1649379] Wed, 04 March 2015 10:51 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 28698
Registered: July 2009
Senior Member
Philippe,

The download server has been extremely slow these past days, most likely
with so many people updating, resulting timeouts that kill the
installation process. I've been having the same type of problem...


On 04/03/2015 10:42 AM, Philippe Couton wrote:
> Hi all,
>
> I am using Eclipse Luna SR1. Since monday, I am trying to update it to
> SR2 by using the menu Help / Check for Updates. Eclipse shows me the
> available update to SR2 : Eclipse IDE for Java Developers
> 4.4.2.20150219-0708
>
> Once the update is started, it aborts a few minutes after with this
> error message:
>
> Quote:
>> An error occurred while collecting items to be installed
>> session context was:(profile=epp.package.java,
>> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect,
>> operand=, action=).
>> No repository found containing:
>> osgi.bundle,org.eclipse.egit,3.7.0.201502260915-r
>> No repository found containing:
>> osgi.bundle,org.eclipse.egit.core,3.7.0.201502260915-r
>> No repository found containing:
>> osgi.bundle,org.eclipse.egit.doc,3.7.0.201502260915-r
>> No repository found containing:
>> osgi.bundle,org.eclipse.egit.mylyn.ui,3.7.0.201502260915-r
>> No repository found containing:
>> osgi.bundle,org.eclipse.egit.ui,3.7.0.201502260915-r
>> No repository found containing:
>> osgi.bundle,org.eclipse.jgit,3.7.0.201502260915-r
>> No repository found containing:
>> osgi.bundle,org.eclipse.jgit.archive,3.7.0.201502260915-r
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.egit,3.7.0.201502260915-r
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.egit.mylyn,3.7.0.201502260915-r
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.jgit,3.7.0.201502260915-r
>> No repository found containing:
>> osgi.bundle,org.eclipse.jgit.java7,3.7.0.201502260915-r
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.jgit.java7,3.7.0.201502260915-r
>> No repository found containing:
>> osgi.bundle,org.slf4j.impl.log4j12,1.7.2.v20131105-2200
>
>
> Is there a problem with the update site?
> Do you have any hint to resolve this problem?
>
> Thank you for your help.
Re: Unable to update Eclipse to Luna SR2 [message #1669171 is a reply to message #1649491] Thu, 12 March 2015 20:05 Go to previous messageGo to next message
Denis Kuniß is currently offline Denis KunißFriend
Messages: 3
Registered: March 2015
Junior Member
... seems to be a more general error as I got similar one for different Eclipse instances, versions, network environments, and OSs (at work and at home):
An error occurred while collecting items to be installed
session context was:(profile=epp.package.dsl, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.egit,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.egit.core,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.egit.doc,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.egit.ui,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.jgit,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.jgit.archive,3.7.0.201502260915-r
No repository found containing: org.eclipse.update.feature,org.eclipse.egit,3.7.0.201502260915-r
No repository found containing: org.eclipse.update.feature,org.eclipse.jgit,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.eclipse.jgit.java7,3.7.0.201502260915-r
No repository found containing: org.eclipse.update.feature,org.eclipse.jgit.java7,3.7.0.201502260915-r
No repository found containing: osgi.bundle,org.slf4j.impl.log4j12,1.7.2.v20131105-2200

Does anyone has an idea how to overcome this?

Denis
Re: Unable to update Eclipse to Luna SR2 [message #1678778 is a reply to message #1669171] Mon, 16 March 2015 10:33 Go to previous messageGo to next message
Philippe Couton is currently offline Philippe CoutonFriend
Messages: 15
Registered: July 2009
Junior Member
Hi all,

I finally resolved my problem by manually adding the EGit update site (http://download.eclipse.org/egit/updates) to my update sites list in the Eclipse preferences. After that, updates worked without any error.

I don't remember if I accidentally removed this upate site since I do not use Git at all or if it was "naturally" missing.

Philippe
Re: Unable to update Eclipse to Luna SR2 [message #1690919 is a reply to message #1669171] Tue, 31 March 2015 22:21 Go to previous messageGo to next message
Eric Leboffe is currently offline Eric LeboffeFriend
Messages: 1
Registered: March 2015
Junior Member
Denis,

Were you able to resolve your error? I am getting a similar error and haven't been able to resolve what the problem might be.

Here is my error:

"An error occurred while collecting items to be installed
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,net.java.dev.jna,3.5.2"

Thanks
Re: Unable to update Eclipse to Luna SR2 [message #1691083 is a reply to message #1690919] Thu, 02 April 2015 08:17 Go to previous messageGo to next message
Mulham Coder is currently offline Mulham CoderFriend
Messages: 1
Registered: April 2015
Junior Member
Thanks Philippe, that fixed the issue for me.
Re: Unable to update Eclipse to Luna SR2 [message #1691252 is a reply to message #1678778] Fri, 03 April 2015 23:19 Go to previous messageGo to next message
Daniel   is currently offline Daniel Friend
Messages: 24
Registered: July 2014
Junior Member
Philippe Couton wrote on Mon, 16 March 2015 11:33
[...] resolved my problem by manually adding the EGit update site (please look up 3 posts above for url) to my update sites list in the Eclipse preferences. After that, updates worked without any error.[...]


reply because i found this thread while running into same error and this was the solution. Thank you for taking the time to describe it, Philippe!

Daniel
Re: Unable to update Eclipse to Luna SR2 [message #1691495 is a reply to message #1678778] Tue, 07 April 2015 15:46 Go to previous messageGo to next message
Benjamin Ellenberger is currently offline Benjamin EllenbergerFriend
Messages: 3
Registered: April 2015
Junior Member
Thanks Phillipe, that resolved my problem as well. It is the missing egit repository.
Re: Unable to update Eclipse to Luna SR2 [message #1693561 is a reply to message #1649379] Sat, 25 April 2015 09:53 Go to previous messageGo to next message
Mickey Mouse is currently offline Mickey MouseFriend
Messages: 18
Registered: July 2012
Junior Member
Hi,
I was facing the same error and I already had the update site http://download.eclipse.org/egit/updates registered. Though installing/updating EGit from the Eclipse Marketplace did the trick for me: http://marketplace.eclipse.org/content/egit-git-team-provider

All the best,
Mickey

[Updated on: Sat, 25 April 2015 09:53]

Report message to a moderator

Re: Unable to update Eclipse to Luna SR2 [message #1694744 is a reply to message #1693561] Thu, 07 May 2015 13:59 Go to previous messageGo to next message
Rob Mitchell is currently offline Rob MitchellFriend
Messages: 1
Registered: May 2015
Junior Member
Since Git/EGit has horrible performance for me with Eclipse Luna, I disabled it in my projects. When I try to do Luna update, I would get error:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.egit,3.7.1.201504261725-r
No repository found containing: osgi.bundle,org.eclipse.egit.core,3.7.1.201504261725-r
No repository found containing: osgi.bundle,org.eclipse.egit.doc,3.7.1.201504261725-r
No repository found containing: osgi.bundle,org.eclipse.egit.mylyn.ui,3.7.1.201504261725-r
No repository found containing: osgi.bundle,org.eclipse.egit.ui,3.7.1.201504261725-r
No repository found containing: osgi.bundle,org.eclipse.jgit,3.7.1.201504261725-r
No repository found containing: osgi.bundle,org.eclipse.jgit.archive,3.7.1.201504261725-r
No repository found containing: org.eclipse.update.feature,org.eclipse.egit,3.7.1.201504261725-r
No repository found containing: org.eclipse.update.feature,org.eclipse.egit.mylyn,3.7.1.201504261725-r
No repository found containing: org.eclipse.update.feature,org.eclipse.jgit,3.7.1.201504261725-r
No repository found containing: osgi.bundle,org.eclipse.jgit.java7,3.7.1.201504261725-r
No repository found containing: org.eclipse.update.feature,org.eclipse.jgit.java7,3.7.1.201504261725-r
No repository found containing: osgi.bundle,org.slf4j.impl.log4j12,1.7.2.v20131105-2200

To fix, I "disabled" the EGit update from the Eclipse > Preferences > Available Software Sites and now Update worked properly. Just my $0.02

I hope debugging and getting Editor to get to first line of debug works faster.
Re: Unable to update Eclipse to Luna SR2 [message #1730620 is a reply to message #1649379] Wed, 27 April 2016 07:36 Go to previous messageGo to next message
Xavier Ottolini is currently offline Xavier OttoliniFriend
Messages: 4
Registered: April 2016
Junior Member
Hi you all,

I have got the same kind of message. I added the available softwares sites in the linked file. When I go to Help > Check for Udate, I get this message after a long time :

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,minimal-json,0.9.4
No repository found containing: osgi.bundle,minimatch.java,1.1.0
No repository found containing: osgi.bundle,org.apache.axis,1.4.0.v201411182030
No repository found containing: osgi.bundle,org.eclipse.dltk,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.annotations,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.console,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.console.ui,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.core,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.core.index,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.core.index.sql,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.core.index.sql.h2,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.core.manipulation,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.debug,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.debug.ui,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.formatter,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.launching,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.logconsole,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.logconsole.ui,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.testing,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.ui,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.validators.core,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.validators.externalchecker,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.dltk.validators.ui,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.egit.github.core,4.0.3.201509231615-r
No repository found containing: osgi.bundle,org.eclipse.jem.proxy,2.0.500.v201504161518
No repository found containing: osgi.bundle,org.eclipse.jst.common.frameworks,1.1.701.v201509021802
No repository found containing: osgi.bundle,org.eclipse.jst.j2ee,1.1.850.v201506041749
No repository found containing: osgi.bundle,org.eclipse.jst.j2ee.core,1.3.200.v201505041449
No repository found containing: osgi.bundle,org.eclipse.jst.j2ee.web,1.1.850.v201503311656
No repository found containing: osgi.bundle,org.eclipse.jst.jsf.common,1.5.101.v201504022146
No repository found containing: osgi.bundle,org.eclipse.jst.jsf.core,1.7.110.v201504071708
No repository found containing: osgi.bundle,org.eclipse.jst.jsf.facelet.core,1.3.100.v201504071708
No repository found containing: osgi.bundle,org.eclipse.jst.jsf.facelet.ui,1.3.100.v201505112336
No repository found containing: osgi.bundle,org.eclipse.jst.jsp.core,1.2.800.v201505130300
No repository found containing: osgi.bundle,org.eclipse.jst.jsp.ui,1.1.1000.v201505130300
No repository found containing: osgi.bundle,org.eclipse.jst.pagedesigner,1.7.100.v201507242118
No repository found containing: osgi.bundle,org.eclipse.jst.server.tomcat.core,1.1.701.v201508232356
No repository found containing: osgi.bundle,org.eclipse.jst.ws,1.0.750.v201503231435
No repository found containing: osgi.bundle,org.eclipse.jst.ws.axis.consumption.core,1.0.550.v201505131719
No repository found containing: osgi.bundle,org.eclipse.jst.ws.axis.consumption.ui,1.0.800.v201505131719
No repository found containing: osgi.bundle,org.eclipse.jst.ws.axis.creation.ui,1.0.850.v201505131719
No repository found containing: osgi.bundle,org.eclipse.jst.ws.consumption,1.0.800.v201505131719
No repository found containing: osgi.bundle,org.eclipse.jst.ws.consumption.ui,1.1.800.v201504152025
No repository found containing: osgi.bundle,org.eclipse.jst.ws.creation.ui,1.0.900.v201503111711
No repository found containing: osgi.bundle,org.eclipse.jst.ws.jaxrs.core,1.0.600.v201505131719
No repository found containing: osgi.bundle,org.eclipse.jst.ws.jaxrs.ui,1.0.700.v201505131719
No repository found containing: osgi.bundle,org.eclipse.jst.ws.jaxws.core,1.0.402.v201504272018
No repository found containing: osgi.bundle,org.eclipse.jst.ws.jaxws.ui,1.0.401.v201504291921
No repository found containing: osgi.bundle,org.eclipse.jst.ws.jaxws.utils,1.0.301.v201504272154
No repository found containing: osgi.bundle,org.eclipse.jst.ws.uddiregistry,1.0.600.v201505131719
No repository found containing: osgi.bundle,org.eclipse.jst.ws.ui,1.0.500.v201505131719
No repository found containing: osgi.bundle,org.eclipse.m2e.core,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.core.ui,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.discovery,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.editor,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.editor.xml,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.jdt,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.jdt.ui,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.launching,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.lifecyclemapping.defaults,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.logback.appender,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.logback.configuration,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.model.edit,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.profiles.core,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.profiles.ui,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.refactoring,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.scm,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.wtp,1.2.1.20150819-2220
No repository found containing: osgi.bundle,org.eclipse.m2e.wtp.jaxrs,1.2.1.20150819-2220
No repository found containing: osgi.bundle,org.eclipse.m2e.wtp.jpa,1.2.1.20150819-2224
No repository found containing: osgi.bundle,org.eclipse.m2e.wtp.jsf,1.2.1.20150819-2220
No repository found containing: osgi.bundle,org.eclipse.m2e.wtp.overlay,1.2.1.20150819-2220
No repository found containing: osgi.bundle,org.eclipse.m2e.wtp.overlay.ui,1.2.1.20150819-2220
No repository found containing: osgi.bundle,org.eclipse.mylyn.github.core,4.0.3.201509231615-r
No repository found containing: osgi.bundle,org.eclipse.mylyn.github.doc,4.0.3.201509231615-r
No repository found containing: osgi.bundle,org.eclipse.mylyn.github.ui,4.0.3.201509231615-r
No repository found containing: osgi.bundle,org.eclipse.php.core,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.core.parser,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.debug.core,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.debug.daemon,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.debug.ui,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.formatter.core,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.formatter.ui,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.help,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.refactoring.core,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.refactoring.ui,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.server.core,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.server.ui,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.php.ui,3.6.0.201509151953
No repository found containing: osgi.bundle,org.eclipse.rap.doc,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.rap.tools.intro,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.rap.tools.intro.source,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.rap.tools.launch,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.rap.tools.launch.rwt,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.rap.tools.launch.rwt.source,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.rap.tools.launch.source,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.rap.tools.templates,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.rap.tools.templates.source,3.0.1.20150708-1759
No repository found containing: osgi.bundle,org.eclipse.team.svn.core.nl1,3.0.0.I20150529-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.m2e.sources,3.0.0.I20150529-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.mylyn.sources,3.0.0.I20150529-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.nl1,3.0.0.I20150529-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.nl1.sources,3.0.0.I20150529-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.resource.ignore.rules.jdt.sources,3.0.0.I20150529-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.revision.graph.sources,3.0.0.I20150529-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.sources,3.0.4.I20160131-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.ui.nl1,3.0.0.I20150529-1700
No repository found containing: osgi.bundle,org.eclipse.wst.command.env,1.0.500.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.command.env.core,1.0.300.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.command.env.ui,1.1.200.v201503231435
No repository found containing: osgi.bundle,org.eclipse.wst.common.emf,1.2.400.v201505132009
No repository found containing: osgi.bundle,org.eclipse.wst.common.frameworks.ui,1.2.400.v201504292002
No repository found containing: osgi.bundle,org.eclipse.wst.common.modulecore.ui,1.0.300.v201505072128
No repository found containing: osgi.bundle,org.eclipse.wst.common.project.facet.ui,1.4.600.v201505072140
No repository found containing: osgi.bundle,org.eclipse.wst.common.uriresolver,1.2.200.v201505132009
No repository found containing: osgi.bundle,org.eclipse.wst.html.ui,1.0.1000.v201505130300
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.core,1.3.401.v201507290128
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.debug.core,3.1.200.v201502261613
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.debug.crossfire,1.0.500.v201505071819
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.debug.rhino,1.0.400.v201503300052
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.debug.rhino.debugger,1.0.500.v201503300052
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.debug.rhino.ui,1.0.400.v201503270022
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.debug.transport,1.0.300.v201502261613
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.debug.ui,1.0.500.v201502261613
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.doc,1.4.101.v201507140011
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.manipulation,1.0.600.v201505071819
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.support.ie,1.0.600.v201505071819
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.ui,1.1.601.v201507290118
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.web.core,1.0.800.v201505130300
No repository found containing: osgi.bundle,org.eclipse.wst.server.core,1.7.0.v201508271522
No repository found containing: osgi.bundle,org.eclipse.wst.server.discovery,1.1.0.v201508271522
No repository found containing: osgi.bundle,org.eclipse.wst.server.preview,1.1.302.v201411112027
No repository found containing: osgi.bundle,org.eclipse.wst.server.ui,1.5.201.v201509022125
No repository found containing: osgi.bundle,org.eclipse.wst.sse.ui,1.3.400.v201505141512
No repository found containing: osgi.bundle,org.eclipse.wst.validation,1.2.700.v201508251749
No repository found containing: osgi.bundle,org.eclipse.wst.ws,1.1.400.v201503231435
No repository found containing: osgi.bundle,org.eclipse.wst.ws.explorer,1.0.800.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.ws.parser,1.0.600.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.ws.service.policy,1.0.450.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.ws.service.policy.ui,1.0.500.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.ws.ui,1.1.300.v201503231435
No repository found containing: osgi.bundle,org.eclipse.wst.wsdl,1.2.400.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.wsdl.ui,1.2.700.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.wsdl.validation,1.1.700.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.wsi,1.0.600.v201505131719
No repository found containing: osgi.bundle,org.eclipse.wst.wsi.ui,1.0.600.v201505131719
No repository found containing: osgi.bundle,org.mozilla.javascript,1.7.4.v201504221540
No repository found containing: osgi.bundle,org.sonatype.m2e.mavenarchiver,0.17.0.201502101659-signed-20150525172209
No repository found containing: osgi.bundle,tern.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.jsdt.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.jsdt.ui,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.eslint.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.eslint.ui,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.jscs.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.jscs.ui,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.jshint.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.jshint.ui,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.lint.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.lint.ui,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.linter.ui,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.server.nodejs.core,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.server.nodejs.embed.win32.win32.x86_64,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.server.nodejs.ui,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.eclipse.ide.ui,1.1.0.201511082254
No repository found containing: osgi.bundle,tern.server.nodejs,1.1.0.201511082254
No repository found containing: osgi.bundle,ternjs,1.1.0.201511082254
No repository found containing: osgi.bundle,javax.servlet,3.1.0.v201410161800
No repository found containing: org.eclipse.update.feature,org.eclipse.dltk.core,5.3.0.201509040407
No repository found containing: org.eclipse.update.feature,org.eclipse.dltk.core.index,5.3.0.201509040407
No repository found containing: binary,org.eclipse.dltk.core_root,5.3.0.201509040407
No repository found containing: osgi.bundle,org.eclipse.jetty.continuation,9.2.13.v20150730
No repository found containing: osgi.bundle,org.eclipse.jetty.http,9.2.13.v20150730
No repository found containing: osgi.bundle,org.eclipse.jetty.io,9.2.13.v20150730
No repository found containing: osgi.bundle,org.eclipse.jetty.security,9.2.13.v20150730
No repository found containing: osgi.bundle,org.eclipse.jetty.server,9.2.13.v20150730
No repository found containing: osgi.bundle,org.eclipse.jetty.servlet,9.2.13.v20150730
No repository found containing: osgi.bundle,org.eclipse.jetty.util,9.2.13.v20150730
No repository found containing: osgi.bundle,org.eclipse.jetty.webapp,9.2.9.v20150224
No repository found containing: osgi.bundle,org.eclipse.jetty.webapp,9.2.13.v20150730
No repository found containing: osgi.bundle,org.eclipse.jetty.xml,9.2.9.v20150224
No repository found containing: osgi.bundle,org.eclipse.jetty.xml,9.2.13.v20150730
No repository found containing: org.eclipse.update.feature,org.eclipse.jpt.jpa.feature,3.4.2.v201505291546
No repository found containing: org.eclipse.update.feature,org.eclipse.jsf.feature,3.8.0.v201505112336
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.enterprise_ui.feature,3.7.0.v201505131719
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature,2.6.0.v201410101748
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.server_adapters.ext.feature,3.3.401.v201508232356
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.server_adapters.feature,3.2.400.v201503102136
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.server_core.feature,3.4.200.v201503102136
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.server_ui.feature,3.4.200.v201503102136
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.server_userdoc.feature,3.3.300.v201503102136
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.web_core.feature,3.7.1.v201509021802
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.web_ui.feature,3.7.1.v201509021802
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.webpageeditor.feature,2.7.1.v201508270443
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.ws.cxf.feature,1.1.203.v201503151903
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.ws.jaxws.dom.feature,1.0.302.v201504272154
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.ws.jaxws.feature,1.2.202.v201504291921
No repository found containing: org.eclipse.update.feature,org.eclipse.jst.ws.jaxws_userdoc.feature,1.0.402.v201503151903
No repository found containing: osgi.bundle,org.eclipse.m2e.archetype.common,1.6.2.20150902-0001
No repository found containing: org.eclipse.update.feature,org.eclipse.m2e.feature,1.6.2.20150902-0002
No repository found containing: org.eclipse.update.feature,org.eclipse.m2e.logback.feature,1.6.2.20150902-0002
No repository found containing: osgi.bundle,org.eclipse.m2e.maven.indexer,1.6.2.20150902-0001
No repository found containing: osgi.bundle,org.eclipse.m2e.maven.runtime,1.6.2.20150902-0001
No repository found containing: osgi.bundle,org.eclipse.m2e.maven.runtime.slf4j.simple,1.6.2.20150902-0001
No repository found containing: osgi.bundle,org.eclipse.m2e.workspace.cli,0.3.1
No repository found containing: org.eclipse.update.feature,org.eclipse.m2e.wtp.feature,1.2.1.20150819-2220
No repository found containing: org.eclipse.update.feature,org.eclipse.m2e.wtp.jaxrs.feature,1.2.1.20150819-2220
No repository found containing: org.eclipse.update.feature,org.eclipse.m2e.wtp.jpa.feature,1.2.1.20150819-2224
No repository found containing: org.eclipse.update.feature,org.eclipse.m2e.wtp.jsf.feature,1.2.1.20150819-2220
No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.github.feature,4.0.3.201509231615-r
No repository found containing: org.eclipse.update.feature,org.eclipse.php,3.6.0.201509151953
No repository found containing: org.eclipse.update.feature,org.eclipse.rap.tools.feature,3.0.1.20150908-1020
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.m2e.sources,3.0.0.I20150529-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.mylyn.sources,3.0.0.I20150529-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.nl1,3.0.0.I20150529-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.nl1.sources,3.0.0.I20150529-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.resource.ignore.rules.jdt.sources,3.0.0.I20150529-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.revision.graph.sources,3.0.0.I20150529-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.source,3.0.4.I20160131-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.sources,3.0.4.I20160131-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.common.fproj,3.7.0.v201505072140
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.common_core.feature,3.7.1.v201508262220
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.common_ui.feature,3.7.1.v201508262220
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.jsdt.feature,1.6.201.v201508262249
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.server_adapters.feature,3.2.402.v201505042029
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.server_core.feature,3.3.600.v201508271522
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.server_ui.feature,3.3.600.v201509022125
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.web_core.feature,3.7.1.v201508271605
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.web_ui.feature,3.7.1.v201509022125
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.ws_core.feature,3.7.0.v201505131719
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.ws_ui.feature,3.7.1.v201508271926
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.xml_core.feature,3.7.0.v201502261749
No repository found containing: org.eclipse.update.feature,org.eclipse.wst.xml_ui.feature,3.7.1.v201508271605
No repository found containing: org.eclipse.update.feature,org.sonatype.m2e.mavenarchiver.feature,0.17.0.201502101659-signed-20150525172209
No repository found containing: org.eclipse.update.feature,tern-feature,1.1.0.201511082254
No repository found containing: org.eclipse.update.feature,tern-jsdt-feature,1.1.0.201511082254
No repository found containing: org.eclipse.update.feature,tern-linters-feature,1.1.0.201511082254
No repository found containing: org.eclipse.update.feature,tern-server-nodejs-feature,1.1.0.201511082254
No repository found containing: org.eclipse.update.feature,tern.eclipse.ide.server.nodejs.embed,1.1.0.201511082254
Re: Unable to update Eclipse to Luna SR2 [message #1736844 is a reply to message #1730620] Sat, 02 July 2016 21:46 Go to previous messageGo to next message
jscriptor Mike is currently offline jscriptor MikeFriend
Messages: 1
Registered: July 2016
Junior Member
I started seeing this error when I downloaded Version: 3.7.3.RELEASE. I followed all the above recommendations, nothing worked.

I went back to Version: 3.7.2.RELEASE and did an update from there, the error went away.

I have no idea why, but update from Version: 3.7.2.RELEASE to Version: 3.7.3.RELEASE instead of a fresh download of Version: 3.7.3.RELEASE seems to resolve the problem
Re: Unable to update Eclipse to Luna SR2 [message #1750197 is a reply to message #1736844] Sat, 17 December 2016 10:28 Go to previous messageGo to next message
Christophe GOMES is currently offline Christophe GOMESFriend
Messages: 1
Registered: December 2016
Junior Member
You have to add this update site URL:

http://download.eclipse.org/technology/m2e/releases/
icon13.gif  Re: Unable to update Eclipse to Luna SR2 [message #1750957 is a reply to message #1649379] Mon, 02 January 2017 20:16 Go to previous message
Miroslav Zat'ko is currently offline Miroslav Zat'koFriend
Messages: 2
Registered: February 2016
Junior Member
this is definitely some weird issue.
I have 2 installations of exactly same version of eclipse(4.6.1) on two machines with same OS(Ubuntu 16.04LTS) with exactly same set of update sites (export->import) maintained since initial installation with same set of plugins & features
One updates without any issue and other one fails with long list of "No repository found containing: .....". Of course, when searching for updates, everything seems to be correct. This list comes after trying to run update itself.
Sad
Previous Topic:Develop Eclipse Plugins with e4
Next Topic:Duplicate tool item in eclipse e4 migration application
Goto Forum:
  


Current Time: Sat Aug 19 15:06:47 GMT 2017

Powered by FUDForum. Page generated in 0.03405 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software