Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Luna SR2 Papyrus Additional Components install problem
Luna SR2 Papyrus Additional Components install problem [message #1649136] Wed, 04 March 2015 07:06 Go to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

It seems that I cannot install "Papyrus Additional Components "

The errors from the log are below. Is this to be expected? Will this
be resolve shortly (he wrote hopefully)?

TIA

Joost

!ENTRY org.eclipse.papyrus.infra.discovery.ui 4 0 2015-03-04 07:59:21.553
!MESSAGE Problems occurred while performing installation: Operation
details
!STACK 1
org.eclipse.core.runtime.CoreException: Operation details
at
org.eclipse.papyrus.infra.discovery.ui.internal.common.PrepareInstallProfileJob.resolve(PrepareInstallProfileJob.java:135)
at
org.eclipse.papyrus.infra.discovery.ui.internal.common.PrepareInstallProfileJob.run(PrepareInstallProfileJob.java:98)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Contains: Cannot complete the install because of a conflicting dependency.
Contains: Software being installed: Papyrus Marte (Incubation)
1.0.2.v201502181446
(org.eclipse.papyrus.extra.marte.feature.feature.group
1.0.2.v201502181446)
Contains: Software currently installed: Papyrus UML
1.0.1.v201409170932 (org.eclipse.papyrus.sdk.feature.feature.group
1.0.1.v201409170932)
Contains: Only one of the following can be installed at once:
Contains: GMF Xtext Integration 1.0.1.v201409170932
(org.eclipse.papyrus.uml.xtext.integration.ui 1.0.1.v201409170932)
Contains: GMF Xtext Integration 1.0.2.v201502181349
(org.eclipse.papyrus.uml.xtext.integration.ui 1.0.2.v201502181349)
Contains: Cannot satisfy dependency:
Contains: From: Papyrus Marte (Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.extra.marte.feature.feature.group
1.0.2.v201502181446)
Contains: To: org.eclipse.papyrus.marte.vsl.ui [1.0.2.v201502181446]
Contains: Cannot satisfy dependency:
Contains: From: UML profile and library for MARTE (Incubation)
1.0.2.v201502181446 (org.eclipse.papyrus.marte.vsl.ui 1.0.2.v201502181446)
Contains: To: bundle org.eclipse.papyrus.uml.xtext.integration.ui 1.0.2
Contains: Cannot satisfy dependency:
Contains: From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
Contains: To:
org.eclipse.papyrus.uml.xtext.integration.feature.feature.group
[1.0.1.v201409170932]
Contains: Cannot satisfy dependency:
Contains: From: Papyrus XText Integration Feature 1.0.1.v201409170932
(org.eclipse.papyrus.uml.xtext.integration.feature.feature.group
1.0.1.v201409170932)
Contains: To: org.eclipse.papyrus.uml.xtext.integration.ui
[1.0.1.v201409170932]
!SUBENTRY 1 org.eclipse.equinox.p2.operations 4 0 2015-03-04 07:59:21.554
!MESSAGE Operation details
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 10054 2015-03-04
07:59:21.554
!MESSAGE Cannot complete the install because of a conflicting dependency.
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.554
!MESSAGE Software being installed: Papyrus Marte (Incubation)
1.0.2.v201502181446
(org.eclipse.papyrus.extra.marte.feature.feature.group
1.0.2.v201502181446)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE Software currently installed: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:21.555
!MESSAGE Only one of the following can be installed at once:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE GMF Xtext Integration 1.0.1.v201409170932
(org.eclipse.papyrus.uml.xtext.integration.ui 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE GMF Xtext Integration 1.0.2.v201502181349
(org.eclipse.papyrus.uml.xtext.integration.ui 1.0.2.v201502181349)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:21.555
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE From: Papyrus Marte (Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.extra.marte.feature.feature.group
1.0.2.v201502181446)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE To: org.eclipse.papyrus.marte.vsl.ui [1.0.2.v201502181446]
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:21.555
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE From: UML profile and library for MARTE (Incubation)
1.0.2.v201502181446 (org.eclipse.papyrus.marte.vsl.ui 1.0.2.v201502181446)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE To: bundle org.eclipse.papyrus.uml.xtext.integration.ui 1.0.2
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:21.555
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE To:
org.eclipse.papyrus.uml.xtext.integration.feature.feature.group
[1.0.1.v201409170932]
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:21.555
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE From: Papyrus XText Integration Feature 1.0.1.v201409170932
(org.eclipse.papyrus.uml.xtext.integration.feature.feature.group
1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:21.555
!MESSAGE To: org.eclipse.papyrus.uml.xtext.integration.ui
[1.0.1.v201409170932]

!ENTRY org.eclipse.papyrus.infra.discovery.ui 4 0 2015-03-04 07:59:37.248
!MESSAGE Problems occurred while performing installation: Operation
details
!STACK 1
org.eclipse.core.runtime.CoreException: Operation details
at
org.eclipse.papyrus.infra.discovery.ui.internal.common.PrepareInstallProfileJob.resolve(PrepareInstallProfileJob.java:135)
at
org.eclipse.papyrus.infra.discovery.ui.internal.common.PrepareInstallProfileJob.run(PrepareInstallProfileJob.java:98)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Contains: Cannot complete the install because of a conflicting dependency.
Contains: Software being installed: Papyrus Marte (Incubation)
1.0.2.v201502181446
(org.eclipse.papyrus.extra.marte.feature.feature.group
1.0.2.v201502181446)
Contains: Software currently installed: Papyrus UML
1.0.1.v201409170932 (org.eclipse.papyrus.sdk.feature.feature.group
1.0.1.v201409170932)
Contains: Only one of the following can be installed at once:
Contains: GMF Xtext Integration 1.0.1.v201409170932
(org.eclipse.papyrus.uml.xtext.integration.ui 1.0.1.v201409170932)
Contains: GMF Xtext Integration 1.0.2.v201502181349
(org.eclipse.papyrus.uml.xtext.integration.ui 1.0.2.v201502181349)
Contains: Cannot satisfy dependency:
Contains: From: Papyrus Marte (Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.extra.marte.feature.feature.group
1.0.2.v201502181446)
Contains: To: org.eclipse.papyrus.marte.vsl.ui [1.0.2.v201502181446]
Contains: Cannot satisfy dependency:
Contains: From: UML profile and library for MARTE (Incubation)
1.0.2.v201502181446 (org.eclipse.papyrus.marte.vsl.ui 1.0.2.v201502181446)
Contains: To: bundle org.eclipse.papyrus.uml.xtext.integration.ui 1.0.2
Contains: Cannot satisfy dependency:
Contains: From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
Contains: To:
org.eclipse.papyrus.uml.xtext.integration.feature.feature.group
[1.0.1.v201409170932]
Contains: Cannot satisfy dependency:
Contains: From: Papyrus XText Integration Feature 1.0.1.v201409170932
(org.eclipse.papyrus.uml.xtext.integration.feature.feature.group
1.0.1.v201409170932)
Contains: To: org.eclipse.papyrus.uml.xtext.integration.ui
[1.0.1.v201409170932]
!SUBENTRY 1 org.eclipse.equinox.p2.operations 4 0 2015-03-04 07:59:37.248
!MESSAGE Operation details
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 10054 2015-03-04
07:59:37.248
!MESSAGE Cannot complete the install because of a conflicting dependency.
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.248
!MESSAGE Software being installed: Papyrus Marte (Incubation)
1.0.2.v201502181446
(org.eclipse.papyrus.extra.marte.feature.feature.group
1.0.2.v201502181446)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.248
!MESSAGE Software currently installed: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:37.248
!MESSAGE Only one of the following can be installed at once:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE GMF Xtext Integration 1.0.1.v201409170932
(org.eclipse.papyrus.uml.xtext.integration.ui 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE GMF Xtext Integration 1.0.2.v201502181349
(org.eclipse.papyrus.uml.xtext.integration.ui 1.0.2.v201502181349)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:37.249
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE From: Papyrus Marte (Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.extra.marte.feature.feature.group
1.0.2.v201502181446)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE To: org.eclipse.papyrus.marte.vsl.ui [1.0.2.v201502181446]
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:37.249
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE From: UML profile and library for MARTE (Incubation)
1.0.2.v201502181446 (org.eclipse.papyrus.marte.vsl.ui 1.0.2.v201502181446)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE To: bundle org.eclipse.papyrus.uml.xtext.integration.ui 1.0.2
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:37.249
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE To:
org.eclipse.papyrus.uml.xtext.integration.feature.feature.group
[1.0.1.v201409170932]
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 07:59:37.249
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE From: Papyrus XText Integration Feature 1.0.1.v201409170932
(org.eclipse.papyrus.uml.xtext.integration.feature.feature.group
1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 07:59:37.249
!MESSAGE To: org.eclipse.papyrus.uml.xtext.integration.ui
[1.0.1.v201409170932]

!ENTRY org.eclipse.papyrus.infra.discovery.ui 4 0 2015-03-04 08:00:50.363
!MESSAGE Problems occurred while performing installation: Operation
details
!STACK 1
org.eclipse.core.runtime.CoreException: Operation details
at
org.eclipse.papyrus.infra.discovery.ui.internal.common.PrepareInstallProfileJob.resolve(PrepareInstallProfileJob.java:135)
at
org.eclipse.papyrus.infra.discovery.ui.internal.common.PrepareInstallProfileJob.run(PrepareInstallProfileJob.java:98)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Contains: Cannot complete the install because of a conflicting dependency.
Contains: Software being installed: Papyrus Moka Model Execution Tool
(Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.extra.moka.feature.feature.group 1.0.2.v201502181446)
Contains: Software currently installed: Papyrus UML
1.0.1.v201409170932 (org.eclipse.papyrus.sdk.feature.feature.group
1.0.1.v201409170932)
Contains: Only one of the following can be installed at once:
Contains: Papyrus UML Model Elements Icons Plugin 1.0.1.v201409170932
(org.eclipse.papyrus.uml.icons 1.0.1.v201409170932)
Contains: Papyrus UML Model Elements Icons Plugin 1.0.2.v201502181349
(org.eclipse.papyrus.uml.icons 1.0.2.v201502181349)
Contains: Cannot satisfy dependency:
Contains: From: Papyrus Moka Model Execution Tool (Incubation)
1.0.2.v201502181446
(org.eclipse.papyrus.extra.moka.feature.feature.group 1.0.2.v201502181446)
Contains: To: org.eclipse.papyrus.moka.composites.utils
[1.0.2.v201502181446]
Contains: Cannot satisfy dependency:
Contains: From: Moka Composite Utils (Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.moka.composites.utils 1.0.2.v201502181446)
Contains: To: bundle org.eclipse.papyrus.uml.icons 1.0.2
Contains: Cannot satisfy dependency:
Contains: From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
Contains: To: org.eclipse.papyrus.uml.feature.feature.group
[1.0.1.v201409170932]
Contains: Cannot satisfy dependency:
Contains: From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.uml.feature.feature.group 1.0.1.v201409170932)
Contains: To: org.eclipse.papyrus.uml.icons [1.0.1.v201409170932]
!SUBENTRY 1 org.eclipse.equinox.p2.operations 4 0 2015-03-04 08:00:50.363
!MESSAGE Operation details
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 10054 2015-03-04
08:00:50.363
!MESSAGE Cannot complete the install because of a conflicting dependency.
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.363
!MESSAGE Software being installed: Papyrus Moka Model Execution Tool
(Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.extra.moka.feature.feature.group 1.0.2.v201502181446)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE Software currently installed: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:00:50.364
!MESSAGE Only one of the following can be installed at once:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE Papyrus UML Model Elements Icons Plugin 1.0.1.v201409170932
(org.eclipse.papyrus.uml.icons 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE Papyrus UML Model Elements Icons Plugin 1.0.2.v201502181349
(org.eclipse.papyrus.uml.icons 1.0.2.v201502181349)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:00:50.364
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE From: Papyrus Moka Model Execution Tool (Incubation)
1.0.2.v201502181446
(org.eclipse.papyrus.extra.moka.feature.feature.group 1.0.2.v201502181446)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE To: org.eclipse.papyrus.moka.composites.utils
[1.0.2.v201502181446]
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:00:50.364
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE From: Moka Composite Utils (Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.moka.composites.utils 1.0.2.v201502181446)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE To: bundle org.eclipse.papyrus.uml.icons 1.0.2
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:00:50.364
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE To: org.eclipse.papyrus.uml.feature.feature.group
[1.0.1.v201409170932]
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:00:50.364
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.uml.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:00:50.364
!MESSAGE To: org.eclipse.papyrus.uml.icons [1.0.1.v201409170932]

!ENTRY org.eclipse.papyrus.infra.discovery.ui 4 0 2015-03-04 08:01:40.186
!MESSAGE Problems occurred while performing installation: Operation
details
!STACK 1
org.eclipse.core.runtime.CoreException: Operation details
at
org.eclipse.papyrus.infra.discovery.ui.internal.common.PrepareInstallProfileJob.resolve(PrepareInstallProfileJob.java:135)
at
org.eclipse.papyrus.infra.discovery.ui.internal.common.PrepareInstallProfileJob.run(PrepareInstallProfileJob.java:98)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Contains: Cannot complete the install because of a conflicting dependency.
Contains: Software being installed: Papyrus RobotML Modeling Tools
(Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.extra.robotml.feature.feature.group
1.0.2.v201502181446)
Contains: Software currently installed: Papyrus UML
1.0.1.v201409170932 (org.eclipse.papyrus.sdk.feature.feature.group
1.0.1.v201409170932)
Contains: Only one of the following can be installed at once:
Contains: Papyrus Composite Structure Diagram 1.0.1.v201409170932
(org.eclipse.papyrus.uml.diagram.composite 1.0.1.v201409170932)
Contains: Papyrus Composite Structure Diagram 1.0.2.v201502181349
(org.eclipse.papyrus.uml.diagram.composite 1.0.2.v201502181349)
Contains: Cannot satisfy dependency:
Contains: From: Papyrus RobotML Modeling Tools (Incubation)
1.0.2.v201502181446
(org.eclipse.papyrus.extra.robotml.feature.feature.group
1.0.2.v201502181446)
Contains: To: org.eclipse.papyrus.robotml.diagram.common
[1.0.2.v201502181446]
Contains: Cannot satisfy dependency:
Contains: From: Common plugin for RobotML (Incubation)
1.0.2.v201502181446 (org.eclipse.papyrus.robotml.diagram.common
1.0.2.v201502181446)
Contains: To: bundle org.eclipse.papyrus.uml.diagram.composite 1.0.2
Contains: Cannot satisfy dependency:
Contains: From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
Contains: To: org.eclipse.papyrus.uml.diagram.feature.feature.group
[1.0.1.v201409170932]
Contains: Cannot satisfy dependency:
Contains: From: Papyrus UML Diagram 1.0.1.v201409170932
(org.eclipse.papyrus.uml.diagram.feature.feature.group
1.0.1.v201409170932)
Contains: To: org.eclipse.papyrus.uml.diagram.composite
[1.0.1.v201409170932]
!SUBENTRY 1 org.eclipse.equinox.p2.operations 4 0 2015-03-04 08:01:40.186
!MESSAGE Operation details
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 10054 2015-03-04
08:01:40.186
!MESSAGE Cannot complete the install because of a conflicting dependency.
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE Software being installed: Papyrus RobotML Modeling Tools
(Incubation) 1.0.2.v201502181446
(org.eclipse.papyrus.extra.robotml.feature.feature.group
1.0.2.v201502181446)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE Software currently installed: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:01:40.186
!MESSAGE Only one of the following can be installed at once:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE Papyrus Composite Structure Diagram 1.0.1.v201409170932
(org.eclipse.papyrus.uml.diagram.composite 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE Papyrus Composite Structure Diagram 1.0.2.v201502181349
(org.eclipse.papyrus.uml.diagram.composite 1.0.2.v201502181349)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:01:40.186
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE From: Papyrus RobotML Modeling Tools (Incubation)
1.0.2.v201502181446
(org.eclipse.papyrus.extra.robotml.feature.feature.group
1.0.2.v201502181446)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE To: org.eclipse.papyrus.robotml.diagram.common
[1.0.2.v201502181446]
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:01:40.186
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE From: Common plugin for RobotML (Incubation)
1.0.2.v201502181446 (org.eclipse.papyrus.robotml.diagram.common
1.0.2.v201502181446)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE To: bundle org.eclipse.papyrus.uml.diagram.composite 1.0.2
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:01:40.186
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.186
!MESSAGE From: Papyrus UML 1.0.1.v201409170932
(org.eclipse.papyrus.sdk.feature.feature.group 1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.187
!MESSAGE To: org.eclipse.papyrus.uml.diagram.feature.feature.group
[1.0.1.v201409170932]
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 1 2015-03-04 08:01:40.187
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.187
!MESSAGE From: Papyrus UML Diagram 1.0.1.v201409170932
(org.eclipse.papyrus.uml.diagram.feature.feature.group
1.0.1.v201409170932)
!SUBENTRY 4 org.eclipse.equinox.p2.director 4 0 2015-03-04 08:01:40.187
!MESSAGE To: org.eclipse.papyrus.uml.diagram.composite
[1.0.1.v201409170932]



-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlT2rvsACgkQ0VJKUkHcX79lRQCfUDaeBo/lhk8QC4XEL8BRkGBk
F+cAnjG7WG7EagKWAVQX79fb2kD4Evw1
=QP1A
-----END PGP SIGNATURE-----


Cheers,

Joost
Re: Luna SR2 Papyrus Additional Components install problem [message #1649312 is a reply to message #1649136] Wed, 04 March 2015 09:01 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi Joost,

We've noticed an issue in the discovery site when trying to install version SR2 of an extra component on top of Papyrus SR1. And it seems that the Modeling Package's discovery site still ships Papyrus SR1 instead of SR2 for some reason.

Please try "Check for updates" to ensure that Papyrus SR2 is installed, then retry installing Marte

Camille


Camille Letavernier
Re: Luna SR2 Papyrus Additional Components install problem [message #1649499 is a reply to message #1649312] Wed, 04 March 2015 10:58 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6796
Registered: July 2009
Senior Member
Hi

There is something fundamentally broken with the "Additional Components"
mechanism.

I have just done a clean install of the Luna SR2 Modeling package and
the DSML component is once again missing from whatever, and who knows
what or where that is?

Please provide a conventional P2 aggregate repo and downloadable ZIP so
that users can use tried and trusted, debuggable, work-aroundable
technology.

Regards

Ed Willink

On 04/03/2015 09:01, Camille Letavernier wrote:
> Hi Joost,
>
> We've noticed an issue in the discovery site when trying to install
> version SR2 of an extra component on top of Papyrus SR1. And it seems
> that the Modeling Package's discovery site still ships Papyrus SR1
> instead of SR2 for some reason.
>
> Please try "Check for updates" to ensure that Papyrus SR2 is
> installed, then retry installing Marte
>
> Camille
Re: Luna SR2 Papyrus Additional Components install problem [message #1649584 is a reply to message #1649499] Wed, 04 March 2015 11:52 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi Ed,

The DSML entry for the Discovery Site is not "broken" in Luna; it has simply never been included there. It has been added to the Discovery Site in Mars. Anyway, the Discovery Site is meant for end-users: it only contains the version of extra-plugins aligned on the latest stable release.

Is there anything wrong with the Papyrus extra update sites?

http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/luna/extra
http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/extra

Camille


Camille Letavernier
Re: Luna SR2 Papyrus Additional Components install problem [message #1649614 is a reply to message #1649584] Wed, 04 March 2015 12:14 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6796
Registered: July 2009
Senior Member
Hi

Thanks for the clarifications. I'm just puzzled that there is so much
enthusiasm for me to look at Luna-only DSML issues when DSML is not a
Luna component.

http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/extra


is one half of what I want. A ZIP is much better because it is much more
predictable and allows the "Contact all sites" to be disabled improving
install speeds massively since it is not necessary to reconfigure to
avoid errors and timeouts while loading the contents from every modeling
update site that ever existed.

Regards

Ed Willink

On 04/03/2015 11:52, Camille Letavernier wrote:
> Hi Ed,
>
> The DSML entry for the Discovery Site is not "broken" in Luna; it has
> simply never been included there. It has been added to the Discovery
> Site in Mars. Anyway, the Discovery Site is meant for end-users: it
> only contains the version of extra-plugins aligned on the latest
> stable release.
>
> Is there anything wrong with the Papyrus extra update sites?
>
> http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/luna/extra
>
> http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/extra
>
>
> Camille
Re: Luna SR2 Papyrus Additional Components install problem [message #1649651 is a reply to message #1649614] Wed, 04 March 2015 12:36 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Quote:
I'm just puzzled that there is so much
enthusiasm for me to look at Luna-only DSML issues when DSML is not a
Luna component.


DSML is a Luna component; it is however not exposed in the Discovery site

Quote:
A ZIP is much better because it is much more
predictable and allows the "Contact all sites" to be disabled


Papyrus zip update sites don't contain dependencies, so they wouldn't allow you to disable "Contact all sites" either. Anyway, the zip for extra plug-ins can be found as an Hudson artifact:

https://hudson.eclipse.org/hudson/job/papyrus-trunk-extra-nightly/lastSuccessfulBuild/artifact/ (Luna Nightly, shared instance)
https://hudson.eclipse.org/papyrus/job/Papyrus-Master-Extra/lastSuccessfulBuild/artifact/ (Mars Nightly, HIPP)

Camille


Camille Letavernier
Re: Luna SR2 Papyrus Additional Components install problem [message #1649682 is a reply to message #1649651] Wed, 04 March 2015 12:56 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6796
Registered: July 2009
Senior Member
Hi

Seems like a contradiction, an additional component that you cannot
discover.

I endeavour to learn the dependencies that I need so that I
progrsssively install the EMFv, UML2, MWE, Xtpand-Xtenx, Xtext ....
ZIPs. This means I can disable contact-all-update-sites for installs
that I understand.

Good that the ZIP exists, just needs promotion to the downloads page.

Unfortunately you don't add descriptions to significant builds and mark
them as keep-forever, so it is not clear where the Luna SR2 or Mars M5
ZIPs are. Contrast with:
https://hudson.eclipse.org/ocl/job/qvtd-mars-master/, where 1.0.0M5 and
0.12.0M4 are clearly marked.

Regards

Ed Willink




On 04/03/2015 12:36, Camille Letavernier wrote:
> Quote:
>> I'm just puzzled that there is so much
>> enthusiasm for me to look at Luna-only DSML issues when DSML is not a
>> Luna component.
>
>
> DSML is a Luna component; it is however not exposed in the Discovery site
>
> Quote:
>> A ZIP is much better because it is much more
>> predictable and allows the "Contact all sites" to be disabled
>
>
> Papyrus zip update sites don't contain dependencies, so they wouldn't
> allow you to disable "Contact all sites" either. Anyway, the zip for
> extra plug-ins can be found as an Hudson artifact:
>
> https://hudson.eclipse.org/hudson/job/papyrus-trunk-extra-nightly/lastSuccessfulBuild/artifact/
> (Luna Nightly, shared instance)
> https://hudson.eclipse.org/papyrus/job/Papyrus-Master-Extra/lastSuccessfulBuild/artifact/
> (Mars Nightly, HIPP)
>
> Camille
Re: Luna SR2 Papyrus Additional Components install problem [message #1649878 is a reply to message #1649312] Wed, 04 March 2015 14:59 Go to previous messageGo to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04-03-15 10:01, Camille Letavernier wrote:
> Hi Joost,
>
> We've noticed an issue in the discovery site when trying to
> install version SR2 of an extra component on top of Papyrus SR1.
> And it seems that the Modeling Package's discovery site still ships
> Papyrus SR1 instead of SR2 for some reason.
I did not install on top of SR1 but fresh downloaded CDT SR2 package.
I than installed the the Amalgan Install Modelling Components to
install my modelling componenent: I did not use the "install New
Software". This procedure installs Papyrus SR1. This does not seem to
be appropriate. I suspect the Amalgan stuff did not make a SR2 releas?


>
> Please try "Check for updates" to ensure that Papyrus SR2 is
> installed, then retry installing Marte
>
I will try to use "install new software" without Amalgan.

TIA

Joost

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlT3HbQACgkQ0VJKUkHcX7+uZgCfXBe6RGNO4jiAupZ9wy8rdfWy
V0UAn1SFc+Jf/U4b4usbabvF/DcviIAQ
=loLK
-----END PGP SIGNATURE-----


Cheers,

Joost
Re: Luna SR2 Papyrus Additional Components install problem [message #1650012 is a reply to message #1649878] Wed, 04 March 2015 16:17 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6796
Registered: July 2009
Senior Member
Hi

There is certainly a lot wrong with

http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna

a) it takes an amazingly long time to load its contents
b) it has no 1.0.0 or 1.0.1 content

Using Wireshark, it would appear that all the 1.0.0, 1.0.1, 1.0.1a
content was removed so P2 times out and then resorts to retry strategies
for alternate naming conventions.

The p2.index files that ensure that P2 goes for correct style content
first time are also missing.

Loading the 1.0.2 index that is nominally there takes 5 seconds and
incurs 5 404's.

Loading the 1.0.1a index that is marginally there takes 8 seconds and
incurs 9 404's.

Regards

Ed Willink



On 04/03/2015 14:59, Joost Kraaijeveld wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> On 04-03-15 10:01, Camille Letavernier wrote:
>> Hi Joost,
>>
>> We've noticed an issue in the discovery site when trying to
>> install version SR2 of an extra component on top of Papyrus SR1.
>> And it seems that the Modeling Package's discovery site still ships
>> Papyrus SR1 instead of SR2 for some reason.
> I did not install on top of SR1 but fresh downloaded CDT SR2 package.
> I than installed the the Amalgan Install Modelling Components to
> install my modelling componenent: I did not use the "install New
> Software". This procedure installs Papyrus SR1. This does not seem to
> be appropriate. I suspect the Amalgan stuff did not make a SR2 releas?
>
>
>> Please try "Check for updates" to ensure that Papyrus SR2 is
>> installed, then retry installing Marte
>>
> I will try to use "install new software" without Amalgan.
>
> TIA
>
> Joost
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1
>
> iEYEARECAAYFAlT3HbQACgkQ0VJKUkHcX7+uZgCfXBe6RGNO4jiAupZ9wy8rdfWy
> V0UAn1SFc+Jf/U4b4usbabvF/DcviIAQ
> =loLK
> -----END PGP SIGNATURE-----
Re: Luna SR2 Papyrus Additional Components install problem [message #1650110 is a reply to message #1650012] Wed, 04 March 2015 17:21 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Quote:
b) it has no 1.0.0 or 1.0.1 content


All 1.0.0, 1.0.1 (and 1.0.1.v201412... which is 1.0.1a) are present in this update site, as long as you uncheck "Show only the latest version". Sounds good to me. This update site contains the 4 Luna releases for Papyrus Main + Extra, including binary and source builds (That's 4*2*2 installable features).

The update site used by the Discovery Site is only a subset of this one, I.e. http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/extra

And it was definitely not so slow a few days ago (e.g. when testing installation scenarios for SR2)

I'm currently trying to install Papyrus Luna 1.0.0 to see if anything is missing further in the installation process, but so far so good.

Camille


Camille Letavernier
Re: Luna SR2 Papyrus Additional Components install problem [message #1650135 is a reply to message #1650110] Wed, 04 March 2015 17:38 Go to previous messageGo to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04-03-15 18:21, Camille Letavernier wrote:
> Quote:
>> b) it has no 1.0.0 or 1.0.1 content
>
>
> All 1.0.0, 1.0.1 (and 1.0.1.v201412... which is 1.0.1a) are present
> in this update site, as long as you uncheck "Show only the latest
> version". Sounds good to me.
For some reason I suspect that most people want to install the latest,
newest shiniest version....


This update site contains the 4 Luna releases for
> Papyrus Main + Extra, including binary and source builds (That's
> 4*2*2 installable features). The update site used by the Discovery
> Site is only a subset of this one, I.e.
> http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/extra
>
>
>
> And it was definitely not so slow a few days ago (e.g. when
> testing installation scenarios for SR2)
>
> I'm currently trying to install Papyrus Luna 1.0.0 to see if
> anything is missing further in the installation process, but so far
> so good.
I *really* would like to see a smooth "install newest version". I have
more than 40 students I have to talk through an installation of the
latest Papyrus.... 40 * 4*2*2 -1 possible errors....

TIA

Joost

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlT3Qv8ACgkQ0VJKUkHcX7/kQACeL6JcGLnSKSEVG1xnSfQ3EY9N
r1IAoJaALyYLNpLR+flwYRcyckKB9l2Z
=thE2
-----END PGP SIGNATURE-----


Cheers,

Joost
Re: Luna SR2 Papyrus Additional Components install problem [message #1650143 is a reply to message #1649878] Wed, 04 March 2015 17:42 Go to previous messageGo to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

>

> I will try to use "install new software" without Amalgan.

That installs SR1 also. Only an upgrade from SR1 seems to install SR2

Gr

joost
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlT3Q/IACgkQ0VJKUkHcX78BdQCfXI61E+GLBSzIj0N7rAJBefGo
lsQAoJJILXGTkN+T0bFnSQ4PY1vbt4zS
=JZT0
-----END PGP SIGNATURE-----


Cheers,

Joost
Re: Luna SR2 Papyrus Additional Components install problem [message #1650144 is a reply to message #1650110] Wed, 04 March 2015 17:43 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6796
Registered: July 2009
Senior Member
Hi

You're right.

OCL has fooled me. We have a long standing practice/bug of naming with
version, so the OCL-5.0.4 and OCL-5.0.3 are both 'most recent'.

Perhaps today's favourite mirror may also have an effect. Have you got
the p2.mirrorsURL right ? See

https://wiki.eclipse.org/OCL/Dev/Releng/Quiet_Week#Prepare_the_releases_p2_repository

I accidentally had a & / & error once and the consequences were bad
but hidden.

Regards

Ed

On 04/03/2015 17:21, Camille Letavernier wrote:
> Quote:
>> b) it has no 1.0.0 or 1.0.1 content
>
>
> All 1.0.0, 1.0.1 (and 1.0.1.v201412... which is 1.0.1a) are present in
> this update site, as long as you uncheck "Show only the latest
> version". Sounds good to me. This update site contains the 4 Luna
> releases for Papyrus Main + Extra, including binary and source builds
> (That's 4*2*2 installable features).
> The update site used by the Discovery Site is only a subset of this
> one, I.e.
> http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/extra
>
> And it was definitely not so slow a few days ago (e.g. when testing
> installation scenarios for SR2)
>
> I'm currently trying to install Papyrus Luna 1.0.0 to see if anything
> is missing further in the installation process, but so far so good.
>
> Camille
Re: Luna SR2 Papyrus Additional Components install problem [message #1650152 is a reply to message #1650135] Wed, 04 March 2015 17:47 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Quote:
I *really* would like to see a smooth "install newest version". I have
more than 40 students I have to talk through an installation of the
latest Papyrus.... 40 * 4*2*2 -1 possible errors....


Then http://download.eclipse.org/releases/luna is for you. Except that it is really sluggish right now (https://www.eclipse.org/forums/index.php/t/1025771/), and AFAIK there's nothing we (in the Papyrus project) can do about it.

BTW, the 4*2*2 options only happen if you explicitly uncheck "Show only latest version" (i.e. only if you are willingly looking for trouble). The default is 4 choices (Papyrus Main, Papyrus Extra, + sources), so the risk of failure is low (Installing everything will work)

If the discovery site, for some reason, doesn't work, then you can use these two update sites:

http://download.eclipse.org/releases/luna (Official Eclipse update site, contain Papyrus Main components)
http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/extra (Papyrus-specific update site, containing only Extra components)

HTH,
Camille


Camille Letavernier
Re: Luna SR2 Papyrus Additional Components install problem [message #1650193 is a reply to message #1650152] Wed, 04 March 2015 18:11 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Quote:
> I will try to use "install new software" without Amalgan.

That installs SR1 also. Only an upgrade from SR1 seems to install SR2


Installing Papyrus UML 1.0.2 from http://download.eclipse.org/releases/luna on top of Eclipse Modeling Package Luna SR2 works for me. However, installing it via "Install Modeling Components" gives me SR1 and I then need to "Check for updates" (At least that's what I got when I tried yesterday)

Camille


Camille Letavernier
Re: Luna SR2 Papyrus Additional Components install problem [message #1650202 is a reply to message #1650193] Wed, 04 March 2015 18:18 Go to previous messageGo to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04-03-15 19:11, Camille Letavernier wrote:
> Quote:
>>> I will try to use "install new software" without Amalgan.
>>
>> That installs SR1 also. Only an upgrade from SR1 seems to install
>> SR2
>
>
> Installing Papyrus UML 1.0.2 from
> http://download.eclipse.org/releases/luna on top of Eclipse
> Modeling Package Luna SR2 works for me. However, installing it via
> "Install Modeling Components" gives me SR1 and I then need to
> "Check for updates" (At least that's what I got when I tried
> yesterday)

I am currently installing Papyryus SR2 from
http://download.eclipse.org/releases/luna on top of the CDT-package
SR2. Then I have to figure out what my students have to select from
the "Install Modeling Components" to install the remainder. I don't
think that that will be a big deal. I just hope that the additional
Papyrus packages will go OK (Marte, realmtime, C++ generation). And
Xtend and OCL.

Gr

Joost

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlT3TI8ACgkQ0VJKUkHcX78RagCgoZMmsm0BHUVzromWvA9lJA8K
MjMAn0jqf3Urmi6ceA/RmH1wFtx/CLW8
=ZzyX
-----END PGP SIGNATURE-----


Cheers,

Joost
Re: Luna SR2 Papyrus Additional Components install problem [message #1650218 is a reply to message #1650202] Wed, 04 March 2015 18:28 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6796
Registered: July 2009
Senior Member
Hi

I have reported out-of-date issues for "Install Modeling Components" on
at least two previous occasions.

There is a really simple solution. Don't use it. "Install New
Software..." allows you to see what you are doing.

Regards

Ed Willink

On 04/03/2015 18:18, Joost Kraaijeveld wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> On 04-03-15 19:11, Camille Letavernier wrote:
>> Quote:
>>>> I will try to use "install new software" without Amalgan.
>>> That installs SR1 also. Only an upgrade from SR1 seems to install
>>> SR2
>>
>> Installing Papyrus UML 1.0.2 from
>> http://download.eclipse.org/releases/luna on top of Eclipse
>> Modeling Package Luna SR2 works for me. However, installing it via
>> "Install Modeling Components" gives me SR1 and I then need to
>> "Check for updates" (At least that's what I got when I tried
>> yesterday)
> I am currently installing Papyryus SR2 from
> http://download.eclipse.org/releases/luna on top of the CDT-package
> SR2. Then I have to figure out what my students have to select from
> the "Install Modeling Components" to install the remainder. I don't
> think that that will be a big deal. I just hope that the additional
> Papyrus packages will go OK (Marte, realmtime, C++ generation). And
> Xtend and OCL.
>
> Gr
>
> Joost
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1
>
> iEYEARECAAYFAlT3TI8ACgkQ0VJKUkHcX78RagCgoZMmsm0BHUVzromWvA9lJA8K
> MjMAn0jqf3Urmi6ceA/RmH1wFtx/CLW8
> =ZzyX
> -----END PGP SIGNATURE-----
Re: Luna SR2 Papyrus Additional Components install problem [message #1650241 is a reply to message #1650218] Wed, 04 March 2015 18:40 Go to previous message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04-03-15 19:28, Ed Willink wrote:
> Hi
>
> I have reported out-of-date issues for "Install Modeling
> Components" on at least two previous occasions.
>
> There is a really simple solution. Don't use it. "Install New
> Software..." allows you to see what you are doing.

Do you really think that solution is simple with *my* students ;-)?

I will write a detailed instruction.

Gr

Joost

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlT3UZgACgkQ0VJKUkHcX79zRgCfbm4onI1SduiEf1M6hU4uFOnH
6csAni9+oh94crsNWz1BJiOGZbZeZfn0
=NDHK
-----END PGP SIGNATURE-----


Cheers,

Joost
Previous Topic:How to add group of elements to diagram
Next Topic:UML Tutorial Diagram
Goto Forum:
  


Current Time: Wed Aug 12 09:29:13 GMT 2020

Powered by FUDForum. Page generated in 0.03071 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top