Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Problems with makefile when building static library
Problems with makefile when building static library [message #1827666] Wed, 20 May 2020 08:47
Apurva Patel is currently offline Apurva PatelFriend
Messages: 1
Registered: May 2020
Junior Member
Hello! I dont have any experience building static libraries so I am facing some problems. I am using open source code and I have to build the project to get the archive file. The project makefile includes a library.cfg file and creates a config.h file. I am using MinGW GCC toolchain and GNU make builder.

Build command:
make -f ${workspace_loc:/gateway/makefile}

I added the extra bit after make because I was getting "config.h: No such file or directory".

I added paths to both the main project and include folders for the include directories (under Properties > C/C++ General > Paths and Symbols). I also unchecked the "Generate Makefiles automatically" box (under Project Properties > C/C++ Build) However, I am getting the error "library.cfg: No such file or directory". I do not know what I am missing here. Help will be much appreciated.
Previous Topic:Full call stack
Next Topic:Qt integration with eclipse
Goto Forum:
  


Current Time: Wed May 27 22:42:41 GMT 2020

Powered by FUDForum. Page generated in 0.01890 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top