Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Error Connecting Oracle Team Productivity Center
Error Connecting Oracle Team Productivity Center [message #1591103] Thu, 29 January 2015 10:12 Go to next message
bunny new is currently offline bunny newFriend
Messages: 3
Registered: January 2015
Junior Member
Hi
In Job Configuration, Post Build Actions > Publish test results to Oracle Team Productivity Center ,
trying to connect OTPC server throws error -
interface alm.oracle.jawxs.test.tpctestservice.TPCTestService is not visible from class loader.

The HudsonTPCPlugin.hpi version is 1.3 which is generated while installing OTPC from oracle.However, searching in Plugin-Manager, 1.3 is only HudsonTpcPlugin.hpi available.

The current Hudson Server is 3.2.1. I don't want to downgrade Hudson to 2.1.0 to work with this HudsonTPCPlugin.hpi 1.3. Is there any workaround available to make it working ?

The HudsonTPCPlugin.hpi 1.3 Manifest file -
Manifest-Version: 1.0
Archiver-Version: Plexus Archiver
Created-By: Apache Maven
Built-By: ALMSERVER4$
Build-Jdk: 1.6.0_21
Extension-Name: HudsonTpcPlugin
Specification-Title: This plugin publishes the test results of a hudso
n build to the Oracle Team Productivity Center.
Specification-Vendor: Hudson
Implementation-Vendor: Hudson
Implementation-Title: HudsonTpcPlugin
Implementation-Version: 1.3
Group-Id: oracle.alminternal.test.collector
Short-Name: HudsonTpcPlugin
Long-Name: HudsonTpcPlugin
Url: (URL to Plugin)
Plugin-Version: 1.3
Hudson-Version: 2.1.0
Plugin-Developers:
Re: Error Connecting Oracle Team Productivity Center [message #1591122 is a reply to message #1591103] Thu, 29 January 2015 10:29 Go to previous message
Geoff Waymark is currently offline Geoff WaymarkFriend
Messages: 28
Registered: July 2012
Junior Member
This is a known issue, and the plugin owner is struggling to overcome a library mismatch.

It's filed here https://bugs.eclipse.org/bugs/show_bug.cgi?id=447574 in Eclipse Bugzilla. I've added your report to the bug.

As far as I'm aware there is no workaround as yet.


Geoff Waymark
Eclipse Hudson team
Previous Topic:3.1.2: StackOverflowError on creating/mod jobs
Next Topic:Recent Changes is not showing on Hudson Dashboard
Goto Forum:
  


Current Time: Wed Jun 28 14:22:29 GMT 2017

Powered by FUDForum. Page generated in 0.02288 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software