Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » can NOT install EGit because of m2e - Maven
can NOT install EGit because of m2e - Maven [message #1578625] Thu, 22 January 2015 14:12 Go to next message
Thomas Muhr is currently offline Thomas MuhrFriend
Messages: 1
Registered: January 2015
Junior Member
hello

can anyone tell me, how to fix this problem? i'm using eclipse 3.7.1. i'm not habe to install EGit

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Git Team Provider - Task focused interface 3.6.2.201501210735-r (org.eclipse.egit.mylyn.feature.group 3.6.2.201501210735-r)
Software currently installed: m2e - Maven Integration for Eclipse 1.0.100.20110804-1717 (org.eclipse.m2e.feature.feature.group 1.0.100.20110804-1717)
Only one of the following can be installed at once:
Team Support UI 3.5.100.I20100527-0800 (org.eclipse.team.ui 3.5.100.I20100527-0800)
Team Support UI 3.5.101.R36x_v20100825-0800 (org.eclipse.team.ui 3.5.101.R36x_v20100825-0800)
Team Support UI 3.6.101.R37x_v20111109-0800 (org.eclipse.team.ui 3.6.101.R37x_v20111109-0800)
Team Support UI 3.6.100.I20110525-0800 (org.eclipse.team.ui 3.6.100.I20110525-0800)
Team Support UI 3.5.102.R36x_v20110203-1036 (org.eclipse.team.ui 3.5.102.R36x_v20110203-1036)
Team Support UI 3.7.1.v20130729-1104 (org.eclipse.team.ui 3.7.1.v20130729-1104)
Team Support UI 3.5.0.I20090430-0408 (org.eclipse.team.ui 3.5.0.I20090430-0408)
Cannot satisfy dependency:
From: Eclipse Git Team Provider - Task focused interface 3.6.2.201501210735-r (org.eclipse.egit.mylyn.feature.group 3.6.2.201501210735-r)
To: org.eclipse.egit.mylyn.ui [3.6.2.201501210735-r]
Cannot satisfy dependency:
From: EGit Mylyn UI 3.6.2.201501210735-r (org.eclipse.egit.mylyn.ui 3.6.2.201501210735-r)
To: package org.eclipse.egit.ui [3.6.2,3.7.0)
Cannot satisfy dependency:
From: Git Team Provider UI 3.6.2.201501210735-r (org.eclipse.egit.ui 3.6.2.201501210735-r)
To: bundle org.eclipse.team.ui [3.6.200,4.0.0)
Cannot satisfy dependency:
From: m2e - Maven Integration for Eclipse 1.0.100.20110804-1717 (org.eclipse.m2e.feature.feature.group 1.0.100.20110804-1717)
To: org.eclipse.platform.feature.group 3.6.0
Cannot satisfy dependency:
From: Eclipse Platform 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY (org.eclipse.platform.feature.group 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
To: org.eclipse.team.ui [3.5.100.I20100527-0800]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)
To: org.eclipse.team.ui [3.5.101.R36x_v20100825-0800]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)
To: org.eclipse.team.ui [3.5.102.R36x_v20110203-1036]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f (org.eclipse.platform.feature.group 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f)
To: org.eclipse.team.ui [3.6.100.I20110525-0800]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK)
To: org.eclipse.team.ui [3.6.100.I20110525-0800]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
To: org.eclipse.team.ui [3.6.101.R37x_v20111109-0800]
Re: can NOT install EGit because of m2e - Maven [message #1579273 is a reply to message #1578625] Thu, 22 January 2015 22:31 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1133
Registered: July 2009
Senior Member
You can't install current EGit versions on Eclipse 3.7.x they require a newer version of the team api available in Eclipse version 3.8 and higher.
The last EGit version which supported Eclipse 3.7 is EGit 2.3.1.

Find the table of EGit versions and the platform versions they support here
https://wiki.eclipse.org/EGit/FAQ#What_versions_of_Eclipse_does_EGit_target.3F
Previous Topic:I'm having problems with CommitTimeRevFilter
Next Topic:How to upgrade EGit ?
Goto Forum:
  


Current Time: Fri Apr 10 09:55:07 GMT 2020

Powered by FUDForum. Page generated in 0.05043 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top