Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Copyright notice not generated
Copyright notice not generated [message #1507714] Thu, 11 December 2014 21:46 Go to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 381
Registered: March 2011
Senior Member
In order to generate a copyright notice at the top of the generated Java files, I understand that you have to set "Copyright Text" in the genmodel, but that doesn't seem to be working for me. The files are generated with an empty comment. If I set "Copyright Fields" to true, I do get the field with the appropriate text, but still nothing in the header. Am I missing something?

I'm on Mac OSX 10.9 Mavericks
Eclipse Version: Luna Service Release 1 (4.4.1)
Build id: 20140925-1800

with
EMF - Eclipse Modeling Framework SDK 2.10.2.v20141013-0308 org.eclipse.emf.sdk.feature.group Eclipse Modeling Project
Re: Copyright notice not generated [message #1508163 is a reply to message #1507714] Fri, 12 December 2014 06:55 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30449
Registered: July 2009
Senior Member
Maybe have a look at https://bugs.eclipse.org/bugs/show_bug.cgi?id=432853

There are definitely some short comings in this regard.


On 11/12/2014 10:46 PM, Ernesto Posse wrote:
> In order to generate a copyright notice at the top of the generated
> Java files, I understand that you have to set "Copyright Text" in the
> genmodel, but that doesn't seem to be working for me. The files are
> generated with an empty comment. If I set "Copyright Fields" to true,
> I do get the field with the appropriate text, but still nothing in the
> header. Am I missing something?
>
> I'm on Mac OSX 10.9 Mavericks
> Eclipse Version: Luna Service Release 1 (4.4.1)
> Build id: 20140925-1800
>
> with EMF - Eclipse Modeling Framework SDK
> 2.10.2.v20141013-0308 org.eclipse.emf.sdk.feature.group Eclipse
> Modeling Project
>
Re: Copyright notice not generated [message #1508663 is a reply to message #1508163] Fri, 12 December 2014 16:01 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 381
Registered: March 2011
Senior Member
Thanks. Is there any workaround?

I included the markers as suggested, but I get the same result.

<!-- begin-user-doc -->
My copyright
<!-- end-user-doc -->

Re: Copyright notice not generated [message #1508784 is a reply to message #1508663] Fri, 12 December 2014 18:16 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30449
Registered: July 2009
Senior Member
You noticed the part about merging not being supported? So only what's
generated the first time when the file doesn't yet exists will show up...

On 12/12/2014 5:01 PM, Ernesto Posse wrote:
> Thanks. Is there any workaround?
>
> I included the markers as suggested, but I get the same result.
>
> <!-- begin-user-doc -->
> My copyright
> <!-- end-user-doc -->
>
>
Previous Topic:How to create an EMF based form editor?
Next Topic:How to change ConstraintStatus severity
Goto Forum:
  


Current Time: Wed Sep 18 05:17:06 GMT 2019

Powered by FUDForum. Page generated in 0.01866 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top