Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Please help! Product export problem with ECP 1.5.0M2
Please help! Product export problem with ECP 1.5.0M2 [message #1495646] Tue, 02 December 2014 11:37 Go to next message
Christian Reuter is currently offline Christian ReuterFriend
Messages: 34
Registered: October 2010
Member
Hi,

I have lots of trouble exporting my product since I updated to version 1.5.0M2.

When I start my product in eclipse by using "Launch an eclipse application" in the product editor's "Overview" tab everything works just fine. However when I export the product and try to start it I keep getting the same problem.

The .product file which was working well with V. 1.4.x has been modified only by removing the 1.4.x features and adding the 1.5.0M2 features. Since then I always get the following error:

eclipse.buildId=unknown
java.version=1.7.0_71
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Framework arguments:  -profile=default -Djava.net.preferIPv4Stack=true
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -profile=default -Djava.net.preferIPv4Stack=true

!ENTRY org.eclipse.emf.ecp.application.e3 4 0 2014-12-02 12:10:52.574
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.ecp.application.e3 [130]
  Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.ui.e3; bundle-version="[1.4.0,2.0.0)"
    -> Bundle-SymbolicName: org.eclipse.emf.ecp.ui.e3; bundle-version="1.5.0.20141115-2220"; singleton:="true"
       org.eclipse.emf.ecp.ui.e3 [170]
         Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.ui; bundle-version="[1.4.0,2.0.0)"
           -> Bundle-SymbolicName: org.eclipse.emf.ecp.ui; bundle-version="1.5.0.20141115-2220"; singleton:="true"
              org.eclipse.emf.ecp.ui [169]
                Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.edit; bundle-version="[1.4.0,2.0.0)"
                  -> Bundle-SymbolicName: org.eclipse.emf.ecp.edit; bundle-version="1.5.0.20141115-2220"; singleton:="true"
                     org.eclipse.emf.ecp.edit [144]
                       Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.view.context; bundle-version="[1.4.0,2.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.emf.ecp.cdo.ui 4 0 2014-12-02 12:10:52.579
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.ecp.cdo.ui [134]
  Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.ui; bundle-version="[1.4.0,2.0.0)"
    -> Bundle-SymbolicName: org.eclipse.emf.ecp.ui; bundle-version="1.5.0.20141115-2220"; singleton:="true"
       org.eclipse.emf.ecp.ui [169]
         Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.edit; bundle-version="[1.4.0,2.0.0)"
           -> Bundle-SymbolicName: org.eclipse.emf.ecp.edit; bundle-version="1.5.0.20141115-2220"; singleton:="true"
              org.eclipse.emf.ecp.edit [144]
                Unresolved requirement: Require-Bundle: org.eclipse.emf.ecp.view.context; bundle-version="[1.4.0,2.0.0)"

.
.
.
(lots of similar error messages stating that org.eclipse.emf.ecp.view.context can not be resolved)


Obviously the bundle org.eclipse.emf.ecp.view.context can not be resolved.
Of course I triple-checked whteher the bundle is present in the exported plugins directory and it definately is (plugin org.eclipse.emf.ecp.view.context_1.5.0.20141115-2220.jar)!
I also ensured that there are no old versions floating araund. So for sure the 1.5.0 bundles (and only these) are present!

I tried all sorts of things but simply can not figure out why this dependency can not be resolved.

Any help is greatly appreciated!

I attached the .product file to this post. By the way I would also appreciate some tips on how to reduce the loads of features that seem to be required. I just kept adding features until no more problems were detected but that results in a very big package. My application includes the demo application with my own model and accesses emfstore as a client to persist the model.
It also contains a small custom feature which make some contributions to the demo application (copy+paste in context menu and a special validation which validates averything on every change).
Can anybody suggest how to find out the minimal feature list for this application.

Thx,

chris
Re: Please help! Product export problem with ECP 1.5.0M2 [message #1495843 is a reply to message #1495646] Tue, 02 December 2014 15:08 Go to previous message
Christian Reuter is currently offline Christian ReuterFriend
Messages: 34
Registered: October 2010
Member
OK - so finally I am a step further.
As it is often I have been chasing a ghost. The problem had nothing to do with the new version of ECP. It had been caused by another change I have made.

Version 1.4.x was working well however I received lots of error messages during startup saying that a bundle could not be loaded because it had already been loaded before.
Google told me that setting the property "org.eclipse.update.reconcile=false" would help with this problem which actually did remove these messages with version 1.4.x and everything was still working well.
I therefore set this property in my new product configuration for version 1.5.0M2 which in the end has caused all this trouble.
After removing this property and also all custom start level settings (which have been created automatically by eclipse) I can now start my exported product without any errors!

So never mind!

Sorry - I hope that nobody has spent any time on this already!

chris
Previous Topic:[EMFStore] registerEPackage of child class that has its abstract class in a different epackage
Next Topic:Edapt ecore migration with XSD/XML
Goto Forum:
  


Current Time: Sun Apr 05 04:59:32 GMT 2020

Powered by FUDForum. Page generated in 0.04388 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top