Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Workbench layout not saved between sessions(Window size and parts layout not saved between sessions)
Workbench layout not saved between sessions [message #1476671] Mon, 17 November 2014 08:50 Go to next message
Mihael Schmidt is currently offline Mihael SchmidtFriend
Messages: 81
Registered: August 2010
Member
Hi,

I have a pure e4 application and everytime I open the application I start with a fresh layout. The window size, visible parts, part sizes are not persisted between the sessions.

I haven't set -clearPersistedState.

I am calling workbench.close() in my QuitHandler.

The application is developed with the latest release of the Eclipse RCP package, 4.4 SR1.

Any idea what may trigger the new state of the layout everytime I start the application? Where should I look?

Thanx in advance.

Mihael
Re: Workbench layout not saved between sessions [message #1498190 is a reply to message #1476671] Thu, 04 December 2014 08:31 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Do you clear the workspace?

Best regards

Jonas

Am 17.11.2014 09:50, schrieb Mihael Schmidt:
> Hi,
>
> I have a pure e4 application and everytime I open the application I
> start with a fresh layout. The window size, visible parts, part sizes
> are not persisted between the sessions.
>
> I haven't set -clearPersistedState.
>
> I am calling workbench.close() in my QuitHandler.
>
> The application is developed with the latest release of the Eclipse RCP
> package, 4.4 SR1.
>
> Any idea what may trigger the new state of the layout everytime I start
> the application? Where should I look?
>
> Thanx in advance.
>
> Mihael


--
Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Workbench layout not saved between sessions [message #1498220 is a reply to message #1498190] Thu, 04 December 2014 08:57 Go to previous message
Mihael Schmidt is currently offline Mihael SchmidtFriend
Messages: 81
Registered: August 2010
Member
Hi,

I have found the problem. My project was created with an "early" version of the e4 application wizard which set the "clearPersistedState" property into the plugin.xml. I removed it and now it works.

http://wiki.rpgnextgen.com/doku.php?id=persisting_ui_state

Regards

Mihael
Previous Topic:Does ECP Support LOCALIZATION?
Next Topic:Eclipse RCP Themes .MToolBar.Draggable Problem.
Goto Forum:
  


Current Time: Thu Jan 28 16:37:53 GMT 2021

Powered by FUDForum. Page generated in 0.01621 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top