Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Problem launching OCL interpreter example
Problem launching OCL interpreter example [message #26373] Wed, 01 March 2006 15:50 Go to next message
Eclipse UserFriend
Originally posted by: aradzivanovich.gmail.com

I'm trying to play with OCL interpreter example, however I did not get
it working yet. I installed eclipse-SDK-3.2M5-win32,
emf-sdo-runtime-2.2.0M5, emft-ocl-SDK-1.0.0M5. When I launch eclipse I
cannot find OCL anywhere in the workbench. There are no errors in the
log, the configuration is given below. Could you please help me to
resolve this problem? Thanx.

*** Features:
org.eclipse.emf (2.2.0.v200602241148-25CBLxJKfw) "Eclipse Modeling
Framework (EMF)"
org.eclipse.emf.ecore.sdo (2.2.0.v200602241148--QIIAYAAMY) "EMF Service
Data Objects (SDO)"
org.eclipse.emf.ocl (1.0.0.v200602241417--644282258) "Eclipse Modeling
Framework Technology OCL Interpreter"
org.eclipse.emf.ocl.doc (1.0.0.v200602241417--644282258) "Eclipse
Modeling Framework Technology OCL Documentation"
org.eclipse.emf.ocl.examples (1.0.0.v200602241417--C995G55AG) "Eclipse
Modeling Framework Technology OCL Examples"
org.eclipse.emf.ocl.examples.source (1.0.0.v200602241417--C995G55AG)
"Eclipse Modeling Framework Technology (EMFT) OCL Examples Source"
org.eclipse.emf.ocl.source (1.0.0.v200602241417--644282258) "Eclipse
Modeling Framework Technology (EMFT) OCL Source"
org.eclipse.jdt (3.2.0.v20060215-1200-0cq-cuim1y) "Eclipse Java
Development Tools"
org.eclipse.jdt.source (3.2.0.v20060215-1200-0cq-cuim1y) "Eclipse Java
Development Tools SDK"
org.eclipse.pde (3.2.0.v20060210--qSWJzJJez) "Eclipse Plug-in
Development Environment"
org.eclipse.pde.source (3.2.0.v20060210--qSWJzJJez) "Eclipse Plug-in
Development Environment Developer Resources"
org.eclipse.platform (3.2.0.v20060215-6arkIf-1sI) "Eclipse Platform"
org.eclipse.platform.source (3.2.0.v20060215-6arkIf-1sI) "Eclipse
Platform Plug-in Developer Resources"
org.eclipse.rcp (3.2.0.v20060210-3BlARRhN5X) "Eclipse RCP"
org.eclipse.rcp.source (3.2.0.v20060210-3BlARRhN5X) "Eclipse RCP Plug-in
Developer Resources"
org.eclipse.sdk (3.2.0.v20060210--hQXJzJJez) "Eclipse Project SDK"

*** Plug-in Registry:
antlr (2.7.2) "ANTLR Plug-in" [Resolved]
com.ibm.icu (3.4.2) "International Components for Unicode for Java
(ICU4J)" [Resolved]
com.ibm.icu.source (3.4.2) "International Components for Unicode for
Java (ICU4J) source plug-in" [Resolved]
com.jcraft.jsch (0.1.18) "Jsch Plug-in" [Resolved]
org.apache.ant (1.6.5) "Apache Ant" [Resolved]
org.apache.lucene (1.4.103.v20051212) "Apache Lucene" [Resolved]
org.eclipse.ant.core (3.1.100.v20060216) "Ant Build Tool Core" [Resolved]
org.eclipse.ant.ui (3.2.0.v20060216a) "Ant UI" [Resolved]
org.eclipse.compare (3.2.0.v20060209) "Compare Support" [Resolved]
org.eclipse.core.boot (3.1.0.v20051108) "Core Boot" [Resolved]
org.eclipse.core.commands (3.2.0.I20060214-1600) "Commands" [Active]
org.eclipse.core.contenttype (3.2.0.v20060215a) "Eclipse Content
Mechanism" [Active]
org.eclipse.core.expressions (3.2.0.v20060215-1200) "Expression
Language" [Active]
org.eclipse.core.filebuffers (3.2.0.v20060215-1200) "File Buffers" [Active]
org.eclipse.core.filesystem (1.0.0.v20060206) "Core File Systems" [Resolved]
org.eclipse.core.filesystem.win32.x86 (1.0.0.v20051114) "Core File
System for Windows" [Resolved]
org.eclipse.core.jobs (3.2.0.v20060206) "Eclipse Jobs Mechanism" [Active]
org.eclipse.core.resources (3.2.0.v20060214) "Core Resource Management"
[Active]
org.eclipse.core.resources.compatibility (3.2.0.v20060123) "Core
Resource Management Compatibility Fragment" [Resolved]
org.eclipse.core.resources.win32 (3.2.0.v20060130) "Core Resource
Management Win32 Fragment" [Resolved]
org.eclipse.core.runtime (3.2.0.v20060216) "Core Runtime" [Active]
org.eclipse.core.runtime.compatibility (3.1.0.v20060123) "Core Runtime
Plug-in Compatibility" [Active]
org.eclipse.core.runtime.compatibility.registry (3.2.0.v20060215a)
"Eclipse Registry Compatibility Fragment" [Resolved]
org.eclipse.core.variables (3.1.100.v20060209) "Core Variables" [Resolved]
org.eclipse.debug.core (3.2.0.v20060216e) "Debug Core" [Active]
org.eclipse.debug.ui (3.2.0.v20060216e) "Debug UI" [Active]
org.eclipse.emf (2.2.0.v200602241148) "Eclipse Modeling Framework (EMF)"
[Resolved]
org.eclipse.emf.ant (2.2.0.v200602241148) "EMF Ant Tasks" [Resolved]
org.eclipse.emf.codegen (2.2.0.v200602241148) "EMF Template Code
Generator" [Resolved]
org.eclipse.emf.codegen.ecore (2.2.0.v200602241148) "EMF Ecore Code
Generation" [Resolved]
org.eclipse.emf.codegen.ecore.ui (2.2.0.v200602241148) "EMF Ecore Code
Generation UI" [Resolved]
org.eclipse.emf.codegen.ui (2.1.0.v200602241148) "EMF Template Code
Generator UI" [Resolved]
org.eclipse.emf.common (2.2.0.v200602241148) "EMF Common" [Resolved]
org.eclipse.emf.common.ui (2.2.0.v200602241148) "EMF Common UI" [Resolved]
org.eclipse.emf.commonj.sdo (2.1.0.v200602241148) "CommonJ SDO" [Resolved]
org.eclipse.emf.converter (2.2.0.v200602241148) "EMF Model Convert
Support" [Resolved]
org.eclipse.emf.ecore (2.2.0.v200602241148) "EMF Ecore" [Resolved]
org.eclipse.emf.ecore.change (2.2.0.v200602241148) "EMF Ecore Change
Model" [Resolved]
org.eclipse.emf.ecore.change.edit (2.1.0.v200602241148) "EMF Ecore
Change Edit Support" [Resolved]
org.eclipse.emf.ecore.edit (2.2.0.v200602241148) "EMF Ecore Edit
Support" [Resolved]
org.eclipse.emf.ecore.editor (2.2.0.v200602241148) "Sample Ecore Editor"
[Resolved]
org.eclipse.emf.ecore.sdo (2.2.0.v200602241148) "EMF Service Data
Objects (SDO)" [Resolved]
org.eclipse.emf.ecore.sdo.edit (2.1.0.v200602241148) "EMF Service Data
Objects (SDO) Edit Support" [Resolved]
org.eclipse.emf.ecore.sdo.editor (2.1.0.v200602241148) "EMF Service Data
Objects (SDO) Editor" [Resolved]
org.eclipse.emf.ecore.xmi (2.2.0.v200602241148) "EMF XMI" [Resolved]
org.eclipse.emf.edit (2.2.0.v200602241148) "EMF Edit" [Resolved]
org.eclipse.emf.edit.ui (2.2.0.v200602241148) "EMF Edit UI" [Resolved]
org.eclipse.emf.exporter (2.2.0.v200602241148) "EMF Model Export
Support" [Resolved]
org.eclipse.emf.importer (2.2.0.v200602241148) "EMF Model Import
Support" [Resolved]
org.eclipse.emf.importer.ecore (2.2.0.v200602241148) "EMF Ecore
Importer" [Resolved]
org.eclipse.emf.importer.java (2.2.0.v200602241148) "EMF Annotated Java
Importer" [Resolved]
org.eclipse.emf.importer.rose (2.2.0.v200602241148) "EMF Rose Importer"
[Resolved]
org.eclipse.emf.mapping (2.2.0.v200602241148) "EMF Mapping" [Resolved]
org.eclipse.emf.mapping.ecore2ecore (2.2.0.v200602241148) "Ecore to
Ecore Mapping" [Resolved]
org.eclipse.emf.mapping.ecore2ecore.editor (2.2.0.v200602241148) "Ecore
to Ecore Mapping Editor" [Resolved]
org.eclipse.emf.mapping.ecore2xml (2.2.0.v200602241148) "Ecore to XML
Mapping" [Resolved]
org.eclipse.emf.mapping.ecore2xml.ui (2.2.0.v200602241148) "Ecore to XML
Mapping UI" [Resolved]
org.eclipse.emf.mapping.ui (2.2.0.v200602241148) "EMF Mapping UI" [Resolved]
org.eclipse.emf.ocl (1.0.0.v200602241417) "Eclipse Modeling Framework
Technology OCL Interpreter" [Resolved]
org.eclipse.emf.ocl.doc (1.0.0.qualifier) "Eclipse Modeling Framework
Technology OCL Documentation" [Resolved]
org.eclipse.emf.ocl.examples (1.0.0.v200602241417) "Eclipse Modeling
Framework Technology OCL Examples" [Resolved]
org.eclipse.emf.ocl.examples.interpreter (1.0.0.v200602241417) "Eclipse
Modeling Framework Technology OCL Interpreter Example" [Resolved]
org.eclipse.emf.ocl.examples.source (1.0.0.v200602241417--C995G55AG)
"Eclipse Modeling Framework Technology (EMFT) OCL Examples Source"
[Resolved]
org.eclipse.emf.ocl.source (1.0.0.v200602241417--644282258) "Eclipse
Modeling Framework Technology (EMFT) OCL Source" [Resolved]
org.eclipse.equinox.common (1.0.0.v20060215a) "Common Eclipse Runtime"
[Active]
org.eclipse.equinox.preferences (1.0.0.v20060215a) "Eclipse Preferences
Mechanism" [Active]
org.eclipse.equinox.registry (3.2.0.v20060217) "Extension Registry
Support" [Active]
org.eclipse.help (3.2.0.v20060212) "Help System Core" [Active]
org.eclipse.help.appserver (3.1.100.v20051212) "Help Application Server"
[Resolved]
org.eclipse.help.base (3.2.0.v20060212) "Help System Base" [Resolved]
org.eclipse.help.ui (3.2.0.v20060212) "Help System UI" [Resolved]
org.eclipse.help.webapp (3.2.0.v20060212) "Help System Webapp" [Resolved]
org.eclipse.jdt (3.2.0.v20060216-0800) "Eclipse Java Development Tools"
[Resolved]
org.eclipse.jdt.apt.core (3.2.0.v20060214-2220) "Java Annotation
Processing Core" [Resolved]
org.eclipse.jdt.apt.ui (3.2.0.v20060214-2220) "Java Annotation
Processing UI" [Resolved]
org.eclipse.jdt.core (3.2.0.v_642) "Java Development Tools Core" [Active]
org.eclipse.jdt.core.manipulation (1.0.0.v20060215-1200) "Java Code
Manipulation Functionality" [Resolved]
org.eclipse.jdt.debug (3.2.0.v20060216d) "JDI Debug Model" [Resolved]
org.eclipse.jdt.debug.ui (3.2.0.v20060215b) "JDI Debug UI" [Resolved]
org.eclipse.jdt.doc.isv (3.2.0.v20060215-1200) "Eclipse JDT Plug-in
Developer Guide" [Resolved]
org.eclipse.jdt.doc.user (3.2.0.v20060215-1200) "Eclipse Java
Development User Guide" [Resolved]
org.eclipse.jdt.junit (3.2.0.v20060215-1200) "Java Development Tools
JUnit support" [Resolved]
org.eclipse.jdt.junit.runtime (3.2.0.v20060215-1200) "Java Development
Tools JUnit runtime support" [Resolved]
org.eclipse.jdt.launching (3.2.0.v20060210a) "Java Development Tools
Launching Support" [Active]
org.eclipse.jdt.source (3.2.0.v20060215-1200-0cq-cuim1y) "Eclipse Java
Development Tools SDK" [Resolved]
org.eclipse.jdt.ui (3.2.0.v20060217-1100) "Java Development Tools UI"
[Active]
org.eclipse.jface (3.2.0.I20060216-1600) "JFace" [Active]
org.eclipse.jface.databinding (3.2.0.I20060214-1600) "JFace Data
Binding" [Resolved]
org.eclipse.jface.text (3.2.0.v20060215-1200) "JFace Text" [Active]
org.eclipse.ltk.core.refactoring (3.2.0.v20060215-1200) "Refactoring
Core" [Active]
org.eclipse.ltk.ui.refactoring (3.2.0.v20060215-1200) "Refactoring UI"
[Active]
org.eclipse.osgi.services (3.1.100.v20060109) "OSGi Release 3 Services"
[Resolved]
org.eclipse.osgi.util (3.1.100.v20060109) "OSGi R3 Utility Classes"
[Resolved]
org.eclipse.pde (3.2.0.v20060213-1200) "Eclipse Plug-in Development
Environment" [Resolved]
org.eclipse.pde.build (3.2.0.v20060217) "Plug-in Development Environment
Build Support" [Resolved]
org.eclipse.pde.core (3.2.0.v20060217-0800) "Plug-in Development Core"
[Resolved]
org.eclipse.pde.doc.user (3.1.0.v20060216-1600) "Eclipse Plug-in
Development User Guide" [Resolved]
org.eclipse.pde.junit.runtime (3.2.0.v20060213-1200) "PDE JUnit Plug-in
Test" [Resolved]
org.eclipse.pde.runtime (3.2.0.v20060131) "Plug-in Development
Environment Runtime" [Resolved]
org.eclipse.pde.source (3.2.0.v20060210--qSWJzJJez) "Eclipse Plug-in
Development Environment Developer Resources" [Resolved]
org.eclipse.pde.ui (3.2.0.v20060216-1030) "Plug-in Development UI"
[Resolved]
org.eclipse.platform (3.2.0.v20060214-1600) "Eclipse Platform" [Resolved]
org.eclipse.platform.doc.isv (3.2.0.I20060217-1100) "Eclipse Platform
Plug-in Developer Guide" [Resolved]
org.eclipse.platform.doc.user (3.2.0.v20060213-0010) "Eclipse Workbench
User Guide" [Resolved]
org.eclipse.platform.source (3.2.0.v20060215-6arkIf-1sI) "Eclipse
Platform Plug-in Developer Resources" [Resolved]
org.eclipse.platform.source.win32.win32.x86 (3.2.0.v20060215-6arkIf-1sI)
"Eclipse Platform Plug-in Developer Resources" [Resolved]
org.eclipse.rcp (3.2.0.v20051206) "Eclipse RCP" [Resolved]
org.eclipse.rcp.source (3.2.0.v20060210-3BlARRhN5X) "Eclipse RCP Plug-in
Developer Resources" [Resolved]
org.eclipse.rcp.source.win32.win32.x86 (3.2.0.v20060210-3BlARRhN5X)
"Eclipse RCP Plug-in Developer Resources" [Resolved]
org.eclipse.sdk (3.2.0.v20060214) "Eclipse Project SDK" [Resolved]
org.eclipse.search (3.2.0.v20060217-1100) "Search Support" [Resolved]
org.eclipse.swt (3.2.0.v3224m) "Standard Widget Toolkit" [Resolved]
org.eclipse.swt.win32.win32.x86 (3.2.0.v3224) "Standard Widget Toolkit
for Windows" [Resolved]
org.eclipse.team.core (3.2.0.I200602141600) "Team Support Core" [Active]
org.eclipse.team.cvs.core (3.2.0.I200602161200) "CVS Team Provider Core"
[Resolved]
org.eclipse.team.cvs.ssh (3.2.0.I20051128) "CVS SSH Core" [Resolved]
org.eclipse.team.cvs.ssh2 (3.2.0.I200602161600) "CVS SSH2" [Resolved]
org.eclipse.team.cvs.ui (3.2.0.I200602170010) "CVS Team Provider UI"
[Resolved]
org.eclipse.team.ui (3.2.0.I200602170010) "Team Support UI" [Resolved]
org.eclipse.text (3.2.0.v20060215-1200) "Text" [Active]
org.eclipse.tomcat (4.1.130.v20060212) "Tomcat Wrapper" [Resolved]
org.eclipse.ui (3.2.0.I20060216-1600) "Eclipse UI" [Active]
org.eclipse.ui.browser (3.2.0.v20060212) "Browser Support" [Resolved]
org.eclipse.ui.cheatsheets (3.2.0.v20060212) "Cheat Sheets" [Resolved]
org.eclipse.ui.console (3.1.100.v20060214) "Console" [Resolved]
org.eclipse.ui.editors (3.2.0.v20060215-1200) "Default Text Editor" [Active]
org.eclipse.ui.externaltools (3.1.100.v20060206) "External Tools" [Active]
org.eclipse.ui.forms (3.2.0.v20060212b) "Eclipse Forms" [Resolved]
org.eclipse.ui.ide (3.2.0.I20060216-1200) "Eclipse IDE UI" [Active]
org.eclipse.ui.intro (3.2.0.v20060213) "Welcome Framework" [Resolved]
org.eclipse.ui.navigator (3.2.0.I20060210-0800) "Common Navigator View"
[Active]
org.eclipse.ui.navigator.resources (3.2.0.I20060210-0800) "Navigator
Workbench Components" [Active]
org.eclipse.ui.presentations.r21 (3.2.0.I20060207-0800) "R21
Presentation Plug-in" [Resolved]
org.eclipse.ui.views (3.2.0.I20060207-0800) "Views" [Active]
org.eclipse.ui.views.properties.tabbed (3.2.0.I20060213-2000) "Tabbed
Properties View" [Resolved]
org.eclipse.ui.win32 (3.2.0.I20060207-0800) "Eclipse UI Win32
Enhancements" [Resolved]
org.eclipse.ui.workbench (3.2.0.I20060216-1600) "Workbench" [Active]
org.eclipse.ui.workbench.compatibility (3.2.0.I20060207-0800) "Workbench
Compatibility" [Resolved]
org.eclipse.ui.workbench.texteditor (3.2.0.v20060216-0800) "Text Editor
Framework" [Active]
org.eclipse.update.configurator (3.1.100.v20051214) "Install/Update
Configurator" [Active]
org.eclipse.update.core (3.1.100.v20051215a) "Install/Update Core" [Active]
org.eclipse.update.core.win32 (3.1.100.v20051205) "Install/Update Core
for Windows" [Resolved]
org.eclipse.update.scheduler (3.1.100) "Automatic Updates Scheduler"
[Active]
org.eclipse.update.ui (3.1.100.v20051215) "Install/Update UI" [Resolved]
org.junit (3.8.1) "JUnit Testing Framework" [Resolved]
system.bundle (3.2.0.v20060214) "OSGi System Bundle" [Active]
Re: Problem launching OCL interpreter example [message #26412 is a reply to message #26373] Wed, 01 March 2006 17:29 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

Hi, Aliaksandr,

Did you install the antlr.jar library into the plugins/antlr_2.7.2/lib
folder according to the instructions in the plugins/antlr_2.7.2/README.txt
file? If you missed that file, I don't blame you; I don't think there's
any pointer to these special instructions on the download page.

However, in M6 we hope to port the parser off of ANTLR, so this procedure
should be obsolete then.

If you did install ANTLR, then you will see context menus related to OCL in
the editor for *.extlibrary models. To create an extlibrary resource,
choose the "File -> New -> Other..." main menu action and select the
"Example EMF Model Creation Wizards -> EXTLibrary Model" wizard. Follow
the steps (the most useful root element type is Library) to create the
file.

Now, you should see in the context menu of library elements in the resource
(not on the resource or resource set nodes) an "OCL" menu with an action to
open the interpreter console.

HTH,

Christian


Aliaksandr Radzivanovich wrote:

> I'm trying to play with OCL interpreter example, however I did not get
> it working yet. I installed eclipse-SDK-3.2M5-win32,
> emf-sdo-runtime-2.2.0M5, emft-ocl-SDK-1.0.0M5. When I launch eclipse I
> cannot find OCL anywhere in the workbench. There are no errors in the
> log, the configuration is given below. Could you please help me to
> resolve this problem? Thanx.

<snip>
Re: Problem launching OCL interpreter example [message #26450 is a reply to message #26412] Wed, 01 March 2006 19:32 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: aradzivanovich.gmail.com

Wow, that helped, thanks a lot.
Yes, the ANTLR runtime jar dependency is annoying.
Btw, what technology the new OCL parser will be based on? Will it be
JavaCC or something similar?

Christian W. Damus wrote:
> Hi, Aliaksandr,
>
> Did you install the antlr.jar library into the plugins/antlr_2.7.2/lib
> folder according to the instructions in the plugins/antlr_2.7.2/README.txt
> file? If you missed that file, I don't blame you; I don't think there's
> any pointer to these special instructions on the download page.
>
> However, in M6 we hope to port the parser off of ANTLR, so this procedure
> should be obsolete then.
>
> If you did install ANTLR, then you will see context menus related to OCL in
> the editor for *.extlibrary models. To create an extlibrary resource,
> choose the "File -> New -> Other..." main menu action and select the
> "Example EMF Model Creation Wizards -> EXTLibrary Model" wizard. Follow
> the steps (the most useful root element type is Library) to create the
> file.
>
> Now, you should see in the context menu of library elements in the resource
> (not on the resource or resource set nodes) an "OCL" menu with an action to
> open the interpreter console.
>
> HTH,
>
> Christian
>
>
> Aliaksandr Radzivanovich wrote:
>
>> I'm trying to play with OCL interpreter example, however I did not get
>> it working yet. I installed eclipse-SDK-3.2M5-win32,
>> emf-sdo-runtime-2.2.0M5, emft-ocl-SDK-1.0.0M5. When I launch eclipse I
>> cannot find OCL anywhere in the workbench. There are no errors in the
>> log, the configuration is given below. Could you please help me to
>> resolve this problem? Thanx.
>
> <snip>
Re: Problem launching OCL interpreter example [message #26482 is a reply to message #26450] Wed, 01 March 2006 22:25 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

I'm glad that worked.

The new parser will be an LALR parser with a BNF-style notation for the
grammar, derived from the Jikes project on SourceForge.

cW

Aliaksandr Radzivanovich wrote:

> Wow, that helped, thanks a lot.
> Yes, the ANTLR runtime jar dependency is annoying.
> Btw, what technology the new OCL parser will be based on? Will it be
> JavaCC or something similar?
>

<snip>
Re: Problem launching OCL interpreter example [message #26514 is a reply to message #26482] Thu, 02 March 2006 13:58 Go to previous message
Vishy Ramaswamy is currently offline Vishy RamaswamyFriend
Messages: 30
Registered: July 2009
Member
Hi All,
We are currently waiting for the Jikes team to get OSSC approval to include
the new Jikes LPG parser and source in to open source. Until that time the
OCL engine in EMFT will continue to depend on ANTLR. Once the Jikes parser
source and runtime are available in SourceForge we will be updating OCL
engine in EMFT to use the new parser

Thanks
Vishy

"Christian W. Damus" <cdamus@ca.ibm.com> wrote in message
news:du571h$4qe$1@utils.eclipse.org...
>
> I'm glad that worked.
>
> The new parser will be an LALR parser with a BNF-style notation for the
> grammar, derived from the Jikes project on SourceForge.
>
> cW
>
> Aliaksandr Radzivanovich wrote:
>
> > Wow, that helped, thanks a lot.
> > Yes, the ANTLR runtime jar dependency is annoying.
> > Btw, what technology the new OCL parser will be based on? Will it be
> > JavaCC or something similar?
> >
>
> <snip>
Re: Problem launching OCL interpreter example [message #570657 is a reply to message #26373] Wed, 01 March 2006 17:29 Go to previous message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

Hi, Aliaksandr,

Did you install the antlr.jar library into the plugins/antlr_2.7.2/lib
folder according to the instructions in the plugins/antlr_2.7.2/README.txt
file? If you missed that file, I don't blame you; I don't think there's
any pointer to these special instructions on the download page.

However, in M6 we hope to port the parser off of ANTLR, so this procedure
should be obsolete then.

If you did install ANTLR, then you will see context menus related to OCL in
the editor for *.extlibrary models. To create an extlibrary resource,
choose the "File -> New -> Other..." main menu action and select the
"Example EMF Model Creation Wizards -> EXTLibrary Model" wizard. Follow
the steps (the most useful root element type is Library) to create the
file.

Now, you should see in the context menu of library elements in the resource
(not on the resource or resource set nodes) an "OCL" menu with an action to
open the interpreter console.

HTH,

Christian


Aliaksandr Radzivanovich wrote:

> I'm trying to play with OCL interpreter example, however I did not get
> it working yet. I installed eclipse-SDK-3.2M5-win32,
> emf-sdo-runtime-2.2.0M5, emft-ocl-SDK-1.0.0M5. When I launch eclipse I
> cannot find OCL anywhere in the workbench. There are no errors in the
> log, the configuration is given below. Could you please help me to
> resolve this problem? Thanx.

<snip>
Re: Problem launching OCL interpreter example [message #570724 is a reply to message #26412] Wed, 01 March 2006 19:32 Go to previous message
Eclipse UserFriend
Originally posted by: aradzivanovich.gmail.com

Wow, that helped, thanks a lot.
Yes, the ANTLR runtime jar dependency is annoying.
Btw, what technology the new OCL parser will be based on? Will it be
JavaCC or something similar?

Christian W. Damus wrote:
> Hi, Aliaksandr,
>
> Did you install the antlr.jar library into the plugins/antlr_2.7.2/lib
> folder according to the instructions in the plugins/antlr_2.7.2/README.txt
> file? If you missed that file, I don't blame you; I don't think there's
> any pointer to these special instructions on the download page.
>
> However, in M6 we hope to port the parser off of ANTLR, so this procedure
> should be obsolete then.
>
> If you did install ANTLR, then you will see context menus related to OCL in
> the editor for *.extlibrary models. To create an extlibrary resource,
> choose the "File -> New -> Other..." main menu action and select the
> "Example EMF Model Creation Wizards -> EXTLibrary Model" wizard. Follow
> the steps (the most useful root element type is Library) to create the
> file.
>
> Now, you should see in the context menu of library elements in the resource
> (not on the resource or resource set nodes) an "OCL" menu with an action to
> open the interpreter console.
>
> HTH,
>
> Christian
>
>
> Aliaksandr Radzivanovich wrote:
>
>> I'm trying to play with OCL interpreter example, however I did not get
>> it working yet. I installed eclipse-SDK-3.2M5-win32,
>> emf-sdo-runtime-2.2.0M5, emft-ocl-SDK-1.0.0M5. When I launch eclipse I
>> cannot find OCL anywhere in the workbench. There are no errors in the
>> log, the configuration is given below. Could you please help me to
>> resolve this problem? Thanx.
>
> <snip>
Re: Problem launching OCL interpreter example [message #570758 is a reply to message #26450] Wed, 01 March 2006 22:25 Go to previous message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

I'm glad that worked.

The new parser will be an LALR parser with a BNF-style notation for the
grammar, derived from the Jikes project on SourceForge.

cW

Aliaksandr Radzivanovich wrote:

> Wow, that helped, thanks a lot.
> Yes, the ANTLR runtime jar dependency is annoying.
> Btw, what technology the new OCL parser will be based on? Will it be
> JavaCC or something similar?
>

<snip>
Re: Problem launching OCL interpreter example [message #570790 is a reply to message #26482] Thu, 02 March 2006 13:58 Go to previous message
Vishy Ramaswamy is currently offline Vishy RamaswamyFriend
Messages: 30
Registered: July 2009
Member
Hi All,
We are currently waiting for the Jikes team to get OSSC approval to include
the new Jikes LPG parser and source in to open source. Until that time the
OCL engine in EMFT will continue to depend on ANTLR. Once the Jikes parser
source and runtime are available in SourceForge we will be updating OCL
engine in EMFT to use the new parser

Thanks
Vishy

"Christian W. Damus" <cdamus@ca.ibm.com> wrote in message
news:du571h$4qe$1@utils.eclipse.org...
>
> I'm glad that worked.
>
> The new parser will be an LALR parser with a BNF-style notation for the
> grammar, derived from the Jikes project on SourceForge.
>
> cW
>
> Aliaksandr Radzivanovich wrote:
>
> > Wow, that helped, thanks a lot.
> > Yes, the ANTLR runtime jar dependency is annoying.
> > Btw, what technology the new OCL parser will be based on? Will it be
> > JavaCC or something similar?
> >
>
> <snip>
Previous Topic:Problem launching OCL interpreter example
Next Topic:Discovering transaction insertion point
Goto Forum:
  


Current Time: Sat Oct 01 09:20:31 GMT 2022

Powered by FUDForum. Page generated in 0.02161 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top