Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Eclipse Process Manager (Stardust) » Business Process Modeling Error(I can not implement the model as per "Creating Models" training video)
Business Process Modeling Error [message #1430975] Thu, 25 September 2014 04:00 Go to next message
Dan Cimpoesu is currently offline Dan CimpoesuFriend
Messages: 23
Registered: August 2014
Junior Member
Hi

When I try to connect "Manager Review" activity to "Process Request" activity I get the following error:

No further connection allowed to this activity.

I tried all sorts of things but I could not figure out why this is happening. For example I changed the activity type and settings. I also tried both with Chrome and Firefox. I also fully configured the transitions from gateway and I was able to deploy and execute the process. I tried new models etc.

Please see attached screen shot.

Please help.

Regards
Dan
Re: Business Process Modeling Error [message #1430990 is a reply to message #1430975] Thu, 25 September 2014 04:31 Go to previous messageGo to next message
Vishal Chaudhari is currently offline Vishal ChaudhariFriend
Messages: 9
Registered: October 2013
Junior Member
Hi Dan,

Any activity takes only one incoming connection. You have to model this using an XOR join before the process request activity. Please see the attached screenshot. I hope this helps.

Regards,
Vishal
  • Attachment: Join.png
    (Size: 15.31KB, Downloaded 149 times)
Re: Business Process Modeling Error [message #1431024 is a reply to message #1430990] Thu, 25 September 2014 05:41 Go to previous messageGo to next message
Dan Cimpoesu is currently offline Dan CimpoesuFriend
Messages: 23
Registered: August 2014
Junior Member
Hi Vishal

Is this a new feature? Please see attached the training video "Create Model" screenshot. According to the video a join is not necessary.

Also, if I am not wrong, in BPMN 2.0 a join is not necessary either. In BPMN 2.0 a join is implicit as far as I know.

Are there any settings for modeler that control this behavior?

Regards
Dan
Re: Business Process Modeling Error [message #1431066 is a reply to message #1431024] Thu, 25 September 2014 07:02 Go to previous messageGo to next message
Vishal Chaudhari is currently offline Vishal ChaudhariFriend
Messages: 9
Registered: October 2013
Junior Member
Dan,

This feature is not yet implemented and it is planned for future releases.

Meanwhile, can you please post the link to the video you referred in earlier post. We'll review and correct it if required.

Thanks, Vishal

[Updated on: Thu, 25 September 2014 07:16]

Report message to a moderator

Re: Business Process Modeling Error [message #1431174 is a reply to message #1431066] Thu, 25 September 2014 09:54 Go to previous message
Dan Cimpoesu is currently offline Dan CimpoesuFriend
Messages: 23
Registered: August 2014
Junior Member
Hi Vishal

It is very strange to see a live demo for a feature that is not yet implemented.

Here is the page with training videos:

https://www.eclipse.org/stardust/documentation/training-videos.php

If you go down the page please notice: Simple Browser Modeler Example (13 Minutes)
Learn how th Browser Modeler can be used alternatively to BPMN modeling in Eclipse.

https://www.eclipse.org/stardust/videos/Creating_Models.mov

Thanks for quick reply,

Regards
Dan
Previous Topic:Audit Trail support for MySql current version
Next Topic:Stardust offline donwload links no longer working
Goto Forum:
  


Current Time: Wed Sep 19 16:35:00 GMT 2018

Powered by FUDForum. Page generated in 0.02007 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top