Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Postgres Reference List update problem
[CDO] Postgres Reference List update problem [message #1426396] Thu, 18 September 2014 17:42 Go to next message
Per Sterner is currently offline Per SternerFriend
Messages: 91
Registered: October 2011
Member
We are using CDO with h2 and postgres.

With postgres I encountered sometimes problems with reference lists.

If you add some EObjects or remove some EObjects an exception like this may occur:

Batch-Eintrag 2 UPDATE MODEL1_PRODUCT1_ORDERDETAILS_LIST SET CDO_IDX=CDO_IDX+3 WHERE CDO_SOURCE=5 AND CDO_IDX BETWEEN 2 AND 5 /*! ORDER BY CDO_IDX DESC */ wurde abgebrochen.  Rufen Sie 'getNextException' auf, um die Ursache zu erfahren.


I have added a JUnit test with the problem.
Re: [CDO] Postgres Reference List update problem [message #1426777 is a reply to message #1426396] Fri, 19 September 2014 07:47 Go to previous messageGo to next message
Per Sterner is currently offline Per SternerFriend
Messages: 91
Registered: October 2011
Member
It seems postgres can't update with an order-flag, If this is the problem, here is a workaround:
http://stackoverflow.com/questions/16735950/update-with-order-by
Re: [CDO] Postgres Reference List update problem [message #1431150 is a reply to message #1426777] Thu, 25 September 2014 09:18 Go to previous messageGo to next message
Per Sterner is currently offline Per SternerFriend
Messages: 91
Registered: October 2011
Member
I'm sorry to refresh my topic, but with my CDO-Test workspace I have this problem and in real life too.

Should I try to make my own fix or could there be a workaround.

(In one situation I already replace the complete list instead of modifying it. Of course I want to remove this one.)
Re: [CDO] Postgres Reference List update problem [message #1434513 is a reply to message #1431150] Tue, 30 September 2014 07:29 Go to previous message
Per Sterner is currently offline Per SternerFriend
Messages: 91
Registered: October 2011
Member
I think it's really a bug. I opened a ticket:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=445443
Previous Topic:[Xcore] What is the advantage of "derived feature" from "operation"
Next Topic:[Xcore] overriding value of a superclass attribute
Goto Forum:
  


Current Time: Tue Nov 19 21:30:44 GMT 2019

Powered by FUDForum. Page generated in 0.01862 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top