Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » GlassFish integration to Eclipse Error(Getting error while installing glassfish server adapter in Eclipse)
GlassFish integration to Eclipse Error [message #1425227] Wed, 17 September 2014 02:35 Go to next message
John Waugh is currently offline John WaughFriend
Messages: 3
Registered: September 2014
Junior Member
Hi,
My intention is to integrate glassfish server in Eclipse, so that I can run some webservice applications.
But when I try to download additional server adapters and click on glassfish tool, it throws the below error:

Cannot complete the install because one or more required items could not be found.
Software being installed: GlassFish Tools 7.2.1.201407111426 (oracle.eclipse.tools.glassfish.feature.group 7.2.1.201407111426)
Missing requirement: GlassFish Tools 7.2.1.201407111426 (oracle.eclipse.tools.glassfish 7.2.1.201407111426) requires 'bundle org.eclipse.jdt.core [3.10.0,3.11.0)' but it could not be found
Cannot satisfy dependency:
From: GlassFish Tools 7.2.1.201407111426 (oracle.eclipse.tools.glassfish.feature.group 7.2.1.201407111426)
To: oracle.eclipse.tools.glassfish [7.2.1.201407111426]


Need some help to resolve this.
I am using Eclipse Mars JAVA EE version
Re: GlassFish integration to Eclipse Error [message #1453689 is a reply to message #1425227] Mon, 27 October 2014 10:20 Go to previous messageGo to next message
Valeriu Ohan is currently offline Valeriu OhanFriend
Messages: 1
Registered: October 2014
Junior Member
Hi,

I have a similar error when trying to install the Glassfish plugin for Eclipse Mars on Win 8.1 Pro 64 bit machine.

Cannot complete the install because of a conflicting dependency.
Software being installed: GlassFish Tools 7.3.0.201409251743 (oracle.eclipse.tools.glassfish.feature.group 7.3.0.201409251743)
Software currently installed: Eclipse IDE for Java EE Developers 4.5.0.20140927-1159 (epp.package.jee 4.5.0.20140927-1159)
Only one of the following can be installed at once:
Console 3.6.0.v20140728-1625 (org.eclipse.ui.console 3.6.0.v20140728-1625)
Console 3.5.300.v20140424-1437 (org.eclipse.ui.console 3.5.300.v20140424-1437)
Console 3.6.0.v20140812-1255 (org.eclipse.ui.console 3.6.0.v20140812-1255)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 4.5.0.20140927-1159 (epp.package.jee 4.5.0.20140927-1159)
To: org.eclipse.epp.package.jee.feature.feature.group [4.5.0.20140927-1159]
Cannot satisfy dependency:
From: GlassFish Tools 7.3.0.201409251743 (oracle.eclipse.tools.glassfish.feature.group 7.3.0.201409251743)
To: oracle.eclipse.tools.glassfish.ui [7.3.0.201409251743]
Cannot satisfy dependency:
From: GlassFish Tools UI 7.3.0.201409251743 (oracle.eclipse.tools.glassfish.ui 7.3.0.201409251743)
To: bundle org.eclipse.ui.console [3.5.300,3.6.0)
Cannot satisfy dependency:
From: EPP Java EE IDE Feature 4.5.0.20140927-1159 (org.eclipse.epp.package.jee.feature.feature.group 4.5.0.20140927-1159)
To: org.eclipse.platform.feature.group [4.5.0.v20140918-0330]
Cannot satisfy dependency:
From: Eclipse Platform 4.5.0.v20140918-0330 (org.eclipse.platform.feature.group 4.5.0.v20140918-0330)
To: org.eclipse.ui.console [3.6.0.v20140812-1255]
Re: GlassFish integration to Eclipse Error [message #1453765 is a reply to message #1425227] Mon, 27 October 2014 12:58 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
What this is telling you is that the Glassfish adapter you're trying to install is coded to specifically only work with Eclipse JDT 3.10.x - that's the version included in Eclipse Luna but I suspect Marts includes a later version of JDT. Is there another version of Glassfish adapter that is intended for use in Eclipse Mars?

John Waugh wrote on Wed, 17 September 2014 02:35
Hi,
My intention is to integrate glassfish server in Eclipse, so that I can run some webservice applications.
But when I try to download additional server adapters and click on glassfish tool, it throws the below error:

Cannot complete the install because one or more required items could not be found.
Software being installed: GlassFish Tools 7.2.1.201407111426 (oracle.eclipse.tools.glassfish.feature.group 7.2.1.201407111426)
Missing requirement: GlassFish Tools 7.2.1.201407111426 (oracle.eclipse.tools.glassfish 7.2.1.201407111426) requires 'bundle org.eclipse.jdt.core [3.10.0,3.11.0)' but it could not be found
Cannot satisfy dependency:
From: GlassFish Tools 7.2.1.201407111426 (oracle.eclipse.tools.glassfish.feature.group 7.2.1.201407111426)
To: oracle.eclipse.tools.glassfish [7.2.1.201407111426]


Need some help to resolve this.
I am using Eclipse Mars JAVA EE version

Previous Topic:Clean, Auto Build does not work
Next Topic:Self Teaching Resources Please
Goto Forum:
  


Current Time: Thu Oct 24 01:37:42 GMT 2019

Powered by FUDForum. Page generated in 0.02887 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top