Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » "GCC" not found in path(Error description!)
icon8.gif  "GCC" not found in path [message #1422203] Fri, 12 September 2014 13:40 Go to next message
Zaid Ahmed is currently offline Zaid AhmedFriend
Messages: 3
Registered: September 2014
Junior Member
index.php/fa/19114/0/

index.php/fa/19114/0/


HElp me! resolve this error!

The GNU arm tool chain has been added properly!
I did refer to various blogs and posts on this forum and am still left without a solution.
I kindly request the community to help me resolve this issue.

It would be of great help if i was provided with a step by step solution.
  • Attachment: Error.jpg
    (Size: 119.98KB, Downloaded 32358 times)
Re: "GCC" not found in path [message #1422255 is a reply to message #1422203] Fri, 12 September 2014 15:08 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Moving this to the CDT forum.
Re: "GCC" not found in path [message #1426415 is a reply to message #1422203] Thu, 18 September 2014 18:19 Go to previous messageGo to next message
Axel Mueller is currently offline Axel MuellerFriend
Messages: 1973
Registered: July 2009
Senior Member
Eclipse uses the compiler to get the builtin include paths and symbols. The default command is "gcc". You have to adapt it to your compiler.
More info can be found here:
https://wiki.eclipse.org/CDT/User/FAQ#I_am_using_a_non_gnu_compiler_and_I_get_the_following_messages:_.22Error_launching_external_scanner_info_generator_.28gcc_-E_-P_-v_-dD.22_and_.22File_not_indexed_because_it_was_not_built_.22._How_do_I_get_rid_of_them.3F
http://help.eclipse.org/luna/index.jsp?topic=%2Forg.eclipse.cdt.doc.user%2Fconcepts%2Fcdt_c_scanner_discovery.htm


Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: "GCC" not found in path [message #1440420 is a reply to message #1426415] Wed, 08 October 2014 10:42 Go to previous messageGo to next message
Cristobal Chaves is currently offline Cristobal ChavesFriend
Messages: 5
Registered: October 2014
Junior Member
Hi, I'm working with on-board computer in Eclipse C/C++ and I have some problems .Currently I added libraries necessary for the board used and libraries Arm, but the errors continue. These are the errors that I have currently. You have any idea what library I should add or do to make it work.

List of errors:

configTICK_RATE_HZ
xTaskWoken
xSemaphoreTake
xSemaphoreGive
xHigherPriorityTaskWoken
portTickType
portBASE_TYPE
portTICK_RATE_MS
port_MAX_DELAY
port_STACK_TYPE
portTickType
CSP_BASE_TYPE
CSP_MAX_DELAY


Thank you,
  • Attachment: errors.png
    (Size: 236.83KB, Downloaded 612 times)

[Updated on: Wed, 08 October 2014 10:43]

Report message to a moderator

Re: "GCC" not found in path [message #1744751 is a reply to message #1422203] Thu, 29 September 2016 22:22 Go to previous message
Albert Dawidczyk is currently offline Albert DawidczykFriend
Messages: 1
Registered: September 2016
Junior Member
This solution worked for me Wink

1) Make sure that you have a path to your GNU in your system variables.
To check it, go to Computer Properties > Advances System Settings > Environmental variables > in "User variables" you should get a "PATH" variable. Edit it, and check if there's a path to your GNU. If not, add it.

2) Go to Eclipse, Window > Properties > C/C++ > Build > Environment and check if you have a PATH variable there. It should have value of "${PATH} (which directs to your just set system variable) or just a path to your GNU. For me, setting it to the "${PATH}" value worked. Tick "Appendvariables to native environment" below.

3) Now go to Properties > C/C++ > Build > Settings > Discovery and find settings for your GNU (e.g. "CDT GCC Built-In Compiler Settings MinGW" as for me). To the compiler specs below the list add two paths. First to "gcc.exe" file in your GNU directory (e.g "C:\MinGW\bin\gcc.exe" for MinGW), second - to "g++.exe" in the same dir.

4) Apply all changes and it should work now.

However the errors still appear for me, but at least code gets started and works Wink
Previous Topic:Debugging arduino (samd) target
Next Topic:Paths and Symbols - relative shortfalls
Goto Forum:
  


Current Time: Wed Jan 19 12:09:20 GMT 2022

Powered by FUDForum. Page generated in 0.01390 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top