Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Sirius 1.0.1 Prevents Creation of New Ecore Modelling Projects(This problem is only with New Ecore Modelling Projects - Existing ecore projects ok)
Sirius 1.0.1 Prevents Creation of New Ecore Modelling Projects [message #1418225] Sat, 06 September 2014 18:54 Go to next message
Suleiman Shehu is currently offline Suleiman ShehuFriend
Messages: 5
Registered: August 2014
Junior Member
I have been been using Ecore Tools version 2 to create ecore models and using Sirius 1.0 to conduct the Sirius tutorial without any problems.

Then I updated Sirius to version 1.0.1. I found that when I then tried to create a new Ecore Modelling Project using the project wizard, that after the selection of the Viewpoints that the Ecore Modelling Wizard goes into an infinite loop and never completes the creation process. One never gets to the EcoreTools 2 class diagram to create an ecore model.

The only way to terminate the Wizard is to cancel the process.

Please note that existing Ecore Modelling projects with Ecore Tools 2 continue to work with Sirius 1.0.1 and to solve this problem I had to uninstall Sirius 1.0.1 and go back to Sirius 1.0.0.

My question is do I have a bug or have I missed something.

I had Ecore Tools 2.0 and Sirius 1.0 installed on Ubuntu (64) 14.04 with Eclipse Luna 4.4 Modelling Tools edition.

Many thanks
Suleiman Shehu
Re: Sirius 1.0.1 Prevents Creation of New Ecore Modelling Projects [message #1421365 is a reply to message #1418225] Thu, 11 September 2014 09:13 Go to previous message
Steve Monnier is currently offline Steve MonnierFriend
Messages: 470
Registered: May 2011
Senior Member
Hello,

I have just updated a new Eclipse Luna with Ecore Tools 2 from Sirius
1.0 to Sirius 1.0.1 (using the update site
http://download.eclipse.org/sirius/updates/releases/1.0.1/luna). I was
not able to reproduce your issue on the Ecore Modeling Project wizard,
it ended without any loop.
When you updated your Sirius version did you updated the 3 following
features:
- Sirius Core Runtime
- Sirius Runtime IDE
- Sirius Runtime Support for Acceleo 3

Regards,
Steve

Le 06/09/2014 20:54, Suleiman Shehu a écrit :
> I have been been using Ecore Tools version 2 to create ecore models and
> using Sirius 1.0 to conduct the Sirius tutorial without any problems.
>
> Then I updated Sirius to version 1.0.1. I found that when I then tried
> to create a new Ecore Modelling Project using the project wizard, that
> after the selection of the Viewpoints that the Ecore Modelling Wizard
> goes into an infinite loop and never completes the creation process. One
> never gets to the EcoreTools 2 class diagram to create an ecore model.
> The only way to terminate the Wizard is to cancel the process.
>
> Please note that existing Ecore Modelling projects with Ecore Tools 2
> continue to work with Sirius 1.0.1 and to solve this problem I had to
> uninstall Sirius 1.0.1 and go back to Sirius 1.0.0.
>
> My question is do I have a bug or have I missed something.
>
> I had Ecore Tools 2.0 and Sirius 1.0 installed on Ubuntu (64) 14.04 with
> Eclipse Luna 4.4 Modelling Tools edition.
>
> Many thanks
> Suleiman Shehu


--
Steve Monnier - Obeo

Need professional services for Sirius?
http://www.obeodesigner.com/sirius


Steve Monnier - Obeo
Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Previous Topic:Select view object after navigation
Next Topic:Creating Connectors for a UML Component like diagram
Goto Forum:
  


Current Time: Tue Apr 07 05:07:52 GMT 2020

Powered by FUDForum. Page generated in 0.01858 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top