Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Issues with Sirius interpreting my odesing file
Issues with Sirius interpreting my odesing file [message #1415285] Tue, 02 September 2014 13:51 Go to next message
Who Cares is currently offline Who CaresFriend
Messages: 6
Registered: July 2014
Junior Member
Hi,

I just encountered a few errors I cannot explain.

When I want to create a diagram in a modeling project (which previously worked) I see the diagram creation dialog but after that finishes the diagram does not show up. In the Eclipse error log I see that Sirius is trying to access an attribute of my Classes which fails (although it is part of the classes). Another thing is that the autocompletion inside my .odesign file only presents me the basic EMF stuff, like EContainer etc but not the attributes and relations which I added.
Also I can not select my Viewpoint in newly created project which is exactly the same as my first project (created by the same wizard) where I still have the viewpoint selected and can en/disable it.

Do you know what could be going wrong? I dont knowingly changed anything so I have no idea where this comes from.
Re: Issues with Sirius interpreting my odesing file [message #1415324 is a reply to message #1415285] Tue, 02 September 2014 14:44 Go to previous messageGo to next message
Alex Lagarde is currently offline Alex LagardeFriend
Messages: 193
Registered: May 2010
Senior Member

Hi,

this kind of issue may occur if you have your metamodel plugin opened in
the workspace and deployed in your Eclipse runtime in the same time.

Could you check this ? Otherwise, would you have additional information
allowing us to reproduce the issue ?

Regards,


Alex Morel (Lagarde) - Obeo

Need professional services for Sirius?
http://www.obeodesigner.com/sirius/
Re: Issues with Sirius interpreting my odesing file [message #1415359 is a reply to message #1415324] Tue, 02 September 2014 15:49 Go to previous message
Who Cares is currently offline Who CaresFriend
Messages: 6
Registered: July 2014
Junior Member
I think your guess was right, I temporarily checked out the metamodel to my workspace and then deleted it. After these hickups it started to work again for me. If I still see any errors I will try to reproduce them and report back. Thanks!
Previous Topic:How can Sirius interact with other systems
Next Topic:Migrating RCP application and extensions from GMF project
Goto Forum:
  


Current Time: Sat Apr 04 14:01:39 GMT 2020

Powered by FUDForum. Page generated in 0.01941 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top