Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Same searchParticipant for infocenter and workbench mode(try to use an own searchParticipant implementation for both modes, but only workbench is working)
Same searchParticipant for infocenter and workbench mode [message #1412899] Wed, 27 August 2014 10:17
alex pain is currently offline alex painFriend
Messages: 2
Registered: August 2014
Location: Berlin
Junior Member
Hello everybody,

i am trying to display my search results in the workbench mode and in the infocenter mode also. The documents which are the content of my help are no html documents, but in
the content producer i convert them to html. That works fine, but the search function can't index them, so i use the searchParticipant extension Point and have implemented my own help searchParticipant.
The help search participant is used to "index documents outside of the help system's TOC" and works fine for me in the workbench mode. But if i'm in the infocenter the search participant is never used.

Is the infocenter mode using another participant? Or is there an other extension point that i have to use?

EDIT: The headless mode of the extension point doesn't change anything, true or false, my search participant never is used

[Updated on: Tue, 02 September 2014 07:38]

Report message to a moderator

Previous Topic:Cheatsheet Extensibility support
Next Topic:Unable to aquire PluginConverter service when running Infocenter for the first time
Goto Forum:
  


Current Time: Thu Nov 23 04:02:36 GMT 2017

Powered by FUDForum. Page generated in 0.01793 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software