Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Problem with few steps in jubula(Steps like ub_app_prepareForAUTTermination does not execute on Windows 7)
Problem with few steps in jubula [message #1412853] Wed, 27 August 2014 08:29 Go to next message
Udita Sharma is currently offline Udita SharmaFriend
Messages: 1
Registered: August 2014
Junior Member
Hi all,

I successfully implemented the test steps to restart my rcp application.Although with little troubles as not all in-built restart test steps work properly.
I followed the below order to close and restart the application:

Close Application(Alt+F4) -> prepare for AUT termination -> synchronize termination and re-start of AUT.

When I executed the above test steps on my local machine(Windows Cool the test was successful, whereas when i executed the same test steps on the same application on remote desktop(Windows 7); the test was stuck at prepare for AUT Termination.

I am not sure about the reason which is causing this test failure. Can any body please help me to figure this out.

I have also attached my AUT Agent logs.

Thanks in advance.

  • Attachment: AUT_logs.txt
    (Size: 2.65KB, Downloaded 72 times)
Re: Problem with few steps in jubula [message #1413246 is a reply to message #1412853] Thu, 28 August 2014 06:30 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1371
Registered: July 2009
Senior Member
Hi,

It looks like you have the order of the actions wrong. In the reference manual, it says about the prepare for termination action "Use this action shortly before an action in your test that will cause the AUT to shutdown." For the synchronize shutdown action, "Use this action sometime after using the prepare for termination action, and directly after the action to close the AUT . "

So your order should be:
Prepare for AUT termination -> ALT F4 -> Synchronize termination and re-start.

Hope that helps,
Alex
Previous Topic:Problem with new action in component Application
Next Topic:How to wait for an background job to finish?
Goto Forum:
  


Current Time: Sat Aug 29 06:27:30 GMT 2015

Powered by FUDForum. Page generated in 0.01490 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software