Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Highlighting problem
Highlighting problem [message #1410643] Thu, 21 August 2014 09:15 Go to next message
John Xmas is currently offline John XmasFriend
Messages: 2
Registered: August 2014
Junior Member
Hi,

I'm having a problem with lexical highlighting. I wrote my IHighlightingConfiguration
and my tokenMapper and bound them to my UIModule.

The problem is the following: highlighting only occurs when I open my editor. If
I enter a token, it does not get hihlighted. If I use content assist, the token is highlighted, but the highlight disappears as I got on typing.

Any help would be appreciated

Relevant infos:
Eclipse:
Version: Kepler Service Release 1
Build id: 20130919-0819
Xtext:
Version 2.5.1.v201402030714
Re: Highlighting problem [message #1410759 is a reply to message #1410643] Thu, 21 August 2014 14:49 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13280
Registered: July 2009
Senior Member
Hi,

did you adapt semantic highlighting as well?


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Highlighting problem [message #1410774 is a reply to message #1410759] Thu, 21 August 2014 15:28 Go to previous messageGo to next message
John Xmas is currently offline John XmasFriend
Messages: 2
Registered: August 2014
Junior Member
Hi,

No, just lexical highlighting
Re: Highlighting problem [message #1410776 is a reply to message #1410774] Thu, 21 August 2014 15:34 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13280
Registered: July 2009
Senior Member
hi,

maybe your grammar is a bit too ambigous ..


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:[Eugenia/Xtext] Make the diagram generate formatted code
Next Topic:formatting/serializing of optional attributes
Goto Forum:
  


Current Time: Sun Dec 15 12:25:56 GMT 2019

Powered by FUDForum. Page generated in 0.01893 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top