Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » WindowBuilder and EMF Databinding(Option not available)
WindowBuilder and EMF Databinding [message #1409936] Tue, 19 August 2014 10:47 Go to next message
Davide Da Lio is currently offline Davide Da LioFriend
Messages: 7
Registered: August 2014
Location: Munich
Junior Member
Hi everybody.

I am new to Windowbuilder and EMF and i am having some troubles with emf databinding.

I have a view part with a TableViewer. When i click on the last and i choose bindings > input i don't see the option to select EMF but there is only the "Beans" option.

What am i doing wrong? Ho can i bind to my EMF model and operate trough Windowbuilder?

Thanks
Re: WindowBuilder and EMF Databinding [message #1410167 is a reply to message #1409936] Wed, 20 August 2014 02:05 Go to previous messageGo to next message
Eric Clayberg is currently offline Eric ClaybergFriend
Messages: 979
Registered: July 2009
Location: Boston, MA
Senior Member
According to the WB docs... "additional EMF binding type is available when EMF projects/model objects are detected."
Re: WindowBuilder and EMF Databinding [message #1410636 is a reply to message #1409936] Thu, 21 August 2014 09:03 Go to previous messageGo to next message
Davide Da Lio is currently offline Davide Da LioFriend
Messages: 7
Registered: August 2014
Location: Munich
Junior Member
yep!

Looks like that my problems was that i am using a data model modeled with a specific version of EMF (the latest). After that i have some other local bundles imported locally that are modeled with another version of EMF.

The system doesn't recognized EMF and WindowBuilder doesn't show the option accordingly. If I take away my model the option is available.

Thanks for the reply
Re: WindowBuilder and EMF Databinding [message #1416230 is a reply to message #1410636] Thu, 04 September 2014 16:25 Go to previous messageGo to next message
Marina Knieling is currently offline Marina KnielingFriend
Messages: 83
Registered: February 2013
Member
Same problem here. I'm using EMF 2.10 and WindowBuilder doesn't show the
EMF button on the bindings tab although an EMF generated Object is
present in the code. Is this a known bug or shall I raise one? Would you
recommend using an older version of EMF in the meantime?

Marina Knieling

On 21.08.2014 11:03, Davide Da Lio wrote:
> yep!
>
> Looks like that my problems was that i am using a data model modeled
> with a specific version of EMF (the latest). After that i have some
> other local bundles imported locally that are modeled with another
> version of EMF.
>
> The system doesn't recognized EMF and WindowBuilder doesn't show the
> option accordingly. If I take away my model the option is available.
>
> Thanks for the reply
Re: WindowBuilder and EMF Databinding [message #1417634 is a reply to message #1416230] Fri, 05 September 2014 20:30 Go to previous message
Eric Clayberg is currently offline Eric ClaybergFriend
Messages: 979
Registered: July 2009
Location: Boston, MA
Senior Member
No idea w/o a test case.

I doubt it's a bug though. Could be a feature request, if you are using a newer version of EMF than WB supports.
Previous Topic:JGoodies FormLayout - Which version is supported?
Next Topic:Can WindowBuilder be use for gtkmm projects?
Goto Forum:
  


Current Time: Sun Jul 12 00:24:33 GMT 2020

Powered by FUDForum. Page generated in 0.02064 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top