Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Executing external command always returns 0 but command is not executed
Executing external command always returns 0 but command is not executed [message #1409628] Mon, 18 August 2014 15:15 Go to next message
Vlastimil Havrila is currently offline Vlastimil HavrilaFriend
Messages: 2
Registered: August 2014
Junior Member
I am starting to use external commands in my application and I wanted to start with something easy to test if the command is executed. I have created ".cmd" file that I want jubula to run (attachment). This file is located in: "c:\test\" and is named test.cmd. So I created an "execute external command" test case in jubula with command: "C:\\test\\test.cmd" and expected return code 0.The path is correct because when you enter incorrect path the test would fail. My problem is the opposite: The test will succeed but the file test.txt that this command batch should delete is still there. I tried creating new directories through external commands and it did not work neither.

Could you please let me know what might be the problem? Thanks.
  • Attachment: test.cmd
    (Size: 0.03KB, Downloaded 28 times)
Re: Executing external command always returns 0 but command is not executed [message #1409633 is a reply to message #1409628] Mon, 18 August 2014 15:23 Go to previous messageGo to next message
Achim Loerke is currently offline Achim LoerkeFriend
Messages: 364
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

Something like "cd C:\dir" will not change the drive the program uses. There is some option that makes "cd" also change the drive.

And as you may have guessed, that is not a Jubula problem Wink

- Achim
Re: Executing external command always returns 0 but command is not executed [message #1409898 is a reply to message #1409633] Tue, 19 August 2014 08:47 Go to previous message
Vlastimil Havrila is currently offline Vlastimil HavrilaFriend
Messages: 2
Registered: August 2014
Junior Member
Thanks. I thought I did not have to specify the drive if jubula is on the same one.
Previous Topic:Jubula sometimes loses the connection to the AUT
Next Topic:Zip-file extension-toolkit-rc.zip
Goto Forum:
  


Current Time: Thu Sep 03 19:36:23 GMT 2015

Powered by FUDForum. Page generated in 0.05655 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software