Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » RCP looks on linux
RCP looks on linux [message #1409531] Mon, 18 August 2014 10:52 Go to next message
Christian Pontesegger is currently offline Christian PonteseggerFriend
Messages: 220
Registered: July 2009
Location: Graz, Austria
Senior Member
I always wondered, why RCPs started right from eclipse look so damn ugly on linux. When launching a default RCP from eclipse on a fresh workspace I would expect that the RCP would have similar looks than the running eclipse instance.

But icon backgrounds are greyish on a white toolbar (eg outline view). Cursors in input boxes are not visible and there are many things more.

I know there are issues with GTK2/GTK3 and the installed themes. But if my Eclipse IDE figures out how to ender correctly, why can't my RCP?

Is there a way to configure the launcher to make my RCP look like the IDE?
Re: RCP looks on linux [message #1409564 is a reply to message #1409531] Mon, 18 August 2014 12:11 Go to previous messageGo to next message
Marcel Austenfeld is currently offline Marcel AustenfeldFriend
Messages: 156
Registered: July 2009
Senior Member
Hello Christian,

i had the same problem and embedded the org.eclipse.ui.themes in my RCP.
That should work for the default OS look and feel.

Later i began to create my on theme upon that plugin definition (On Windows it still looked bad with my special RCP which contains complex view menus, etc.).

Re: RCP looks on linux [message #1409590 is a reply to message #1409564] Mon, 18 August 2014 13:33 Go to previous messageGo to next message
Christian Pontesegger is currently offline Christian PonteseggerFriend
Messages: 220
Registered: July 2009
Location: Graz, Austria
Senior Member
What about running it via launch configuration right from the IDE? I have o.e.ui.themes included in my launch configuration, but that does not improve the L&F
Re: RCP looks on linux [message #1410312 is a reply to message #1409590] Wed, 20 August 2014 11:46 Go to previous messageGo to next message
Marcel Austenfeld is currently offline Marcel AustenfeldFriend
Messages: 156
Registered: July 2009
Senior Member
Hello Christian,


I added the plugin to my required plugins in my main RCP plugin and then in the launch configuration selected the plugin, too.

I tested it again with the rcp mail template and it works under Windows.

In your RCP preferences (if active in your RCP) the theme selection menu should be available.

I will test it later under Linux, too.

[Updated on: Wed, 20 August 2014 11:47]

Report message to a moderator

Re: RCP looks on linux [message #1410430 is a reply to message #1410312] Wed, 20 August 2014 19:17 Go to previous messageGo to next message
Christian Pontesegger is currently offline Christian PonteseggerFriend
Messages: 220
Registered: July 2009
Location: Graz, Austria
Senior Member
I just updated the target platform from kepler to juno and now the UI looks fine.
The problem arised when I changed my dev IDE to juno, while my target platform was still kepler-based. I admit, I do not understand why the problem is gone now, but as long as it works, I am happy Smile
Re: RCP looks on linux [message #1410593 is a reply to message #1410430] Thu, 21 August 2014 06:45 Go to previous message
Marcel Austenfeld is currently offline Marcel AustenfeldFriend
Messages: 156
Registered: July 2009
Senior Member
Hello Christian,

good to hear. I tested it yesterday with Linux and everything worked fine, too.


Previous Topic:Running exported E4 app outside of it's directory causes widgets lacking
Next Topic:Can't key bind an action!!!
Goto Forum:
  


Current Time: Thu Jan 21 08:39:09 GMT 2021

Powered by FUDForum. Page generated in 0.01486 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top