Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Ecore Tools » Opening .ecorediagram diagrams in Luna??
icon4.gif  Opening .ecorediagram diagrams in Luna?? [message #1405809] Fri, 08 August 2014 08:25 Go to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 30
Registered: April 2012
Member
Hello,

We are currently migrating our tools suite to the Luna release. Part of it are numerous .ecorediagram files. Is there any way to open these diagrams in Luna. Recreating these diagrams would be a lot of work, which blocks us in migrating to Luna.

Great that a new (better) tool is created to create new ecore-diagrams. But how about support for the old users out of the box:
- A way to open the old editors, that is, .ecorediagram files, and/or
- Migration of old diagrams to the new editor.

Kind regards,
Rolf

[Updated on: Mon, 11 August 2014 06:27]

Report message to a moderator

Re: Opening .ecorediagram diagrams in Luna?? [message #1407295 is a reply to message #1405809] Tue, 12 August 2014 09:21 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 30
Registered: April 2012
Member
Installing version 1.2.0 of ecore tools from the update site
http://download.eclipse.org/modeling/emft/ecoretools/updates/1.2/201306071421, results in the following error:

Cannot complete the install because of a conflicting dependency.
Software being installed: Diagram Editor for Ecore 1.2.0.201306071421 (org.eclipse.emf.ecoretools.feature.group 1.2.0.201306071421)
Software currently installed: Ecore Diagram Editor (SDK) 2.0.0.201406112035 (org.eclipse.emf.ecoretools.sdk.feature.group 2.0.0.201406112035)
Only one of the following can be installed at once:
Ecore Tools Documentation 2.0.0.201406112035 (org.eclipse.emf.ecoretools.doc 2.0.0.201406112035)
Ecore Tools Documentation 1.2.0.201306071421 (org.eclipse.emf.ecoretools.doc 1.2.0.201306071421)
Cannot satisfy dependency:
From: Diagram Editor for Ecore 1.2.0.201306071421 (org.eclipse.emf.ecoretools.feature.group 1.2.0.201306071421)
To: org.eclipse.emf.ecoretools.doc [1.2.0.201306071421]
Cannot satisfy dependency:
From: Ecore Diagram Editor (SDK) 2.0.0.201406112035 (org.eclipse.emf.ecoretools.sdk.feature.group 2.0.0.201406112035)
Re: Opening .ecorediagram diagrams in Luna?? [message #1407297 is a reply to message #1405809] Tue, 12 August 2014 09:25 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 30
Registered: April 2012
Member
Running the current head from git in Luna does allow open the .ecorediagram files, although the editor is not registered for the .ecorediagram files:
To open the files:

Open With > Other ... > Ecore Diagram Editor

Can somebody release a version of the 1.2 tool version that is compatible with the installed 2.0 version, such that both can be used in parallel?
Re: Opening .ecorediagram diagrams in Luna?? [message #1407304 is a reply to message #1407297] Tue, 12 August 2014 09:40 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 30
Registered: April 2012
Member
Installing from the 2.0.0 update site includes an option to install the legacy 1.2 component:

http://download.eclipse.org/ecoretools/updates/releases/2.0.0/luna

A note on the FAQ would have been helpful.

[Updated on: Tue, 12 August 2014 09:51]

Report message to a moderator

Re: Opening .ecorediagram diagrams in Luna?? [message #1691269 is a reply to message #1407304] Sat, 04 April 2015 10:10 Go to previous messageGo to next message
Emil Peric is currently offline Emil PericFriend
Messages: 7
Registered: February 2015
Junior Member
Hi Rolf, i think i have a solution for migrating ecorediag to aird.

Create a new Eclipse modeling project in Eclipse Luna then import your old project with ecorediag models in Eclipse Luna.

In the new Eclipse Modeling project open the ecore file (double click on it) and it opens in the panel. Right click on it and chose Load resources, chose "From workspace" and navigate to the old Eclipse project and chose the ecorediag file you want to migrate.

Now you will have in the panel two ecore files, the new one and the old one.

Just drag and drop all the classes from the old one to the new one.

After that open the diagram panel and chose on the Palette "Add" it will open a window from where you can chose the newly imported classes, just mark them all and they will populate the diagram.

You will loos all the elements positions but all the relations would be there.

Be aware if you have lots of elements ( i have few hundreds) the diagram navigation will be very slow.

Hope it helps.
Opening .ecorediagram diagrams in Mars [message #1707018 is a reply to message #1407304] Tue, 01 September 2015 14:36 Go to previous messageGo to next message
Juan  omínguez is currently offline Juan omínguezFriend
Messages: 12
Registered: July 2009
Junior Member
Hi.

I've downloaded the new Eclipse 4.5 modeling distribution, and the 1.2 legacy component repackaged for Mars is not available.

Was this made on purpose?
Re: Opening .ecorediagram diagrams in Mars [message #1714405 is a reply to message #1707018] Thu, 12 November 2015 12:54 Go to previous message
Cedric Brun is currently offline Cedric BrunFriend
Messages: 430
Registered: July 2009
Senior Member
Indeed, this was removed and has been announced one year in advance through :
https://dev.eclipse.org/mhonarc/lists/cross-project-issues-dev/msg10946.html after a deprecation declared during the Luna release : https://projects.eclipse.org/projects/modeling.emft.ecoretools/releases/2.0.0

It is still available from the older releases though.


http://cedric.brun.io news and articles on eclipse and eclipse modeling.
Previous Topic:Accessing external meta-models and code generation
Next Topic:How to use compile-time annotations in ECore model without introducing runtime dependency
Goto Forum:
  


Current Time: Wed Nov 14 17:26:02 GMT 2018

Powered by FUDForum. Page generated in 0.02068 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top