Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse can't find JVM
Eclipse can't find JVM [message #1405721] Fri, 08 August 2014 03:15 Go to next message
Bob Wakefield is currently offline Bob WakefieldFriend
Messages: 8
Registered: August 2014
Junior Member
This is a common problem but I can't find a solution for my specific case. I was running an old version of Eclipse and it just stopped working saying it could not find the JVM after I downloaded a new JRE today.

At this point, I've downloaded the latest Eclipse and the latest JDK. When I run Eclipse I get:

No java virtual machine was found after searching the following locations: C:\Program Files (x86)\eclipse\jre\bin\javaw.exe.

The location of that file is actually in another folder and I've tried updating the .ini file to fix it but to no avail. Javaw.exe is in:
C:\Program Files (x86)\Java\jdk1.8.0_11\bin

This is what my ini file looks like unaltered:
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20140603-1326
-product
org.eclipse.epp.package.standard.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.7
-Xms40m
-Xmx512m

(For some odd reason, the file is all one line on my computer. When I pasted it here I get line breaks. Weird.)
Re: Eclipse can't find JVM [message #1405798 is a reply to message #1405721] Fri, 08 August 2014 07:56 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3518
Registered: July 2009
Senior Member

You are trying to use a 64-bit Eclipse with a 32-bit Java. They have to match. Most web browsers on Windows are still 32-bit, so it may be in your interest to switch to a 32-bit Eclipse.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse can't find JVM [message #1405814 is a reply to message #1405798] Fri, 08 August 2014 08:40 Go to previous message
Bob Wakefield is currently offline Bob WakefieldFriend
Messages: 8
Registered: August 2014
Junior Member
Yeah I figured it out. The (x86) threw me off when I went to download the JDK. Fixed now.
Previous Topic:how to use org.eclipse.core.resources methods
Next Topic:Console..
Goto Forum:
  


Current Time: Wed Oct 23 16:07:12 GMT 2019

Powered by FUDForum. Page generated in 0.02992 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top