Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Xtend installation without Xtext(Missing feature in Luna update site; errors building intro examples)
Xtend installation without Xtext [message #1404776] Tue, 05 August 2014 16:50
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 382
Registered: March 2011
Senior Member
Hello. I've installed Xtend 2.6.2 SDK alone, without installing Xtext, and I noticed something strange. When I tried installing it with the Luna update site (http://download.eclipse.org/releases/luna it installed the plugins, but it didn't show any features under "Installation Details". However, when I installed it (on a fresh workspace) using the TMF update site (http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/), it did show the Xtend SDK feature. Furthermore, in the first case there where no UI contributions (no New>Other...>Xtend Class, no right-click->Configure->Add Xtext Nature).

Also, when creating the project with Introductory examples I get errors in all the examples, unable to resolve many symbols because two required bundles are missing:

- org.eclipse.xtext.xbase.lib;bundle-version="2.6.2",
- org.eclipse.xtend.lib;bundle-version="2.6.2",

However, both bundles are installed (they show up under Installation Details) with the correct versions. Furthermore, when I create a new Xtend project and I get the same error, clicking on the error and selecting "Add Xtend libs to classpath" works and gets rid of the errors, but when I try to do the same in the xtend-examples project it doesn't work and the errors remain. Now, if I edit xtend-examples/META_INF/MANIFEST.MF and change the minimum version for both dependencies from 2.6.2 to 2.6.0, the errors go away. But this is quite bizarre, as the Installation details window shows that I do have 2.6.2!

So I have a few questions:

1) why doesn't the installation from the Luna update site show the feature?
2) why is there a discrepancy between the Luna update site and the TMF update site?
3) why do I get all those errors with xtend-examples?
4) why does it work after changing the version number even though I have the right one?
5) why doesn't "Add Xtend libs to classpath" work for the xtend-examples project but works for others?
6) is there any way to make the "New...>Xtend XYZ" options available directly under the New context menu without having to open New...>Other..." (when I install the full Xtext I get those options in the New menu).

Thanks

Previous Topic:Does mwe2 require Java 1.7?
Next Topic:Does your MWE2 workflow consume a lot of memory?
Goto Forum:
  


Current Time: Sat Dec 14 16:37:00 GMT 2019

Powered by FUDForum. Page generated in 0.01781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top