Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Automated Testing via Scheduled Task. Autrun.exe not starting
Automated Testing via Scheduled Task. Autrun.exe not starting [message #1404761] Tue, 05 August 2014 14:35 Go to next message
s dongen is currently offline s dongenFriend
Messages: 3
Registered: August 2014
Junior Member
Hey there,

after countless tries to fix my Problems i thought to seek for help.
I have created multiple tests for jubula and automated them via a Batch file. I managed to successfully finish my tests via remote control on another machine. to alleviate the missing desktop issue with remote control i used vmware. But now i am facing a very strange problem. On an irregular basis i either can or cannot start my application via autrun.exe.


A) What i am trying to achieve:

1) Login to a VM with user with admin privileges
2) TeamCity build Agent Triggers a Scheduled Task on the VM.
3) Scheduled Task in said VM executes a Batch script.

Batch Script:
4)start autAgent : start "" "C:\Program Files\jubula_8.0.00170\server\autagent.exe" and wait for it to be running
5)start application via autrun:
"C:\Program Files\jubula_8.0.00170\server\autrun.exe" -swing -w "C:\bla" -a "localhost" -p "60000" -i "AUTMyAUT" -e "C:\bla\start_myAut.cmd"
5.1) start_myAut.cmd -> java -jar .\java\myJar.jar localtesting jnp://my.local:1599
5) execute my tests:
start /WAIT "" "C:\Program Files\jubula_8.0.00170\jubula\testexec.exe" -autconfig "bla@localhost" -data "C:\Users\jubula\workspace" -datadir "C:\Users\jubula\workspace" -dbpw "pw" -dbscheme "myDB" -dbuser "myUser" -language "en EN" -port "60000" -project "myProj" -resultdir "C:\bla\tests" -server "localhost" -testjob "FullPreTest" -version "1.0"

6)stop the aut Agent:
start "" "C:\Program Files\jubula_8.0.00170\server\stopautagent.exe"

B)Occuring Problem:
during 5) the new cmd-console will open but nothing will happen. The Problem takes place often but not always. After rebooting the VM it often works a few times, but then it stops working. Once or twice i got it to work again after some time had passed without logging the Windows user out.
When the Problem takes place i cant close the cmd-console, and i cant close it via Task Manager either ("Access denied" message).

i tried (among others)
- deactivating uac
- run as admin manually
- highest privileges with admin user
- with new console vs in the Batch console itself
- powershell script instead of Batch script (similar behaviour, working initially then not anymore)
- deleting temp files

Any hint or help would be greatly appreciated!
Thanks in advance.
Re: Automated Testing via Scheduled Task. Autrun.exe not starting [message #1405111 is a reply to message #1404761] Wed, 06 August 2014 16:02 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1371
Registered: July 2009
Senior Member
Hi there,

This is new to me. I'm aware that there can be racing conditions when autrun tries to start before the server (AUT Agent) is running. Maybe someone else in the forum will have an idea.

Best regards,
Alex
Re: Automated Testing via Scheduled Task. Autrun.exe not starting [message #1405375 is a reply to message #1405111] Thu, 07 August 2014 07:57 Go to previous messageGo to next message
s dongen is currently offline s dongenFriend
Messages: 3
Registered: August 2014
Junior Member
Thanks for your reply!

I'm not sure if the racing conditions apply in my case. Between every step described above i wait for a longer period ("ping -n 60 127.0.0.1 > NUL"). The autagent Icon appears in the tray after around 20 seconds

Also tried to replace all 'localhost' with 127.0.0.1 to ensure ipv4 is returned.

I guess i'll add:
using:
- jubula_8.0.00170
- Windows 8.1
- Java 1.7 v65
Re: Automated Testing via Scheduled Task. Autrun.exe not starting [message #1410614 is a reply to message #1405375] Thu, 21 August 2014 07:53 Go to previous message
s dongen is currently offline s dongenFriend
Messages: 3
Registered: August 2014
Junior Member
nobody having an idea?
Previous Topic:How to check which Tabbed Component is currently active?
Next Topic:Openoffice Excel and date issues
Goto Forum:
  


Current Time: Mon Aug 31 19:55:01 GMT 2015

Powered by FUDForum. Page generated in 0.08584 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software